aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-04 03:30:26 +0800
committerpgj <pgj@FreeBSD.org>2012-06-04 03:30:26 +0800
commit5765e4e759be5f65f6089ef58cd937b9faec1620 (patch)
treecc85aa8d5ed87f41aaeeff0ff5654c793caab268 /www
parent4675ddfc7f29e0caa87b185eb4cb14e9f9a32e82 (diff)
downloadfreebsd-ports-gnome-5765e4e759be5f65f6089ef58cd937b9faec1620.tar.gz
freebsd-ports-gnome-5765e4e759be5f65f6089ef58cd937b9faec1620.tar.zst
freebsd-ports-gnome-5765e4e759be5f65f6089ef58cd937b9faec1620.zip
This package uses attoparsec for parsing the actual contents of the HTTP
connection. It also provides higher-level functions which allow you to avoid direct usage of enumerators. WWW: http://www.yesodweb.com/book/http-conduit Obtained from: FreeBSD Haskell
Diffstat (limited to 'www')
-rw-r--r--www/hs-http-conduit/Makefile28
-rw-r--r--www/hs-http-conduit/distinfo2
-rw-r--r--www/hs-http-conduit/pkg-descr5
3 files changed, 35 insertions, 0 deletions
diff --git a/www/hs-http-conduit/Makefile b/www/hs-http-conduit/Makefile
new file mode 100644
index 000000000000..567cb406f071
--- /dev/null
+++ b/www/hs-http-conduit/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: hs-http-conduit
+# Date created: December 30, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= http-conduit
+PORTVERSION= 1.4.1.7
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= HTTP client package with conduit interface and HTTPS support
+
+LICENSE= BSD
+
+USE_CABAL= asn1-data>=0.5.1 attoparsec>=0.8.0.2 attoparsec-conduit>=0.4 \
+ base64-bytestring>=0.1 blaze-builder>=0.2.1 \
+ blaze-builder-conduit>=0.4 case-insensitive>=0.2 \
+ certificate>=1.2 conduit>=0.4.1 cookie>=0.4 cprng-aes>=0.2 \
+ data-default>=0.3 failure>=0.1 http-types>=0.6 \
+ lifted-base>=0.1 monad-control>=0.3 mtl network>=2.3 \
+ regex-compat resourcet>=0.3 socks>=0.4 text tls>=0.9.3 \
+ tls-extra>=0.4.5 transformers>=0.2 transformers-base>=0.4 \
+ utf8-string>=0.3.4 void>=0.5.5 zlib-conduit>=0.4
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-http-conduit/distinfo b/www/hs-http-conduit/distinfo
new file mode 100644
index 000000000000..c440d02bdf9c
--- /dev/null
+++ b/www/hs-http-conduit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/http-conduit-1.4.1.7.tar.gz) = 4e0818e07db84b5f9eb2ff6846e6929f730c0ed0280359a4e760e8e107f8712c
+SIZE (cabal/http-conduit-1.4.1.7.tar.gz) = 26778
diff --git a/www/hs-http-conduit/pkg-descr b/www/hs-http-conduit/pkg-descr
new file mode 100644
index 000000000000..21537ebdde93
--- /dev/null
+++ b/www/hs-http-conduit/pkg-descr
@@ -0,0 +1,5 @@
+This package uses attoparsec for parsing the actual contents of the HTTP
+connection. It also provides higher-level functions which allow you to
+avoid direct usage of enumerators.
+
+WWW: http://www.yesodweb.com/book/http-conduit