aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-20 22:15:41 +0800
committerpav <pav@FreeBSD.org>2005-07-20 22:15:41 +0800
commit5d98f7bc71678c6c4dd2347438be2362c7318690 (patch)
tree18d8071f810e98fe5aac943153b336f6cf09167c /www
parent1697a39204a5dc97e3eea81b5034cc064fa706a5 (diff)
downloadfreebsd-ports-gnome-5d98f7bc71678c6c4dd2347438be2362c7318690.tar.gz
freebsd-ports-gnome-5d98f7bc71678c6c4dd2347438be2362c7318690.tar.zst
freebsd-ports-gnome-5d98f7bc71678c6c4dd2347438be2362c7318690.zip
Typo is an absolutely minimal weblogging engine powered by rails. It
supports XMLRPC posting, ping/trackback, comments, textile, categories, all common exports, fulltext search and so on. PR: ports/82397 Submitted by: Jonathan Weiss <jw@innerewut.de>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/typo/Makefile33
-rw-r--r--www/typo/distinfo2
-rw-r--r--www/typo/pkg-descr13
4 files changed, 49 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 079f9c67aa55..ebae9abdf30b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -770,6 +770,7 @@
SUBDIR += twhttpd
SUBDIR += twig
SUBDIR += twiki
+ SUBDIR += typo
SUBDIR += typo3
SUBDIR += udmsearch
SUBDIR += ump
diff --git a/www/typo/Makefile b/www/typo/Makefile
new file mode 100644
index 000000000000..730dff139692
--- /dev/null
+++ b/www/typo/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: www/typo
+# Date created: May 29th 2005
+# Whom: Jonathan Weiss <jw@innerewut.det>
+#
+# $FreeBSD$
+#
+
+PORTNAME= typo
+PORTVERSION= 2.0.6
+CATEGORIES= www
+MASTER_SITES= http://rubyforge.org/frs/download.php/4205/
+
+MAINTAINER= jw@innerewut.de
+COMMENT= An absolutely minimal weblogging engine powered by rails
+
+RUN_DEPENDS= rails:${PORTSDIR}/www/rubygem-rails \
+ ${LOCALBASE}/lib/ruby/gems/1.8/specifications/RedCloth-3.0.3.gemspec:${PORTSDIR}/www/rubygem-redcloth
+
+NO_BUILD= yes
+
+TYPODIR= www/${DISTNAME}
+
+do-install:
+ ${CP} -R ${WRKSRC} ${PREFIX}/${TYPODIR}
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${TYPODIR}
+
+post-install:
+ @${FIND} ${PREFIX}/${TYPODIR} -not -type d \
+ | ${SED} -ne 's,^${PREFIX}/,,p' >> ${TMPPLIST}
+ @${FIND} -d ${PREFIX}/${TYPODIR} -type d \
+ | ${SED} -ne 's,^${PREFIX}/${TYPODIR},@dirrm ${TYPODIR},p' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/www/typo/distinfo b/www/typo/distinfo
new file mode 100644
index 000000000000..2d540146e55e
--- /dev/null
+++ b/www/typo/distinfo
@@ -0,0 +1,2 @@
+MD5 (typo-2.0.6.tar.gz) = cc965db3ab5c0e027c769c48144bb941
+SIZE (typo-2.0.6.tar.gz) = 88522
diff --git a/www/typo/pkg-descr b/www/typo/pkg-descr
new file mode 100644
index 000000000000..5d6df0eab5a4
--- /dev/null
+++ b/www/typo/pkg-descr
@@ -0,0 +1,13 @@
+Typo is an absolutely minimal weblogging engine powered by rails. It
+supports XMLRPC posting, ping/trackback, comments, textile, categories,
+all common exports, fulltext search and so on.
+
+Typo makes it fast and easy to weblog, enabling posting through a rich
+desktop client application like MarsEdit or ecto (see below for a
+compatible clients list). A web-based administration interface handles
+configuration and management.
+
+WWW: http://typo.leetsoft.com/
+
+- Jonathan Weiss
+jw@innerewut.de