aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-02-24 07:16:57 +0800
committeredwin <edwin@FreeBSD.org>2003-02-24 07:16:57 +0800
commit5eebc4b9b7581605cc46739f7122702c3b0d5dfa (patch)
tree04b47bab3e185ff9458996696f9a98c51b7257c8 /www
parent10051e59dc97a9f35f8e92c06ebebcdba27de33e (diff)
downloadfreebsd-ports-gnome-5eebc4b9b7581605cc46739f7122702c3b0d5dfa.tar.gz
freebsd-ports-gnome-5eebc4b9b7581605cc46739f7122702c3b0d5dfa.tar.zst
freebsd-ports-gnome-5eebc4b9b7581605cc46739f7122702c3b0d5dfa.zip
[Maintainer Update] Port: php-templates 1.7
Update to 1.7 Install documentation Use new WANT_AUTO****_VER variables Adapt to new mod_php4 port Fix installation with Apache2 PR: ports/47905 Submitted by: Alex Dupre <sysadmin@alexdupre.com>
Diffstat (limited to 'www')
-rw-r--r--www/php-templates/Makefile30
-rw-r--r--www/php-templates/distinfo3
-rw-r--r--www/php-templates/pkg-message2
-rw-r--r--www/php-templates/pkg-plist7
4 files changed, 28 insertions, 14 deletions
diff --git a/www/php-templates/Makefile b/www/php-templates/Makefile
index c0528a41939e..b20c5da18f44 100644
--- a/www/php-templates/Makefile
+++ b/www/php-templates/Makefile
@@ -6,45 +6,53 @@
#
PORTNAME= php-templates
-PORTVERSION= 1.4
+PORTVERSION= 1.7
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= php_templates-${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+.if !defined(NOPORTDOCS)
+DISTFILES+= php_templates-doc-eng-1.1${EXTRACT_SUFX}
+.endif
MAINTAINER= sysadmin@alexdupre.com
COMMENT= A template framework for PHP
-BUILD_DEPENDS= aclocal:${PORTSDIR}/devel/automake \
- autoconf:${PORTSDIR}/devel/autoconf \
- phpize:${PORTSDIR}/www/mod_php4
+BUILD_DEPENDS= phpize:${PORTSDIR}/www/mod_php4
RUN_DEPENDS= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13 \
- ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+ ${LOCALBASE}/bin/php:${PORTSDIR}/www/mod_php4
USE_LIBTOOL= yes
-USE_REINPLACE= yes
+WANT_AUTOMAKE_VER= 15
+WANT_AUTOCONF_VER= 253
WRKSRC= ${WRKDIR}/templates
CONFIGURE_ARGS= --enable-templates=shared \
--with-php-config=${PREFIX}/bin/php-config
+EXT_DIR= 20020429
+PLIST_SUB= EXT_DIR=${EXT_DIR}
+
PKGMESSAGE= ${WRKDIR}/pkg-message
post-extract:
- @${REINPLACE_CMD} -e 's/[[:cntrl:]]$$//' ${WRKSRC}/php_templates.h \
- ${WRKSRC}/templates.c ${WRKSRC}/tmpl_lib.c
@${ECHO_MSG} "===> PHPizing for ${DISTNAME}"
@cd ${WRKSRC} && ${LOCALBASE}/bin/phpize
post-build:
- @${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g;s|%%PREFIX%%|${PREFIX}|g" \
+ @${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g;s|%%PREFIX%%|${PREFIX}|g;s|%%EXT_DIR%%|${EXT_DIR}|g" \
${.CURDIR}/pkg-message > ${PKGMESSAGE}
do-install:
- @${MKDIR} ${PREFIX}/lib/php/extensions
+ @${MKDIR} ${PREFIX}/lib/php/${EXT_DIR}
@${INSTALL_DATA} ${WRKSRC}/modules/templates.so \
- ${PREFIX}/lib/php/extensions
+ ${PREFIX}/lib/php/${EXT_DIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}-doc/* ${DOCSDIR}
+.endif
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/www/php-templates/distinfo b/www/php-templates/distinfo
index 258fe18aa6dc..cb99444323c4 100644
--- a/www/php-templates/distinfo
+++ b/www/php-templates/distinfo
@@ -1 +1,2 @@
-MD5 (php_templates-1.4.tar.gz) = 0b7505b57a8eb3aec59df6217699d1f9
+MD5 (php_templates-1.7.tar.gz) = 3c06e17a7477a87baac224046a70163c
+MD5 (php_templates-doc-eng-1.1.tar.gz) = ee553f0a1e6dc0b08a1d5a7cd6368c22
diff --git a/www/php-templates/pkg-message b/www/php-templates/pkg-message
index edd4bbb1b95f..d3fafeacfce1 100644
--- a/www/php-templates/pkg-message
+++ b/www/php-templates/pkg-message
@@ -4,6 +4,6 @@ You have installed the php-templates package.
Edit %%LOCALBASE%%/etc/php.ini and add:
-extension="%%PREFIX%%/lib/php/extensions/templates.so"
+extension="%%PREFIX%%/lib/php/%%EXT_DIR%%/templates.so"
*****************************************************************************
diff --git a/www/php-templates/pkg-plist b/www/php-templates/pkg-plist
index c6087436d3cc..6c07b73a3ec4 100644
--- a/www/php-templates/pkg-plist
+++ b/www/php-templates/pkg-plist
@@ -1 +1,6 @@
-lib/php/extensions/templates.so
+lib/php/%%EXT_DIR%%/templates.so
+%%PORTDOCS%%share/doc/php-templates/CHANGELOG
+%%PORTDOCS%%share/doc/php-templates/php_templates-eng.html
+%%PORTDOCS%%share/doc/php-templates/php_templates.css
+@unexec rmdir %D/lib/php/%%EXT_DIR%% 2> /dev/null || true
+%%PORTDOCS%%@dirrm share/doc/php-templates