aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-05 06:57:37 +0800
committeredwin <edwin@FreeBSD.org>2002-11-05 06:57:37 +0800
commit64a5e0f37f47ca9274d3cc6633ed687cc7dc23ca (patch)
tree664d2ba6932861fa84d22c638a1035a3fcd6a962 /www
parent8d98f5042d9d3f5d1c76b52d1826c997af60472d (diff)
downloadfreebsd-ports-gnome-64a5e0f37f47ca9274d3cc6633ed687cc7dc23ca.tar.gz
freebsd-ports-gnome-64a5e0f37f47ca9274d3cc6633ed687cc7dc23ca.tar.zst
freebsd-ports-gnome-64a5e0f37f47ca9274d3cc6633ed687cc7dc23ca.zip
Half of these ones missed yesterday while converting to USE_REINPLACE.
The other half needs perl to build. Noticed on bento and others (full mailbox :-)
Diffstat (limited to 'www')
-rw-r--r--www/knowledgekit/Makefile3
-rw-r--r--www/squid/Makefile2
-rw-r--r--www/squid25/Makefile2
-rw-r--r--www/squid26/Makefile2
-rw-r--r--www/squid27/Makefile2
-rw-r--r--www/squid30/Makefile2
-rw-r--r--www/squid31/Makefile2
-rw-r--r--www/znavigator/Makefile4
8 files changed, 17 insertions, 2 deletions
diff --git a/www/knowledgekit/Makefile b/www/knowledgekit/Makefile
index 5e63d1c3b053..f1ba0a8dcc8c 100644
--- a/www/knowledgekit/Makefile
+++ b/www/knowledgekit/Makefile
@@ -16,6 +16,7 @@ MAINTAINER= nbm@FreeBSD.org
RUN_DEPENDS= ${LOCALBASE}/${SZOPEBASEDIR}/z2.py:${PORTSDIR}/www/zope
+USE_REINPLACE= yes
NO_BUILD= YES
PKGMESSAGE= ${WRKDIR}/.MESSAGE
@@ -34,7 +35,7 @@ PLIST_SUB= ZOPEBASEDIR=${SZOPEBASEDIR}
do-install:
@${CP} ${WRKSRC}/* \
${ZOPEBASEDIR}/import
- @perl -pe 's#%%PREFIX%%#${PREFIX}#; s#%%VER%%#${PORTVERSION}#' ${FILESDIR}/MESSAGE > ${PKGMESSAGE}
+ @${REINPLACE_CMD} -e 's#%%PREFIX%%#${PREFIX}#; s#%%VER%%#${PORTVERSION}#' ${FILESDIR}/MESSAGE > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 6dbd0a704209..7d45a907252d 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -26,7 +26,9 @@ MAINTAINER= adrian@freebsd.org
DIST_SUBDIR= squid2.5
PATCH_DIST_STRIP= -p0
+USE_PERL5= yes
GNU_CONFIGURE= yes
+USE_PERL5= yes
USE_REINPLACE= yes
# Follow the apache port's lead...
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
diff --git a/www/squid25/Makefile b/www/squid25/Makefile
index 6dbd0a704209..7d45a907252d 100644
--- a/www/squid25/Makefile
+++ b/www/squid25/Makefile
@@ -26,7 +26,9 @@ MAINTAINER= adrian@freebsd.org
DIST_SUBDIR= squid2.5
PATCH_DIST_STRIP= -p0
+USE_PERL5= yes
GNU_CONFIGURE= yes
+USE_PERL5= yes
USE_REINPLACE= yes
# Follow the apache port's lead...
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
diff --git a/www/squid26/Makefile b/www/squid26/Makefile
index 6dbd0a704209..7d45a907252d 100644
--- a/www/squid26/Makefile
+++ b/www/squid26/Makefile
@@ -26,7 +26,9 @@ MAINTAINER= adrian@freebsd.org
DIST_SUBDIR= squid2.5
PATCH_DIST_STRIP= -p0
+USE_PERL5= yes
GNU_CONFIGURE= yes
+USE_PERL5= yes
USE_REINPLACE= yes
# Follow the apache port's lead...
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
diff --git a/www/squid27/Makefile b/www/squid27/Makefile
index 6dbd0a704209..7d45a907252d 100644
--- a/www/squid27/Makefile
+++ b/www/squid27/Makefile
@@ -26,7 +26,9 @@ MAINTAINER= adrian@freebsd.org
DIST_SUBDIR= squid2.5
PATCH_DIST_STRIP= -p0
+USE_PERL5= yes
GNU_CONFIGURE= yes
+USE_PERL5= yes
USE_REINPLACE= yes
# Follow the apache port's lead...
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index 6dbd0a704209..7d45a907252d 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -26,7 +26,9 @@ MAINTAINER= adrian@freebsd.org
DIST_SUBDIR= squid2.5
PATCH_DIST_STRIP= -p0
+USE_PERL5= yes
GNU_CONFIGURE= yes
+USE_PERL5= yes
USE_REINPLACE= yes
# Follow the apache port's lead...
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 6dbd0a704209..7d45a907252d 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -26,7 +26,9 @@ MAINTAINER= adrian@freebsd.org
DIST_SUBDIR= squid2.5
PATCH_DIST_STRIP= -p0
+USE_PERL5= yes
GNU_CONFIGURE= yes
+USE_PERL5= yes
USE_REINPLACE= yes
# Follow the apache port's lead...
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
diff --git a/www/znavigator/Makefile b/www/znavigator/Makefile
index f7f4852ae7d2..97d7bb8372e2 100644
--- a/www/znavigator/Makefile
+++ b/www/znavigator/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= nbm@FreeBSD.org
RUN_DEPENDS= ${LOCALBASE}/${SZOPEBASEDIR}/z2.py:${PORTSDIR}/www/zope
NO_BUILD= YES
+USE_REINPLACE= yes
# You can change this in the environment if you like.
SZOPEBASEDIR?= www/Zope
@@ -38,7 +39,8 @@ do-install:
${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}/
@${CP} ${ZOPEPRODUCTSRC}/demo/navigator_demo.zexp \
${ZOPEBASEDIR}/import
- @perl -pe 's#%%PREFIX%%#${PREFIX}#' ${FILESDIR}/MESSAGE > ${PKGMESSAGE}
+ @${REINPLACE_CMD} -e \
+ 's#%%PREFIX%%#${PREFIX}#' ${FILESDIR}/MESSAGE > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>