aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-12-18 08:42:26 +0800
committermiwi <miwi@FreeBSD.org>2009-12-18 08:42:26 +0800
commit68a69215701afd02ebe35ce284688a841ba715c0 (patch)
tree70b067bc8955d14fcd117516f372dc0c278e8495 /www
parent18110cda8d302b0ea7fd7210286ff84841cf734f (diff)
downloadfreebsd-ports-gnome-68a69215701afd02ebe35ce284688a841ba715c0.tar.gz
freebsd-ports-gnome-68a69215701afd02ebe35ce284688a841ba715c0.tar.zst
freebsd-ports-gnome-68a69215701afd02ebe35ce284688a841ba715c0.zip
This plugin allows for validating custom fields as dates in tickets
and adds fancy date selector to these fields. WWW: http://trac-hacks.org/wiki/DateFieldPlugin PR: ports/141702 Submitted by: Eygene Ryabinkin <rea-fbsd at codelabs.ru>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-datefield/Makefile38
-rw-r--r--www/trac-datefield/distinfo3
-rw-r--r--www/trac-datefield/pkg-descr4
4 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e376edfe4591..1cb8101c223a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1549,6 +1549,7 @@
SUBDIR += trac-ctxtnavadd
SUBDIR += trac-customfieldadmin
SUBDIR += trac-customroadmap
+ SUBDIR += trac-datefield
SUBDIR += trac-down
SUBDIR += trac-email2trac
SUBDIR += trac-fullblog
diff --git a/www/trac-datefield/Makefile b/www/trac-datefield/Makefile
new file mode 100644
index 000000000000..be8b8dba44b1
--- /dev/null
+++ b/www/trac-datefield/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: trac-autocomplete
+# Date created: December 16, 2009
+# Whom: Eygene Ryabinkin <rea-fbsd@codelabs.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= datefield
+PORTVERSION= 1.0.1
+CATEGORIES= www python
+MASTER_SITES= http://dist.codelabs.ru/fbsd/
+PKGNAMEPREFIX= trac-
+DISTNAME= datefieldplugin-r${REL}
+
+MAINTAINER= rea-fbsd@codelabs.ru
+COMMENT= A plugin for creating date fields
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= trac>=0.11:${PORTSDIR}/www/trac
+
+USE_PYTHON= 2.5+
+USE_ZIP= yes
+NO_BUILD= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= TracDateField
+PYDISTUTILS_NOEGGINFO= yes
+WRKSRC= ${WRKDIR}/datefieldplugin/0.11
+REL= 7267
+PLIST_FILES= ${PYTHON_SITELIBDIR:S;${LOCALBASE}/;;}/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+# We must fix file permissions -- ZIP file have 0000 for every file.
+# Directory permissions are fine (they aren't stored inside ZIP
+# file), but we set them too -- just in case.
+post-extract:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${CHMOD} 644
+ @${FIND} ${WRKSRC} -type d | ${XARGS} ${CHMOD} 755
+
+.include <bsd.port.mk>
diff --git a/www/trac-datefield/distinfo b/www/trac-datefield/distinfo
new file mode 100644
index 000000000000..421c1df92b33
--- /dev/null
+++ b/www/trac-datefield/distinfo
@@ -0,0 +1,3 @@
+MD5 (datefieldplugin-r7267.zip) = a1dd6e85a484ee191beff2b17c510fdb
+SHA256 (datefieldplugin-r7267.zip) = 565869c98580bd2b64c180b0a466d640b2b36f55a85d2f46804a6c676c1a8abe
+SIZE (datefieldplugin-r7267.zip) = 105459
diff --git a/www/trac-datefield/pkg-descr b/www/trac-datefield/pkg-descr
new file mode 100644
index 000000000000..56672494d570
--- /dev/null
+++ b/www/trac-datefield/pkg-descr
@@ -0,0 +1,4 @@
+This plugin allows for validating custom fields as dates in tickets
+and adds fancy date selector to these fields.
+
+WWW: http://trac-hacks.org/wiki/DateFieldPlugin