aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-13 00:16:16 +0800
committererwin <erwin@FreeBSD.org>2005-12-13 00:16:16 +0800
commit6d84fff45297e5e5ea0296cbf3087fa761e51e42 (patch)
tree2eeea82318bc79ea3d87231f10dc06bed6735c80 /www
parentdc0058b6821787a47f3124d62d93b15ced7850ed (diff)
downloadfreebsd-ports-gnome-6d84fff45297e5e5ea0296cbf3087fa761e51e42.tar.gz
freebsd-ports-gnome-6d84fff45297e5e5ea0296cbf3087fa761e51e42.tar.zst
freebsd-ports-gnome-6d84fff45297e5e5ea0296cbf3087fa761e51e42.zip
This module provides Access Control List style path protection, with
arbitrary rules for Catalyst applications. It operates only on the Catalyst private namespace, at least at the moment. WWW: http://search.cpan.org/dist/Catalyst-Plugin-Authorization-ACL/ PR: ports/90275 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Plugin-Authorization-ACL/Makefile33
-rw-r--r--www/p5-Catalyst-Plugin-Authorization-ACL/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Authorization-ACL/pkg-descr5
-rw-r--r--www/p5-Catalyst-Plugin-Authorization-ACL/pkg-plist6
5 files changed, 48 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 96dbabd9ee3e..55cf176a3f7e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -498,6 +498,7 @@
SUBDIR += p5-Catalyst-Plugin-Authentication-CDBI
SUBDIR += p5-Catalyst-Plugin-Authentication-Store-DBIC
SUBDIR += p5-Catalyst-Plugin-Authentication-Store-Htpasswd
+ SUBDIR += p5-Catalyst-Plugin-Authorization-ACL
SUBDIR += p5-Catalyst-Plugin-Authorization-Roles
SUBDIR += p5-Catalyst-Plugin-DefaultEnd
SUBDIR += p5-Catalyst-Plugin-FillInForm
diff --git a/www/p5-Catalyst-Plugin-Authorization-ACL/Makefile b/www/p5-Catalyst-Plugin-Authorization-ACL/Makefile
new file mode 100644
index 000000000000..5ddd9ea523bb
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authorization-ACL/Makefile
@@ -0,0 +1,33 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-Authorization-ACL
+# Date created: Dec 12, 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Authorization-ACL
+PORTVERSION= 0.04
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= ACL support for Catalyst applications
+
+BUILD_DEPENDS= p5-Catalyst>=5.49:${PORTSDIR}/www/p5-Catalyst \
+ p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ p5-Class-Throwable>=0:${PORTSDIR}/devel/p5-Class-Throwable \
+ p5-Tree-Simple-VisitorFactory>=0:${PORTSDIR}/devel/p5-Tree-Simple-VisitorFactory
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Authorization::ACL::Engine.3 \
+ Catalyst::Plugin::Authorization::ACL.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Authorization-ACL/distinfo b/www/p5-Catalyst-Plugin-Authorization-ACL/distinfo
new file mode 100644
index 000000000000..0e605c985c91
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authorization-ACL/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Authorization-ACL-0.04.tar.gz) = 0f1c07269832a14b95b7260b257c14b3
+SHA256 (Catalyst-Plugin-Authorization-ACL-0.04.tar.gz) = 976257124c6dd381c471095b74d50fd7f603a1a2487796a8d8f09ce3f559d2d4
+SIZE (Catalyst-Plugin-Authorization-ACL-0.04.tar.gz) = 10094
diff --git a/www/p5-Catalyst-Plugin-Authorization-ACL/pkg-descr b/www/p5-Catalyst-Plugin-Authorization-ACL/pkg-descr
new file mode 100644
index 000000000000..6e57b5059b16
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authorization-ACL/pkg-descr
@@ -0,0 +1,5 @@
+This module provides Access Control List style path protection, with
+arbitrary rules for Catalyst applications. It operates only on the
+Catalyst private namespace, at least at the moment.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Authorization-ACL/
diff --git a/www/p5-Catalyst-Plugin-Authorization-ACL/pkg-plist b/www/p5-Catalyst-Plugin-Authorization-ACL/pkg-plist
new file mode 100644
index 000000000000..e0ca79f9a316
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authorization-ACL/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Catalyst/Plugin/Authorization/ACL/Engine.pm
+%%SITE_PERL%%/Catalyst/Plugin/Authorization/ACL.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Authorization/ACL 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Authorization 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true