aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-11-11 22:49:40 +0800
committerrm <rm@FreeBSD.org>2012-11-11 22:49:40 +0800
commit71e4404929b188fb3e7ef40392cccf7a34bce3db (patch)
treebe091bf7f4ce1feab90e016c9692266c69c44024 /www
parentb8a81e2f5c4625aadb9ccb586f3a51ad59cbe52a (diff)
downloadfreebsd-ports-gnome-71e4404929b188fb3e7ef40392cccf7a34bce3db.tar.gz
freebsd-ports-gnome-71e4404929b188fb3e7ef40392cccf7a34bce3db.tar.zst
freebsd-ports-gnome-71e4404929b188fb3e7ef40392cccf7a34bce3db.zip
- do not directly depend on setuptools, use USE_DISTUTILS instead
- bump PORTREVISION because of dependency change - remove indefinite article in COMMENT - convert to optionsng - trim Makefile header - limit python version to 2.x only - move pkg-plist contents into Makefile:PLIST_FILES - tab -> space change in pkg-descr:WWW PR: 173169 Submitted by: rm (myself) Approved by: maintainer timeout (2 weeks) Feature safe: yes
Diffstat (limited to 'www')
-rw-r--r--www/trac-gantt/Makefile30
-rw-r--r--www/trac-gantt/pkg-descr2
-rw-r--r--www/trac-gantt/pkg-plist1
3 files changed, 13 insertions, 20 deletions
diff --git a/www/trac-gantt/Makefile b/www/trac-gantt/Makefile
index b72859642498..f1c3c378bb35 100644
--- a/www/trac-gantt/Makefile
+++ b/www/trac-gantt/Makefile
@@ -1,41 +1,35 @@
-# New ports collection makefile for: trac-gantt
-# Date created: July 12 2006
-# Whom: Dryice Liu <dryice@dryice.name>
-#
+# Created by: Dryice Liu <dryice@dryice.name>
# $FreeBSD$
-#
PORTNAME= TracGantt
PORTVERSION= 0.3.2a
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www devel python
MASTER_SITES= http://willbarton.com/files/ \
http://dryice.name/computer/FreeBSD/distfiles/
PKGNAMEPREFIX= trac-
MAINTAINER= dryice@dryice.name
-COMMENT= A plugin to creates Gantt charts for trac
+COMMENT= Plugin to creates Gantt charts for trac
-BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
RUN_DEPENDS+= trac>=0.11:${PORTSDIR}/www/trac
-NO_BUILD= yes
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHONVERSION=${_PYTHON_VERSION}
-PYDISTUTILS_NOEGGINFO= yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= TracGantt
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= PKG-INFO README
.endif
-.include <bsd.port.pre.mk>
-
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${INSTALL} -d ${DOCSDIR}
@cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/trac-gantt/pkg-descr b/www/trac-gantt/pkg-descr
index ecf962d38164..864e9514002e 100644
--- a/www/trac-gantt/pkg-descr
+++ b/www/trac-gantt/pkg-descr
@@ -13,4 +13,4 @@ Tickets" tab in Trac). The Gantt charts are pure XHTML and are
generated on-the-fly from the ticket reports, using only the tickets
provided by the report.
-WWW: http://willbarton.com/code/tracgantt/
+WWW: http://willbarton.com/code/tracgantt/
diff --git a/www/trac-gantt/pkg-plist b/www/trac-gantt/pkg-plist
deleted file mode 100644
index 01290b0569c8..000000000000
--- a/www/trac-gantt/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-%%PYTHON_SITELIBDIR%%/TracGantt-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg