aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2008-01-17 17:07:58 +0800
committerdinoex <dinoex@FreeBSD.org>2008-01-17 17:07:58 +0800
commit7b49bc00ea7fd58232f291742391f6bd53db5ae7 (patch)
tree072c98e3f9a3c84375b00db14934b1b95e6d6f0a /www
parent62ab4fea9570b005d2b50df36afad972c7ab255d (diff)
downloadfreebsd-ports-gnome-7b49bc00ea7fd58232f291742391f6bd53db5ae7.tar.gz
freebsd-ports-gnome-7b49bc00ea7fd58232f291742391f6bd53db5ae7.tar.zst
freebsd-ports-gnome-7b49bc00ea7fd58232f291742391f6bd53db5ae7.zip
- fix build of japanese language
- cosmetic changes to make portlint happier PR: 119715 Submitted by: TAKATSU Tomonari
Diffstat (limited to 'www')
-rw-r--r--www/webalizer/Makefile14
-rw-r--r--www/webalizer/files/ja-webalizer.conf-dist.patch19
-rw-r--r--www/webalizer/files/sample.conf.patch (renamed from www/webalizer/files/patch-sample.conf)0
3 files changed, 18 insertions, 15 deletions
diff --git a/www/webalizer/Makefile b/www/webalizer/Makefile
index 343246ab97f1..01e199145da6 100644
--- a/www/webalizer/Makefile
+++ b/www/webalizer/Makefile
@@ -93,6 +93,8 @@ CONFIGURE_ARGS+= --with-language=${WEBALIZER_LANG}
# see http://tyche.pu-toyama.ac.jp/~a-urasim/webalizer/
.if ${WEBALIZER_LANG} == japanese
EXTRA_PATCHES+= ${FILESDIR}/ja-webalizer.conf-dist.patch
+.else
+EXTRA_PATCHES+= ${FILESDIR}/sample.conf.patch
.endif
.endif
@@ -117,25 +119,25 @@ CFLAGS+= -DWEBALIZER_LOWERCASE_SEARCH
do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKDIR}
- @for file in ${EXTRACT_ONLY}; do \
- case $$file in \
+ @for f in ${EXTRACT_ONLY}; do \
+ case $$f in \
*.Z|*.gz) \
if ! (cd ${WRKDIR} && \
- ${GZCAT} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/$$file ${EXTRACT_AFTER_ARGS});\
+ ${GZCAT} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/$$f ${EXTRACT_AFTER_ARGS});\
then \
exit 1; \
fi \
;; \
*.bz2) \
if ! (cd ${WRKDIR} && \
- ${BZCAT} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/$$file ${EXTRACT_AFTER_ARGS});\
+ ${BZCAT} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/$$f ${EXTRACT_AFTER_ARGS});\
then \
exit 1; \
fi \
;; \
*.zip) \
if ! (cd ${WRKDIR} && \
- ${UNZIP_CMD} -qo ${_DISTDIR}/$$file -d ${WRKDIR});\
+ ${UNZIP_CMD} -qo ${_DISTDIR}/$$f -d ${WRKDIR});\
then \
exit 1; \
fi \
@@ -143,7 +145,7 @@ do-extract:
*) \
exit 1; \
;; \
- esac; \
+ esac; \
done
.if !defined(EXTRACT_PRESERVE_OWNERSHIP)
@if [ `${ID} -u` = 0 ]; then \
diff --git a/www/webalizer/files/ja-webalizer.conf-dist.patch b/www/webalizer/files/ja-webalizer.conf-dist.patch
index 1124060a7d6c..f9b861fb4b3e 100644
--- a/www/webalizer/files/ja-webalizer.conf-dist.patch
+++ b/www/webalizer/files/ja-webalizer.conf-dist.patch
@@ -1,5 +1,5 @@
---- sample.conf.orig Fri Sep 29 12:51:42 2000
-+++ sample.conf Thu Oct 14 11:48:21 2004
+--- sample.conf.orig 2000-09-29 12:51:42.000000000 +0900
++++ sample.conf 2008-01-16 21:58:12.000000000 +0900
@@ -107,9 +107,12 @@
PageType htm*
@@ -13,15 +13,16 @@
# UseHTTPS should be used if the analysis is being run on a
# secure server, and links to urls should use 'https://' instead
-@@ -153,6 +156,7 @@
+@@ -153,6 +156,8 @@
# is 80 characters, so use multiple lines if needed.
#HTMLHead <META NAME="author" CONTENT="The Webalizer">
+HTMLHead <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=x-euc-jp">
++HTMLHead <META NAME="ROBOTS" CONTENT="NOINDEX, NOFOLLOW">
# HTMLBody defined the HTML code to be inserted, starting with the
# <BODY> tag. If not specified, the default is shown below. If
-@@ -393,6 +397,9 @@
+@@ -393,6 +398,9 @@
HideURL *.png
HideURL *.PNG
HideURL *.ra
@@ -31,7 +32,7 @@
# Hiding agents is kind of futile
#HideAgent RealPlayer
-@@ -412,6 +419,11 @@
+@@ -412,6 +420,11 @@
#GroupReferrer excite.com/ Excite
#GroupReferrer infoseek.com/ InfoSeek
#GroupReferrer webcrawler.com/ WebCrawler
@@ -43,11 +44,10 @@
#GroupUser root Admin users
#GroupUser admin Admin users
-@@ -530,6 +542,21 @@
- SearchEngine mamma.com query=
+@@ -531,6 +544,21 @@
SearchEngine alltheweb.com query=
SearchEngine northernlight.com qr=
-+
+
+SearchEngine yahoo.co.jp p=
+SearchEngine google.co.jp q=
+SearchEngine infoseek.co.jp qt=
@@ -62,6 +62,7 @@
+SearchEngine jp.aol.com query=
+#SearchEngine .google. q=
+#SearchEngine bulkfeeds.net q=
-
++
# The Dump* keywords allow the dumping of Sites, URL's, Referrers
# User Agents, Usernames and Search strings to seperate tab delimited
+ # text files, suitable for import into most database or spreadsheet
diff --git a/www/webalizer/files/patch-sample.conf b/www/webalizer/files/sample.conf.patch
index ee52b3c9275c..ee52b3c9275c 100644
--- a/www/webalizer/files/patch-sample.conf
+++ b/www/webalizer/files/sample.conf.patch