aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2010-10-21 14:46:28 +0800
committersunpoet <sunpoet@FreeBSD.org>2010-10-21 14:46:28 +0800
commit7e3863a1e54b615e456fb40b6cf09b5fac2ec3d5 (patch)
tree22e719715534149a953f15c0a22d5e03eb31b1b5 /www
parentd3493beb23df5e263a8081699e712e5a0eddfe59 (diff)
downloadfreebsd-ports-gnome-7e3863a1e54b615e456fb40b6cf09b5fac2ec3d5.tar.gz
freebsd-ports-gnome-7e3863a1e54b615e456fb40b6cf09b5fac2ec3d5.tar.zst
freebsd-ports-gnome-7e3863a1e54b615e456fb40b6cf09b5fac2ec3d5.zip
- Update to 1.24
Changes: * Generate single empty tag for nillable complex elements i.e <name/> instead of <name><fname/><lname/></name> * Pass the correct schema parser when types are imported * Options to parse schemas from the web/filesystem * Thread safety fixes while fetching temp files * Updated AUTHORS.txt file PR: ports/151557 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Approved by: pgollucci (mentor, implicit)
Diffstat (limited to 'www')
-rw-r--r--www/wsdlpull/Makefile30
-rw-r--r--www/wsdlpull/distinfo6
-rw-r--r--www/wsdlpull/files/patch-src__xmlpull__XmlUtils.cpp11
-rw-r--r--www/wsdlpull/pkg-plist103
4 files changed, 65 insertions, 85 deletions
diff --git a/www/wsdlpull/Makefile b/www/wsdlpull/Makefile
index 0e16f11583e6..f5c800b6cf68 100644
--- a/www/wsdlpull/Makefile
+++ b/www/wsdlpull/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= wsdlpull
-PORTVERSION= 1.23
-PORTREVISION= 3
+PORTVERSION= 1.24
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
@@ -17,27 +16,30 @@ COMMENT= C++ WSDL Parser
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
-MAKE_JOBS_SAFE= yes
-
-USE_GNOME= gnometarget
-USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --includedir=${PREFIX}/include/wsdl
-USE_LDCONFIG= yes
-
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+MAKE_JOBS_SAFE= yes
+USE_AUTOTOOLS= libtool:22
+USE_LDCONFIG= yes
+
+MAN1= wsdlpull.1 wsdlpull-schema.1
post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|: install-docsDATA|:|g'
@${REINPLACE_CMD} -e '/-O2 -Wall/d' ${WRKSRC}/configure
+ @${REINPLACE_CMD} \
+ -e '/SUBDIRS = / s| docs||' \
+ -e '/^install-data-am:/ s| install-docsDATA||' \
+ ${WRKSRC}/Makefile.in
+# Do not install wsdlpull-config.1 for the absence of wsdlpull-config
+ @${REINPLACE_CMD} \
+ -e '/^man_MANS = / s| wsdlpull-config.1||' \
+ ${WRKSRC}/man/Makefile.in
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/wsdlpull.html ${DOCSDIR}/
+ @${MKDIR} ${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} README wsdlpull.html ${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/www/wsdlpull/distinfo b/www/wsdlpull/distinfo
index c7bed69701af..968927506e02 100644
--- a/www/wsdlpull/distinfo
+++ b/www/wsdlpull/distinfo
@@ -1,3 +1,3 @@
-MD5 (wsdlpull-1.23.tar.gz) = b26a695922def964c2796291dfb430c8
-SHA256 (wsdlpull-1.23.tar.gz) = f3652e52ffdad8dcd7eb9097297a5b10847663711da43ce02b9a1026070e3adf
-SIZE (wsdlpull-1.23.tar.gz) = 4307943
+MD5 (wsdlpull-1.24.tar.gz) = c77e1637ebb113921cb4fa5408bff67b
+SHA256 (wsdlpull-1.24.tar.gz) = 9577491e23914d7f84531616ffbe609216f56f263f3a4c9b1f7cafb7f3ebb8a8
+SIZE (wsdlpull-1.24.tar.gz) = 1080317
diff --git a/www/wsdlpull/files/patch-src__xmlpull__XmlUtils.cpp b/www/wsdlpull/files/patch-src__xmlpull__XmlUtils.cpp
deleted file mode 100644
index 0e7ae3c1354d..000000000000
--- a/www/wsdlpull/files/patch-src__xmlpull__XmlUtils.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/xmlpull/XmlUtils.cpp.orig 2009-12-16 02:36:41.855644800 +0000
-+++ ./src/xmlpull/XmlUtils.cpp 2009-12-16 02:37:03.225260481 +0000
-@@ -212,7 +212,7 @@
- // - use-case with a single '/' added (I am not sure this is conform to spec)
- // #ifdef _WIN32
- #if !defined(_WIN32)
-- unsigned int p;
-+ size_t p;
- if ((p=uri.find("file:///"))!=std::string::npos)
- {
- uri = uri.substr(p+7, uri.length()-p-7);
diff --git a/www/wsdlpull/pkg-plist b/www/wsdlpull/pkg-plist
index 922049d4aa4f..ebe7b3876b57 100644
--- a/www/wsdlpull/pkg-plist
+++ b/www/wsdlpull/pkg-plist
@@ -1,67 +1,56 @@
-bin/schema
-bin/wsdl
-include/wsdl/schemaparser/Annotation.h
-include/wsdl/schemaparser/Attribute.h
-include/wsdl/schemaparser/AttributeGroup.h
-include/wsdl/schemaparser/ComplexType.h
-include/wsdl/schemaparser/Constraint.h
-include/wsdl/schemaparser/ContentModel.h
-include/wsdl/schemaparser/Element.h
-include/wsdl/schemaparser/Group.h
-include/wsdl/schemaparser/Schema.h
-include/wsdl/schemaparser/SchemaParser.h
-include/wsdl/schemaparser/SchemaParserException.h
-include/wsdl/schemaparser/SchemaValidator.h
-include/wsdl/schemaparser/SimpleType.h
-include/wsdl/schemaparser/TypeContainer.h
-include/wsdl/schemaparser/TypesTable.h
-include/wsdl/schemaparser/XSDType.h
-include/wsdl/wsdlparser/Binding.h
-include/wsdl/wsdlparser/Message.h
-include/wsdl/wsdlparser/Operation.h
-include/wsdl/wsdlparser/PortType.h
-include/wsdl/wsdlparser/Service.h
-include/wsdl/wsdlparser/Soap.h
-include/wsdl/wsdlparser/WsdlElement.h
-include/wsdl/wsdlparser/WsdlException.h
-include/wsdl/wsdlparser/WsdlExtension.h
-include/wsdl/wsdlparser/WsdlInvoker.h
-include/wsdl/wsdlparser/WsdlParser.h
-include/wsdl/xmlpull/ConfigFile.h
-include/wsdl/xmlpull/XmlDoc.h
-include/wsdl/xmlpull/Qname.h
-include/wsdl/xmlpull/XmlPullParser.h
-include/wsdl/xmlpull/XmlPullParserException.h
-include/wsdl/xmlpull/XmlSerializer.h
-include/wsdl/xmlpull/XmlUtils.h
-include/wsdl/xmlpull/osdir.h
-include/wsdl/xmlpull/wsdlpull_export.h
-lib/libschema.a
-lib/libschema.la
-lib/libschema.so
-lib/libschema.so.0
-lib/libwsdl.a
-lib/libwsdl.la
-lib/libwsdl.so
-lib/libwsdl.so.0
-lib/libxmlpull.a
-lib/libxmlpull.la
-lib/libxmlpull.so
-lib/libxmlpull.so.0
-%%PORTDOCS%%%%DOCSDIR%%/README.txt
+bin/wsdlpull
+bin/wsdlpull-schema
+include/wsdlpull/schemaparser/Annotation.h
+include/wsdlpull/schemaparser/Attribute.h
+include/wsdlpull/schemaparser/AttributeGroup.h
+include/wsdlpull/schemaparser/ComplexType.h
+include/wsdlpull/schemaparser/Constraint.h
+include/wsdlpull/schemaparser/ContentModel.h
+include/wsdlpull/schemaparser/Element.h
+include/wsdlpull/schemaparser/Group.h
+include/wsdlpull/schemaparser/Schema.h
+include/wsdlpull/schemaparser/SchemaParser.h
+include/wsdlpull/schemaparser/SchemaParserException.h
+include/wsdlpull/schemaparser/SchemaValidator.h
+include/wsdlpull/schemaparser/SimpleType.h
+include/wsdlpull/schemaparser/TypeContainer.h
+include/wsdlpull/schemaparser/TypesTable.h
+include/wsdlpull/schemaparser/XSDType.h
+include/wsdlpull/xml/ConfigFile.h
+include/wsdlpull/xml/Qname.h
+include/wsdlpull/xml/XmlDoc.h
+include/wsdlpull/xml/XmlPullParser.h
+include/wsdlpull/xml/XmlPullParserException.h
+include/wsdlpull/xml/XmlSerializer.h
+include/wsdlpull/xml/XmlUtils.h
+include/wsdlpull/xml/osdir.h
+include/wsdlpull/xml/wsdlpull_export.h
+lib/libwsdlpull.a
+lib/libwsdlpull.la
+lib/libwsdlpull.so
+lib/libwsdlpull.so.1
+lib/libwsdlpullschema.a
+lib/libwsdlpullschema.la
+lib/libwsdlpullschema.so
+lib/libwsdlpullschema.so.1
+lib/libwsdlpullxml.a
+lib/libwsdlpullxml.la
+lib/libwsdlpullxml.so
+lib/libwsdlpullxml.so.1
+%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/wsdlpull.html
%%DATADIR%%/http.xsd
%%DATADIR%%/mime.xsd
%%DATADIR%%/schema.conf
%%DATADIR%%/schema.dtd
-%%DATADIR%%/soap-encoding.xsd
%%DATADIR%%/soap.xsd
-%%DATADIR%%/soap12.xsd
+%%DATADIR%%/soap-encoding.xsd
%%DATADIR%%/soap-encoding12.xsd
+%%DATADIR%%/soap12.xsd
%%DATADIR%%/wsdl10.xsd
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm include/wsdl/xmlpull
-@dirrm include/wsdl/wsdlparser
-@dirrm include/wsdl/schemaparser
-@dirrm include/wsdl
+@dirrm include/wsdlpull/xml
+@dirrm include/wsdlpull/wsdlparser
+@dirrm include/wsdlpull/schemaparser
+@dirrm include/wsdlpull