aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorstefan <stefan@FreeBSD.org>2007-10-06 21:40:33 +0800
committerstefan <stefan@FreeBSD.org>2007-10-06 21:40:33 +0800
commit848a89cf9e92938453b996657fb3aa64b2f8ebc3 (patch)
tree4fb7670b1b5de938b5e19e1e16249fff728e78de /www
parentff0ab8fd53c4e126f8c4d198ae53749ddf6e0492 (diff)
downloadfreebsd-ports-gnome-848a89cf9e92938453b996657fb3aa64b2f8ebc3.tar.gz
freebsd-ports-gnome-848a89cf9e92938453b996657fb3aa64b2f8ebc3.tar.zst
freebsd-ports-gnome-848a89cf9e92938453b996657fb3aa64b2f8ebc3.zip
Implement handling of the global WITHOUT_IPV6 and its local equivalent
WITHOUT_DILLO_IPV6 if one needs to disable IPv6 support. While at it, remove no longer relevant notes about 4.x and SSL support. PR: 116973 Submitted by: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/dillo-i18n/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/www/dillo-i18n/Makefile b/www/dillo-i18n/Makefile
index b8c5f6c9c0ed..8780867ca610 100644
--- a/www/dillo-i18n/Makefile
+++ b/www/dillo-i18n/Makefile
@@ -11,11 +11,8 @@
# WITHOUT_DILLO_ANTIALIAS: disable support for antialiased display
# WITH_DILLO_DLGUI: enable experimental FLTK2 based gui for file
# downloads
+# WITHOUT_DILLO_IPV6: disable IPv6 support
#
-# TODO:
-# SSL support is currently partly broken in this version of the i18n Dillo:
-# On FreeBSD 4 with OpenSSL 0.9.7d, the configure script uses checks that are
-# too strict. On FreeBSD 5 and 6 it seems to work OK.
PORTNAME= dillo
PORTVERSION= ${DILLOVERSION}.${I18NVERSION}
@@ -44,7 +41,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --enable-cookies --enable-ipv6 --enable-threaded-dns \
+CONFIGURE_ARGS= --enable-cookies --enable-threaded-dns \
--libdir=${PREFIX}/libexec
CONFLICTS= dillo-[0-9].[0-9].[0-9]*
@@ -59,8 +56,6 @@ CONFIGURE_ARGS+= --disable-nls
.endif
.if defined(WITH_DILLO_SSL)
-# Note: the configure script will deactivate SSL support on 4.x systems.
-# This might get fixed someday so I activate this option unconditionally.
CONFIGURE_ARGS+= --enable-ssl
USE_OPENSSL= yes
.else
@@ -95,6 +90,10 @@ LDFLAGS+= -L${X11BASE}/lib
CONFIGURE_ARGS+= --disable-dlgui
.endif
+.if !defined(WITHOUT_DILLO_IPV6) && !defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
s|-D_THREAD_SAFE|${PTHREAD_CFLAGS}|g' ${WRKSRC}/configure
@@ -127,7 +126,11 @@ pre-configure:
@${ECHO_CMD} " Set WITH_DILLO_DLGUI=yes in your make environment or on the"
@${ECHO_CMD} " commandline to enable a FLTK2 based gui for download operations."
.endif
-
+.if !defined(WITHOUT_DILLO_IPV6) && !defined(WITHOUT_IPV6)
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} " Set WITHOUT_DILLO_IPV6=yes (or WITHOUT_IPV6=yes) in your make"
+ @${ECHO_CMD} " environment or on the commandline to disable IPv6 support."
+.endif
@${ECHO_CMD} ""
.include <bsd.port.mk>