aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2011-03-19 04:24:29 +0800
committerglarkin <glarkin@FreeBSD.org>2011-03-19 04:24:29 +0800
commit8881c9d0505184f3fe4133097fb1769966a87240 (patch)
treea921debffa240deefcfabca34d746893dd37abf9 /www
parent3bda768618d753ca2fb258cc1d1e66516fd8938d (diff)
downloadfreebsd-ports-gnome-8881c9d0505184f3fe4133097fb1769966a87240.tar.gz
freebsd-ports-gnome-8881c9d0505184f3fe4133097fb1769966a87240.tar.zst
freebsd-ports-gnome-8881c9d0505184f3fe4133097fb1769966a87240.zip
Utilities for implementing Modified Preorder Tree Traversal with
your Django Models and working with trees of Model instances. WWW: https://github.com/django-mptt/django-mptt/ PR: ports/154830 Submitted by: Carlo Strub (c-s@c-s.li)
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-mptt/Makefile27
-rw-r--r--www/py-django-mptt/distinfo2
-rw-r--r--www/py-django-mptt/pkg-descr4
4 files changed, 34 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0d1dded0522d..9a8f61e9ff95 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1474,6 +1474,7 @@
SUBDIR += py-django-extensions
SUBDIR += py-django-keyedcache
SUBDIR += py-django-livesettings
+ SUBDIR += py-django-mptt
SUBDIR += py-django-profiles
SUBDIR += py-django-registration
SUBDIR += py-django-signals-ahoy
diff --git a/www/py-django-mptt/Makefile b/www/py-django-mptt/Makefile
new file mode 100644
index 000000000000..6414138d5131
--- /dev/null
+++ b/www/py-django-mptt/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: django-mptt
+# Date created: 2011-02-16
+# Whom: Carlo Strub
+#
+# $FreeBSD$
+#
+
+PORTNAME= django-mptt
+PORTVERSION= 0.4.2
+CATEGORIES= www python
+MASTER_SITES= http://www.c-s.li/ports/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= c-s@c-s.li
+COMMENT= Utilities for implementing a pre-order traversal tree in django
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/django/bin/django-admin.py:${PORTSDIR}/www/py-django
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+LICENSE= BSD
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-7d3e111
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/www/py-django-mptt/distinfo b/www/py-django-mptt/distinfo
new file mode 100644
index 000000000000..9c42480190c6
--- /dev/null
+++ b/www/py-django-mptt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-mptt-0.4.2.tar.gz) = 5da78351ee7255d3f7a0a9112fa2542aba82d3de19abd98ecce858b28dbe776b
+SIZE (django-mptt-0.4.2.tar.gz) = 63197
diff --git a/www/py-django-mptt/pkg-descr b/www/py-django-mptt/pkg-descr
new file mode 100644
index 000000000000..efbbd3d5ca60
--- /dev/null
+++ b/www/py-django-mptt/pkg-descr
@@ -0,0 +1,4 @@
+Utilities for implementing Modified Preorder Tree Traversal with
+your Django Models and working with trees of Model instances.
+
+WWW: https://github.com/django-mptt/django-mptt/