aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
committerbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
commit8a3f534c898f1045896626964b7f3e3e406f946b (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /www
parentccde37a9b75ee6a15ed85af7d0f2e60c16c42192 (diff)
downloadfreebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.tar.gz
freebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.tar.zst
freebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.zip
new devel/pkgconf added to replace devel/pkg-config. new version of pkg-config
are no more self hosting so we are stuck with 0.25 version while pkgconf provide the same set of features as 0.27 and a compatible frontend. A symlink to pkg-config has been added for convenience and compatibility This also introduces a new macro to use pkgconf in your ports: USE_PKGCONFIG it can take the following arguments: - yes (meaning build only dep) - build (meaning build only dep) - run (meaning run only dep) - both (meaning run and build dep) From now USE_GNOME= pkgconfig is deprecated in favour of USE_PKGCONFIG The old gnome macro has been modified to use pkgconf but still the sameway: run and build dep to avoid large breakage. While here fix some ports relying on pkg-config but not specifying it, fix some ports broken because testing wrong .pc files, and fix ports using pkg-config --version to determine pkg-config version instead of pkg-config --modversion pkg-config like recommanded by pkg-config With Hat: portmgr Exp-runs by: bapt (pointhat-west), beat (pointyhat)
Diffstat (limited to 'www')
-rw-r--r--www/apache20/Makefile2
-rw-r--r--www/httpsqs/Makefile3
-rw-r--r--www/lighttpd/Makefile2
-rw-r--r--www/openvrml/Makefile4
4 files changed, 5 insertions, 6 deletions
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index a3aebe09e606..35621fc528e7 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -156,7 +156,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-openssl-9.8up.patch
.endif
.if ${OSVERSION} < 700014 && ${ARCH} == i386
-BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
+USE_PKGCONFIG= yes
.endif
.if defined(WITH_THREADS)
diff --git a/www/httpsqs/Makefile b/www/httpsqs/Makefile
index a9fe50fb32b3..68ecfb0b1e37 100644
--- a/www/httpsqs/Makefile
+++ b/www/httpsqs/Makefile
@@ -18,8 +18,7 @@ LICENSE= BSD
LIB_DEPENDS+= tokyocabinet:${PORTSDIR}/databases/tokyocabinet \
event-2.0:${PORTSDIR}/devel/libevent2
-BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
-
+USE_PKGCONFIG= yes
MAKE_ENV= LIBS="${PTHREAD_LIBS}"
PLIST_FILES= bin/${PORTNAME}
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 1a1ab0e6eaef..05b6bd1e43e1 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -19,13 +19,13 @@ LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYING
.endif
-BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= lthack
USE_GMAKE= yes
+USE_PKGCONFIG= yes
MAKE_JOBS_SAFE= yes
#.if !defined(_BUILDING_LIGHTTPD_MODULE)
diff --git a/www/openvrml/Makefile b/www/openvrml/Makefile
index 3cc64174ea14..d62648c771dd 100644
--- a/www/openvrml/Makefile
+++ b/www/openvrml/Makefile
@@ -14,8 +14,7 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= VRML97 runtime and browser
-BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone \
- pkg-config:${PORTSDIR}/devel/pkg-config
+BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone
LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
js.1:${PORTSDIR}/lang/spidermonkey \
jpeg.11:${PORTSDIR}/graphics/jpeg \
@@ -28,6 +27,7 @@ USE_GNOME= gnomehack libglade2 libgnomeui
USE_SDL= sdl
USE_JAVA= yes
USE_GCC= 4.6+
+USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
LIBTOOLFILES= configure
CONFIGURE_ARGS= --enable-gecko-rpath \