aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-10-27 17:29:23 +0800
committermat <mat@FreeBSD.org>2016-10-27 17:29:23 +0800
commit8fbf82dc51da2ff4f7fd88a0f1ede51d6e58cd20 (patch)
treea407beaebe1195e009b98c77d8eb648d13ef7834 /www
parent4908d613835695270d52368230f9fe3c413a5601 (diff)
downloadfreebsd-ports-gnome-8fbf82dc51da2ff4f7fd88a0f1ede51d6e58cd20.tar.gz
freebsd-ports-gnome-8fbf82dc51da2ff4f7fd88a0f1ede51d6e58cd20.tar.zst
freebsd-ports-gnome-8fbf82dc51da2ff4f7fd88a0f1ede51d6e58cd20.zip
Remove obsolete PHP versions checks.
Sponsored by: Absolight
Diffstat (limited to 'www')
-rw-r--r--www/sams2/Makefile6
-rw-r--r--www/zend-framework/Makefile8
-rw-r--r--www/zend-framework1/Makefile8
3 files changed, 3 insertions, 19 deletions
diff --git a/www/sams2/Makefile b/www/sams2/Makefile
index daaf45c78dde..124a15378b1d 100644
--- a/www/sams2/Makefile
+++ b/www/sams2/Makefile
@@ -35,12 +35,6 @@ APACHE_USE= APACHE=22+
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MAPACHE}
-. if ${PHP_VER} == "54" && (${APACHE_VERSION} >= 24)
-RUN_DEPENDS+= mod_php5>=0:www/mod_php5
-. endif
-. if ${PHP_VER} == "55" && (${APACHE_VERSION} >= 24)
-RUN_DEPENDS+= mod_php55>=0:www/mod_php55
-. endif
. if ${APACHE_VERSION} >= 24
AP24= ""
. endif
diff --git a/www/zend-framework/Makefile b/www/zend-framework/Makefile
index 5a38d6669489..3eebd3c6142a 100644
--- a/www/zend-framework/Makefile
+++ b/www/zend-framework/Makefile
@@ -42,13 +42,7 @@ PORTDOCS= CHANGELOG.md INSTALL.md README-GIT.md CONTRIBUTING.md README.md
# if chosen by the user.
.if ${PORT_OPTIONS:MREQPHP}
USE_PHP+= ctype curl dom gd hash iconv mbstring ldap mcrypt \
- opcache pcre pdo session simplexml soap wddx xml zlib
-.if ${PHP_VER} == 52
-USE_PHP+= sqlite
-.else
-USE_PHP+= sqlite3
-.endif
-
+ opcache pcre pdo session simplexml soap sqlite3 wddx xml zlib
.endif
.if ${PORT_OPTIONS:MOPTPHP}
diff --git a/www/zend-framework1/Makefile b/www/zend-framework1/Makefile
index 32676fe65eaf..84ebe8b2e389 100644
--- a/www/zend-framework1/Makefile
+++ b/www/zend-framework1/Makefile
@@ -53,13 +53,9 @@ INSTALL_DIRS= library extras/library externals/dojo/dijit \
.if ${PORT_OPTIONS:MREQPHP}
USE_PHP+= ctype curl dom gd hash iconv mbstring ldap mcrypt \
- opcache pcre pdo session simplexml soap \
+ opcache pcre pdo session simplexml soap sqlite3 \
wddx xml zlib
-.if ${PHP_VER} == 52
-USE_PHP+= sqlite
-.else
-USE_PHP+= sqlite3
-.endif
+
RUN_DEPENDS+= pecl-memcache>=0:databases/pecl-memcache \
pecl-memcached>=0:databases/pecl-memcached
.endif