aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-11-23 10:51:53 +0800
committerpat <pat@FreeBSD.org>2002-11-23 10:51:53 +0800
commit8fe8e3c6f310516f806d6216dfffa0291e05f2bf (patch)
treee6f038fc1f97a9247a372b2569df0832ff224300 /www
parent47dced7ae86f07bd8b58d0881af0d1fa8b456a51 (diff)
downloadfreebsd-ports-gnome-8fe8e3c6f310516f806d6216dfffa0291e05f2bf.tar.gz
freebsd-ports-gnome-8fe8e3c6f310516f806d6216dfffa0291e05f2bf.tar.zst
freebsd-ports-gnome-8fe8e3c6f310516f806d6216dfffa0291e05f2bf.zip
Add patch to remove SHM blocks when plugin is closed
PR: ports/43498 Submitted by: Wolfgang Zenker <wolfgang@lyxys.ka.sub.org> Reviewed by: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/flashplugin-mozilla/Makefile2
-rw-r--r--www/flashplugin-mozilla/files/patch-plugin.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/www/flashplugin-mozilla/Makefile b/www/flashplugin-mozilla/Makefile
index 30807e342ca8..996b093f7c3c 100644
--- a/www/flashplugin-mozilla/Makefile
+++ b/www/flashplugin-mozilla/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= flashplugin-mozilla
PORTVERSION= 0.4.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.swift-tools.com/Flash/
DISTNAME= flash-${PORTVERSION}
diff --git a/www/flashplugin-mozilla/files/patch-plugin.c b/www/flashplugin-mozilla/files/patch-plugin.c
new file mode 100644
index 000000000000..a77f089cc89e
--- /dev/null
+++ b/www/flashplugin-mozilla/files/patch-plugin.c
@@ -0,0 +1,20 @@
+*** plugin.c.old Mon Jun 12 10:24:09 2000
+--- plugin.c Mon Sep 30 00:48:40 2002
+***************
+*** 193,198 ****
+--- 193,207 ----
+ XSync(This->dpy,False);
+ XFreePixmap(This->dpy, This->canvas);
+ shmdt(This->segInfo.shmaddr);
++ #ifndef linux
++ {
++ struct shmid_ds buf;
++
++ if (shmctl(This->segInfo.shmid, IPC_RMID, &buf) < 0) {
++ perror("shmctl");
++ }
++ }
++ #endif
+
+ FlashClose(This->fh);
+ This->fh = 0;