aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2011-06-23 06:57:16 +0800
committernox <nox@FreeBSD.org>2011-06-23 06:57:16 +0800
commit953c74f0db13f6bfedd68ab2a7f8d4b1f2f8e6b8 (patch)
tree50cd9a19bc95df1d881b829c03cd7ef4d612d2e7 /www
parent7324ef6d8b7e9739d629cc1a21297c90e2f3a1aa (diff)
downloadfreebsd-ports-gnome-953c74f0db13f6bfedd68ab2a7f8d4b1f2f8e6b8.tar.gz
freebsd-ports-gnome-953c74f0db13f6bfedd68ab2a7f8d4b1f2f8e6b8.tar.zst
freebsd-ports-gnome-953c74f0db13f6bfedd68ab2a7f8d4b1f2f8e6b8.zip
Fix build with clang.
Diffstat (limited to 'www')
-rw-r--r--www/tntnet/Makefile1
-rw-r--r--www/tntnet/files/patch-clang27
2 files changed, 28 insertions, 0 deletions
diff --git a/www/tntnet/Makefile b/www/tntnet/Makefile
index e591a87a1323..893d3d5f7da4 100644
--- a/www/tntnet/Makefile
+++ b/www/tntnet/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= cxxtools:${PORTSDIR}/devel/cxxtools
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
USE_ICONV= yes
+USE_CSTD= gnu89
PATCH_STRIP= -p1
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
diff --git a/www/tntnet/files/patch-clang b/www/tntnet/files/patch-clang
new file mode 100644
index 000000000000..b4046c53bdcc
--- /dev/null
+++ b/www/tntnet/files/patch-clang
@@ -0,0 +1,27 @@
+--- a/framework/common/tnt/object.h
++++ b/framework/common/tnt/object.h
+@@ -57,9 +57,9 @@ namespace tnt
+ : ptr(ptr_)
+ { }
+ ~PointerObject()
+- { destroy(ptr); }
++ { this->destroy(ptr); }
+ void set(data_type* ptr_)
+- { destroy(ptr); ptr = ptr_; }
++ { this->destroy(ptr); ptr = ptr_; }
+ data_type* get() { return ptr; }
+ };
+
+--- a/framework/common/tnt/compident.h
++++ b/framework/common/tnt/compident.h
+@@ -39,8 +39,9 @@ namespace tnt
+ /// tntnet components are identified by the library, where they reside and a name
+ /// inside the library. The name is actually a string constant, which was passed
+ /// to the component factory ctor.
+-struct Compident
++class Compident
+ {
++public:
+ std::string libname;
+ std::string compname;
+