aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-11-03 22:54:39 +0800
committertijl <tijl@FreeBSD.org>2016-11-03 22:54:39 +0800
commit984f9ab9c1be0c86366b0e4a7320df21a735a0b4 (patch)
tree1e54179de202f2c97c16dbed67d179a0d801f54c /www
parent84301fd3537035f9c92438f41f8e72808afd61fd (diff)
downloadfreebsd-ports-gnome-984f9ab9c1be0c86366b0e4a7320df21a735a0b4.tar.gz
freebsd-ports-gnome-984f9ab9c1be0c86366b0e4a7320df21a735a0b4.tar.zst
freebsd-ports-gnome-984f9ab9c1be0c86366b0e4a7320df21a735a0b4.zip
Add port for Adobe flash plugin 24.0.0.138 (beta).
Diffstat (limited to 'www')
-rw-r--r--www/Makefile2
-rw-r--r--www/linux-c6-flashplugin24/Makefile43
-rw-r--r--www/linux-c6-flashplugin24/distinfo3
-rw-r--r--www/linux-c6-flashplugin24/pkg-descr10
-rw-r--r--www/linux-c6-flashplugin24/pkg-message7
-rw-r--r--www/linux-c6-flashplugin24/pkg-plist8
-rw-r--r--www/linux-c7-flashplugin24/Makefile7
7 files changed, 80 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 432d940b8c7a..106f6918b427 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -368,8 +368,10 @@
SUBDIR += links-hacked
SUBDIR += links1
SUBDIR += linux-c6-flashplugin11
+ SUBDIR += linux-c6-flashplugin24
SUBDIR += linux-c6-qt47-webkit
SUBDIR += linux-c7-flashplugin11
+ SUBDIR += linux-c7-flashplugin24
SUBDIR += linux-c7-qtwebkit
SUBDIR += linux-f10-flashplugin11
SUBDIR += linux-firefox
diff --git a/www/linux-c6-flashplugin24/Makefile b/www/linux-c6-flashplugin24/Makefile
new file mode 100644
index 000000000000..ffd91894c8dc
--- /dev/null
+++ b/www/linux-c6-flashplugin24/Makefile
@@ -0,0 +1,43 @@
+# Created by: Artyom Mirgorodskiy <artyom.mirgorodsky@gmail.com>
+# $FreeBSD$
+
+PORTNAME= flashplugin
+PORTVERSION= 24.0.0.138
+CATEGORIES= www multimedia linux
+MASTER_SITES= https://fpdownload.macromedia.com/pub/labs/flashruntimes/flashplayer/linux32/
+PKGNAMEPREFIX?= linux-c6-
+PKGNAMESUFFIX= 24
+DISTFILES= flash_player_npapi_linux.i386.tar.gz
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Adobe Flash Player NPAPI Plugin (beta)
+
+ONLY_FOR_ARCHS= amd64 i386
+USES?= linux:c6
+USE_LINUX= alsalib alsa-plugins-oss curl dri gtk2 nspr nss
+
+RESTRICTED= Redistribution not allowed
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+STRIP=
+USES+= cpe webplugin:linux
+CPE_VENDOR= adobe
+CPE_PRODUCT= flash_player
+WEBPLUGIN_FILES=libflashplayer.so
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} '/^NotShowIn=KDE/d' \
+ ${WRKSRC}/usr/share/applications/flash-player-properties.desktop
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WEBPLUGIN_DIR}
+ ${INSTALL_LIB} ${WRKSRC}/libflashplayer.so ${STAGEDIR}${WEBPLUGIN_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/usr/bin/flash-player-properties ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/usr/share/applications/flash-player-properties.desktop ${STAGEDIR}${DESKTOPDIR}
+ (cd ${WRKSRC}/usr/share/icons && ${COPYTREE_SHARE} hicolor ${STAGEDIR}${PREFIX}/share/icons)
+
+.include <bsd.port.mk>
diff --git a/www/linux-c6-flashplugin24/distinfo b/www/linux-c6-flashplugin24/distinfo
new file mode 100644
index 000000000000..25e8cea07ce6
--- /dev/null
+++ b/www/linux-c6-flashplugin24/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1478178247
+SHA256 (flashplugin/24.0.0.138/flash_player_npapi_linux.i386.tar.gz) = b8ad51040695c6c6a6534353f0950b012353682dd1b1e37168897a1c7eaa0c07
+SIZE (flashplugin/24.0.0.138/flash_player_npapi_linux.i386.tar.gz) = 9159673
diff --git a/www/linux-c6-flashplugin24/pkg-descr b/www/linux-c6-flashplugin24/pkg-descr
new file mode 100644
index 000000000000..9c9dcd2de5d8
--- /dev/null
+++ b/www/linux-c6-flashplugin24/pkg-descr
@@ -0,0 +1,10 @@
+This is the official Flash Player from Adobe. This plugin enables
+you to see .swf and .spl files on the 'net from your Opera, Mozilla or
+Firefox sessions.
+
+Please see the Adobe home page for more information.
+
+FreeBSD Flash License Agreement:
+ http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/96374
+
+WWW: http://www.adobe.com/
diff --git a/www/linux-c6-flashplugin24/pkg-message b/www/linux-c6-flashplugin24/pkg-message
new file mode 100644
index 000000000000..98294fcb3e9b
--- /dev/null
+++ b/www/linux-c6-flashplugin24/pkg-message
@@ -0,0 +1,7 @@
+If this is your first time installing flash each user must run:
+
+ nspluginwrapper -v -a -i
+
+If you are updating flash each user must run:
+
+ nspluginwrapper -v -a -u
diff --git a/www/linux-c6-flashplugin24/pkg-plist b/www/linux-c6-flashplugin24/pkg-plist
new file mode 100644
index 000000000000..f771bf3455f4
--- /dev/null
+++ b/www/linux-c6-flashplugin24/pkg-plist
@@ -0,0 +1,8 @@
+bin/flash-player-properties
+%%WEBPLUGIN_DIR%%/libflashplayer.so
+share/applications/flash-player-properties.desktop
+share/icons/hicolor/16x16/apps/flash-player-properties.png
+share/icons/hicolor/22x22/apps/flash-player-properties.png
+share/icons/hicolor/24x24/apps/flash-player-properties.png
+share/icons/hicolor/32x32/apps/flash-player-properties.png
+share/icons/hicolor/48x48/apps/flash-player-properties.png
diff --git a/www/linux-c7-flashplugin24/Makefile b/www/linux-c7-flashplugin24/Makefile
new file mode 100644
index 000000000000..0e18a3d11f4c
--- /dev/null
+++ b/www/linux-c7-flashplugin24/Makefile
@@ -0,0 +1,7 @@
+# $FreeBSD$
+
+PKGNAMEPREFIX= linux-c7-
+USES= linux:c7
+MASTERDIR= ${.CURDIR}/../linux-c6-flashplugin24
+
+.include "${MASTERDIR}/Makefile"