aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>1999-03-01 19:13:12 +0800
committerkris <kris@FreeBSD.org>1999-03-01 19:13:12 +0800
commit9e62812c4501a505dea39c257733fe607f401a97 (patch)
treea1c710f90a15ae7cb83b94d42dcc7d0b21ac25db /www
parent9c8b035feffad87843c3440c87e1c193750f81a8 (diff)
downloadfreebsd-ports-gnome-9e62812c4501a505dea39c257733fe607f401a97.tar.gz
freebsd-ports-gnome-9e62812c4501a505dea39c257733fe607f401a97.tar.zst
freebsd-ports-gnome-9e62812c4501a505dea39c257733fe607f401a97.zip
Snarf is another command-line URL fetcher, which can handle
http/ftp/gopher/finger fetching. It displays the download progress as a little status meter. PR: ports/9839
Diffstat (limited to 'www')
-rw-r--r--www/snarf/Makefile26
-rw-r--r--www/snarf/distinfo1
-rw-r--r--www/snarf/pkg-comment1
-rw-r--r--www/snarf/pkg-descr5
-rw-r--r--www/snarf/pkg-plist1
5 files changed, 34 insertions, 0 deletions
diff --git a/www/snarf/Makefile b/www/snarf/Makefile
new file mode 100644
index 000000000000..0bdd64954d93
--- /dev/null
+++ b/www/snarf/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: snarf
+# Version required: 2.0.5
+# Date created: 2 January 1999
+# Whom: Kris Kennaway <kris@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= snarf-latest
+PKGNAME= snarf-2.0.5
+CATEGORIES= www
+MASTER_SITES= http://www.xach.com/snarf/
+
+MAINTAINER= kris@FreeBSD.ORG
+
+WRKSRC= ${WRKDIR}/snarf-2.0.5/
+
+GNU_CONFIGURE= yes
+
+MAN1= snarf.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/snarf ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/snarf.1 ${PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/www/snarf/distinfo b/www/snarf/distinfo
new file mode 100644
index 000000000000..1fce462f1c5f
--- /dev/null
+++ b/www/snarf/distinfo
@@ -0,0 +1 @@
+MD5 (snarf-latest.tar.gz) = 90502b4519bc150ccc330cf50f549db3
diff --git a/www/snarf/pkg-comment b/www/snarf/pkg-comment
new file mode 100644
index 000000000000..bf6b46873edc
--- /dev/null
+++ b/www/snarf/pkg-comment
@@ -0,0 +1 @@
+Another small command-line URL (http/ftp/gopher/finger) fetcher.
diff --git a/www/snarf/pkg-descr b/www/snarf/pkg-descr
new file mode 100644
index 000000000000..6b5b77a0ca2b
--- /dev/null
+++ b/www/snarf/pkg-descr
@@ -0,0 +1,5 @@
+Snarf is another small command-line URL fetcher. It supports proxying,
+http redirect, http and ftp resume, http and ftp authentication, as well
+as retrieving data via gopher and finger protocols.
+
+http://www.xach.com/snarf/
diff --git a/www/snarf/pkg-plist b/www/snarf/pkg-plist
new file mode 100644
index 000000000000..e683bc9f2fb3
--- /dev/null
+++ b/www/snarf/pkg-plist
@@ -0,0 +1 @@
+bin/snarf