aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsanpei <sanpei@FreeBSD.org>2001-06-16 16:59:04 +0800
committersanpei <sanpei@FreeBSD.org>2001-06-16 16:59:04 +0800
commita0c81c6019b74a837aea9a7262e71ee091217f83 (patch)
tree43f1415a47eb89cfc2ab8da9dc8fa4ac708b47de /www
parent9540dba52307607fd05c16409daac11b97fcd7cf (diff)
downloadfreebsd-ports-gnome-a0c81c6019b74a837aea9a7262e71ee091217f83.tar.gz
freebsd-ports-gnome-a0c81c6019b74a837aea9a7262e71ee091217f83.tar.zst
freebsd-ports-gnome-a0c81c6019b74a837aea9a7262e71ee091217f83.zip
use wc command for check file size.
slower but more portable than using ls
Diffstat (limited to 'www')
-rw-r--r--www/thumbnail_index/Makefile1
-rw-r--r--www/thumbnail_index/files/patch-ab11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/thumbnail_index/Makefile b/www/thumbnail_index/Makefile
index 05acd4354b15..0c0a2f8c37a3 100644
--- a/www/thumbnail_index/Makefile
+++ b/www/thumbnail_index/Makefile
@@ -7,6 +7,7 @@
PORTNAME= thumbnail_index
PORTVERSION= 1998.08.10
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.acme.com/software/thumbnail_index/
DISTNAME= ${PORTNAME}_10aug98
diff --git a/www/thumbnail_index/files/patch-ab b/www/thumbnail_index/files/patch-ab
new file mode 100644
index 000000000000..deb32a163ea1
--- /dev/null
+++ b/www/thumbnail_index/files/patch-ab
@@ -0,0 +1,11 @@
+--- thumbnail_index.orig Tue Aug 11 03:51:55 1998
++++ thumbnail_index Sat Jun 16 17:56:31 2001
+@@ -248,7 +248,7 @@
+ EOF
+ )
+ fi
+- kb=`ls -l "$file" | awk '{print int(($4+1023)/1024)}'`
++ kb=`wc -c < "$file" | awk '{print int(($1+1023)/1024)}'`
+ echo "<TD ALIGN=CENTER><TABLE><TR><TD ALIGN=CENTER><A HREF=\"$file\"><IMG BORDER=0 WIDTH=20 HEIGHT=22 SRC=\"$subdir/.file.gif\"></A></TD></TR><TR><TD ALIGN=CENTER><SMALL><A HREF=\"$file\">$file</A></SMALL></TD></TR><TR><TD ALIGN=CENTER><SMALL>${kb}K</SMALL></TD></TR></TABLE></TD>"
+ fi
+ ;;