aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2013-12-31 04:06:21 +0800
committerdinoex <dinoex@FreeBSD.org>2013-12-31 04:06:21 +0800
commita2e89935eed23e71e96e4cd002f2201249a40d6f (patch)
tree76c8747c1bd60a8fe568a28601b3a5d35aa96b1a /www
parent6810dd43a6bfc4fc073331efa2a777f647ad158a (diff)
downloadfreebsd-ports-gnome-a2e89935eed23e71e96e4cd002f2201249a40d6f.tar.gz
freebsd-ports-gnome-a2e89935eed23e71e96e4cd002f2201249a40d6f.tar.zst
freebsd-ports-gnome-a2e89935eed23e71e96e4cd002f2201249a40d6f.zip
- add more sources of libstdc++.so.6
Diffstat (limited to 'www')
-rw-r--r--www/opera/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/www/opera/Makefile b/www/opera/Makefile
index 8dfd6a191f3c..cf725b7700b2 100644
--- a/www/opera/Makefile
+++ b/www/opera/Makefile
@@ -38,13 +38,18 @@ MANCOMPRESSED= yes
NO_BUILD= yes
EXPLICIT_PACKAGE_DEPENDS= yes
-OPTIONS_DEFINE= CUPS VIDEO GTK2 KDE4 COMPAT9
-OPTIONS_DEFAULT= CUPS VIDEO
+OPTIONS_DEFINE= CUPS VIDEO GTK2 KDE4
+OPTIONS_SINGLE= LIBSTDCXX
+OPTIONS_SINGLE_LIBSTDCXX= COMPAT9 GCCXX GCC42 GCC46
+OPTIONS_DEFAULT= CUPS VIDEO COMPAT9
NO_OPTIONS_SORT=yes
CUPS_DESC= support for printing (requires CUPS)
VIDEO_DESC= support for HTML5 video (requires GStreamer)
-COMPAT9_DESC= use libstdc++.so.6 from compat9x instead of gcc46
+COMPAT9_DESC= use libstdc++.so.6 from compat9x
+GCCXX_DESC= use libstdc++.so.6 from lang/gcc
+GCC42_DESC= use libstdc++.so.6 from lang/gcc42
+GCC46_DESC= use libstdc++.so.6 from lang/gcc46
CUPS_LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client
@@ -86,9 +91,16 @@ IGNORE= only for FreeBSD 7.x and higher
.if ${OSVERSION} >= 1000054
.if ${PORT_OPTIONS:MCOMPAT9}
RUN_DEPENDS+= ${LOCALBASE}/lib/compat/libstdc++.so.6:${PORTSDIR}/misc/compat9x
-.else
+.endif
+.if ${PORT_OPTIONS:MGCC42}
+RUN_DEPENDS+= ${LOCALBASE}/lib/gcc42/libstdc++.so.6:${PORTSDIR}/lang/gcc42
+.endif
+.if ${PORT_OPTIONS:MGCC46}
RUN_DEPENDS+= ${LOCALBASE}/lib/gcc46/libstdc++.so.6:${PORTSDIR}/lang/gcc46
.endif
+.if ${PORT_OPTIONS:MGCCXX}
+RUN_DEPENDS+= ${LOCALBASE}/lib/gcc46/libstdc++.so.6:${PORTSDIR}/lang/gcc
+.endif
.endif
post-extract: