aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-02-19 06:19:24 +0800
committeraaron <aaron@FreeBSD.org>2006-02-19 06:19:24 +0800
commita2f1d8dfe536f794c52a2237547715e7617e7173 (patch)
tree2816c3895380b04c1ffa7cfaef5b438a3287b9ea /www
parentc6e2f146bc3fcad27a64cbf108466a8c39679489 (diff)
downloadfreebsd-ports-gnome-a2f1d8dfe536f794c52a2237547715e7617e7173.tar.gz
freebsd-ports-gnome-a2f1d8dfe536f794c52a2237547715e7617e7173.tar.zst
freebsd-ports-gnome-a2f1d8dfe536f794c52a2237547715e7617e7173.zip
Adding port www/p5-Geo-Caching, an Object interface for querying Geocaching.com website.
Committed by: aaron Approved by: tobez (implicit)
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Geo-Caching/Makefile32
-rw-r--r--www/p5-Geo-Caching/distinfo3
-rw-r--r--www/p5-Geo-Caching/pkg-descr4
-rw-r--r--www/p5-Geo-Caching/pkg-plist5
5 files changed, 45 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a63d51e86339..e7ec3298f026 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -552,6 +552,7 @@
SUBDIR += p5-Feed-Find
SUBDIR += p5-Flickr-API
SUBDIR += p5-Flickr-Upload
+ SUBDIR += p5-Geo-Caching
SUBDIR += p5-HTML
SUBDIR += p5-HTML-Breadcrumbs
SUBDIR += p5-HTML-CalendarMonthSimple
diff --git a/www/p5-Geo-Caching/Makefile b/www/p5-Geo-Caching/Makefile
new file mode 100644
index 000000000000..1c9fc11bb01d
--- /dev/null
+++ b/www/p5-Geo-Caching/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Geo-Caching
+# Date created: 18 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Caching
+PORTVERSION= 0.11
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Geo
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Object interface for querying Geocaching.com website
+
+BUILD_DEPENDS= ${SITE_PERL}/Geo/Cache.pm:${PORTSDIR}/misc/p5-Geo-Cache \
+ ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+MAN3= Geo::Caching.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl5.8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Geo-Caching/distinfo b/www/p5-Geo-Caching/distinfo
new file mode 100644
index 000000000000..fbb044852a5e
--- /dev/null
+++ b/www/p5-Geo-Caching/distinfo
@@ -0,0 +1,3 @@
+MD5 (Geo-Caching-0.11.tar.gz) = dfb3212063ff34c392ddfb697699b868
+SHA256 (Geo-Caching-0.11.tar.gz) = 0fff1b2457cd69d5287e044a6ed4f704d4c6507b464a38662014015984af68fc
+SIZE (Geo-Caching-0.11.tar.gz) = 4671
diff --git a/www/p5-Geo-Caching/pkg-descr b/www/p5-Geo-Caching/pkg-descr
new file mode 100644
index 000000000000..e9a51499a083
--- /dev/null
+++ b/www/p5-Geo-Caching/pkg-descr
@@ -0,0 +1,4 @@
+Provides an object interface to query Geocaching.com
+
+WWW: http://search.cpan.org/dist/Geo-Caching
+Author: Casey Lee <cplee@cplee.org>
diff --git a/www/p5-Geo-Caching/pkg-plist b/www/p5-Geo-Caching/pkg-plist
new file mode 100644
index 000000000000..b06d8c463575
--- /dev/null
+++ b/www/p5-Geo-Caching/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Geo/Caching.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Caching/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Caching
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrm %%SITE_PERL%%/Geo