aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsylvio <sylvio@FreeBSD.org>2013-01-11 04:48:36 +0800
committersylvio <sylvio@FreeBSD.org>2013-01-11 04:48:36 +0800
commita7107c0641788f5aec71e38397818d0334938cd8 (patch)
tree3a48c90b090d3da0d33d0bf6fb0589b65e846416 /www
parent59439f793c35d2ebcd90f95af731adef2e040bfa (diff)
downloadfreebsd-ports-gnome-a7107c0641788f5aec71e38397818d0334938cd8.tar.gz
freebsd-ports-gnome-a7107c0641788f5aec71e38397818d0334938cd8.tar.zst
freebsd-ports-gnome-a7107c0641788f5aec71e38397818d0334938cd8.zip
- Update to 2.2.3
- New file pkg-message due of update tidy Submitted by: bar@ (private mail)
Diffstat (limited to 'www')
-rw-r--r--www/bluefish/Makefile33
-rw-r--r--www/bluefish/distinfo4
-rw-r--r--www/bluefish/pkg-message11
-rw-r--r--www/bluefish/pkg-plist7
4 files changed, 36 insertions, 19 deletions
diff --git a/www/bluefish/Makefile b/www/bluefish/Makefile
index f7602723ca31..22cbcd65a8a1 100644
--- a/www/bluefish/Makefile
+++ b/www/bluefish/Makefile
@@ -1,14 +1,8 @@
-# New ports collection makefile for: bluefish
-# Date created: 23 January 2003
-# Whom: Koop Mast <einekoai@chello.nl>
-#
+# Created by: Koop Mast <einekoai@chello.nl>
# $FreeBSD$
-# $MCom: ports/www/bluefish/Makefile,v 1.6 2007/10/11 03:20:30 mezz Exp $
-#
PORTNAME= bluefish
-PORTVERSION= 2.2.2
-PORTREVISION= 2
+PORTVERSION= 2.2.3
CATEGORIES= www editors
MASTER_SITES= http://www.bennewitz.com/bluefish/stable/source/ \
http://bluefish.mrball.net/stable/source/ \
@@ -38,18 +32,22 @@ CONFIGURE_ARGS= --with-gtk2 \
MAN1= bluefish.1
-OPTIONS= DEBUG "Enable debugging output" Off \
- TIDY "Include Tidy HTML cleanup program" Off \
- WEBLINT "Include Weblint syntax and style checker" On
+OPTIONS_DEFINE= DEBUG TIDY WEBLINT
+
+DEBUG_DESC= Enable debugging output
+TIDY_DESC= Include Tidy HTML cleanup program
+WEBLINT_DESC= Include Weblint syntax and style checker
+
+OPTIONS_DEFAULT= WEBLINT
.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${HAVE_GNOME:Mlibgnomeui}!=""
USE_GNOME+= libgnomeui
.endif
-# Turns debugging output on
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --with-debugging-output
.endif
@@ -61,10 +59,11 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
-.if defined(WITH_TIDY)
-RUN_DEPENDS+= tidy:${PORTSDIR}/www/tidy
+.if ${PORT_OPTIONS:MTIDY}
+RUN_DEPENDS+= tidy4:${PORTSDIR}/www/tidy
.endif
-.if !defined(WITHOUT_WEBLINT)
+
+.if ${PORT_OPTIONS:MWEBLINT}
RUN_DEPENDS+= weblint:${PORTSDIR}/www/weblint
.endif
@@ -72,7 +71,7 @@ pre-install:
@${MKDIR} ${PREFIX}/share/mime
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${MKDIR} ${DOCSDIR}/bflang
${INSTALL_DATA} ${WRKSRC}/data/bflang/sample.bflang2 ${DOCSDIR}/bflang
diff --git a/www/bluefish/distinfo b/www/bluefish/distinfo
index 40d590c3cf49..29bb6f81dd11 100644
--- a/www/bluefish/distinfo
+++ b/www/bluefish/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bluefish-2.2.2.tar.bz2) = 1e9f171657cd7d34e31d7ff8608b10dded56dcb4831bc75d6ab75cd826f97b84
-SIZE (bluefish-2.2.2.tar.bz2) = 3548284
+SHA256 (bluefish-2.2.3.tar.bz2) = be284cd972d82b56a55f9b9588b3c0ff18702318822f45c7598c336de8a4d6ea
+SIZE (bluefish-2.2.3.tar.bz2) = 3635489
diff --git a/www/bluefish/pkg-message b/www/bluefish/pkg-message
new file mode 100644
index 000000000000..95388682c8b2
--- /dev/null
+++ b/www/bluefish/pkg-message
@@ -0,0 +1,11 @@
+$FreeBSD$
+----------------------------------------------------------------------------
+WARNING:
+
+DUE CHANGE OF tidy to tidy4
+
+If ~/.bluefish exists, the commands should be manually fixed opening the
+preferences window (Edit->Preferences) and then changing tidy to tidy4 in
+"External filters" and "Output parser" preferences.
+
+----------------------------------------------------------------------------
diff --git a/www/bluefish/pkg-plist b/www/bluefish/pkg-plist
index 31dd0f4b36d3..ded88f56ae7a 100644
--- a/www/bluefish/pkg-plist
+++ b/www/bluefish/pkg-plist
@@ -84,6 +84,11 @@ share/applications/bluefish.desktop
%%DATADIR%%/bluefish_splash.png
%%DATADIR%%/default_accelmap
%%DATADIR%%/encodings
+%%DATADIR%%/lorem-ipsum-generator
+%%DATADIR%%/lipsum/__init__.py
+%%DATADIR%%/lipsum/data/dictionary.txt
+%%DATADIR%%/lipsum/data/lipsum.xml
+%%DATADIR%%/lipsum/data/sample.txt
%%DATADIR%%/plugins/htmlbar/ui/htmlbar_menu_ui.xml
%%DATADIR%%/plugins/zencoding/__init__.py
%%DATADIR%%/plugins/zencoding/html_matcher.py
@@ -412,6 +417,8 @@ share/xml/bluefish/catalog.xml
@dirrm %%DATADIR%%/plugins/htmlbar/ui
@dirrm %%DATADIR%%/plugins/htmlbar
@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%/lipsum/data
+@dirrm %%DATADIR%%/lipsum
@dirrm %%DATADIR%%/bflib
@dirrm %%DATADIR%%/bflang
@dirrm %%DATADIR%%