aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-10-12 12:06:32 +0800
committerdinoex <dinoex@FreeBSD.org>2004-10-12 12:06:32 +0800
commita7900d1958a5dceaad39938b7100d2583718285e (patch)
treebf5befa79b53c458df9a197bd9f992a902389a30 /www
parentdcb092fba08d5d7e09f82d8601ec23712711e23a (diff)
downloadfreebsd-ports-gnome-a7900d1958a5dceaad39938b7100d2583718285e.tar.gz
freebsd-ports-gnome-a7900d1958a5dceaad39938b7100d2583718285e.tar.zst
freebsd-ports-gnome-a7900d1958a5dceaad39938b7100d2583718285e.zip
- Patch for keepalive-bug
PR: 71961 Submitted by: Kenneth Vestergaard Schmidt
Diffstat (limited to 'www')
-rw-r--r--www/apache13-modssl/Makefile1
-rw-r--r--www/apache13-modssl/files/patch-http_request.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/apache13-modssl/Makefile b/www/apache13-modssl/Makefile
index e69880dbb481..5f4fb8edc924 100644
--- a/www/apache13-modssl/Makefile
+++ b/www/apache13-modssl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= apache+mod_ssl
PORTVERSION= ${VERSION_APACHE}+${VERSION_MODSSL}
+PORTREVISION?= 1
CATEGORIES?= www security
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
${MASTER_SITES_MODSSL:S/$/:mod_ssl/} \
diff --git a/www/apache13-modssl/files/patch-http_request.c b/www/apache13-modssl/files/patch-http_request.c
new file mode 100644
index 000000000000..e4642e4f2d27
--- /dev/null
+++ b/www/apache13-modssl/files/patch-http_request.c
@@ -0,0 +1,11 @@
+--- src/main/http_request.c.bak Wed Apr 28 20:58:42 2004
++++ src/main/http_request.c Mon Jun 14 17:11:06 2004
+@@ -1056,7 +1056,7 @@
+ */
+ if ((r->status != HTTP_NOT_MODIFIED) && (r->status != HTTP_NO_CONTENT)
+ && !ap_status_drops_connection(r->status)
+- && r->connection && (r->connection->keepalive > 0)) {
++ && r->connection && (r->connection->keepalive != -1)) {
+
+ (void) ap_discard_request_body(r);
+ }