aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-05-26 05:12:46 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-05-26 05:12:46 +0800
commita99351c2f5b1239214c549d9320f292a22dcf659 (patch)
tree8f9d1c6dc84ea6f0b6d1fcd65d52d579666d2f40 /www
parent8b9b8c66342fe8265eabacdbc51fd6313ec3ea7e (diff)
downloadfreebsd-ports-gnome-a99351c2f5b1239214c549d9320f292a22dcf659.tar.gz
freebsd-ports-gnome-a99351c2f5b1239214c549d9320f292a22dcf659.tar.zst
freebsd-ports-gnome-a99351c2f5b1239214c549d9320f292a22dcf659.zip
Smooth Streaming Module for Apache. Encode your content once
and playback on Silverlight, iPhone and Flash 10.1. Advantages & features: * It's HTTP-based, so no problems with firewalls. * It's cache/proxy friendly, so you can use generic HTTP caches/proxies. * It's cheap, there is no need for additional media streaming services offered by hosting providers. * The end user will appreciate the fast starting and seeking anywhere in the video. * The video dynamically adapts to network conditions. * It uses the industry standard MPEG4 file format. * Use your favourite open source software (X264) to encode your videos. * Encoded content is compatible with both Smooth Streaming for Silverlight as well as for HTTP Streaming to the iPhone. WWW: http://smoothstreaming.code-shop.com/trac/wiki/Mod-Smooth-Streaming-Apache PR: ports/146967 Submitted by: Marcus Hermansson <bmhermansson at gmail.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_smooth_streaming/Makefile36
-rw-r--r--www/mod_smooth_streaming/distinfo3
-rw-r--r--www/mod_smooth_streaming/files/pkg-message.in11
-rw-r--r--www/mod_smooth_streaming/pkg-descr18
-rw-r--r--www/mod_smooth_streaming/pkg-plist4
6 files changed, 73 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 560065def9da..d83dc32f01d4 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -544,6 +544,7 @@
SUBDIR += mod_sed
SUBDIR += mod_sequester
SUBDIR += mod_shapvh
+ SUBDIR += mod_smooth_streaming
SUBDIR += mod_sqlinclude
SUBDIR += mod_ticket
SUBDIR += mod_tidy
diff --git a/www/mod_smooth_streaming/Makefile b/www/mod_smooth_streaming/Makefile
new file mode 100644
index 000000000000..63abb369f71b
--- /dev/null
+++ b/www/mod_smooth_streaming/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: mod_smooth_streaming
+# Date created: May 25, 2010
+# Whom: Marcus Hermansson <bmhermansson@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_smooth_streaming
+PORTVERSION= 1.0.8
+CATEGORIES= www
+MASTER_SITES= http://smoothstreaming.code-shop.com/download/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
+DISTNAME= apache_${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= apache22
+
+MAINTAINER=
+COMMENT= Apache smooth streaming module
+
+RESTRICTED= no-commercial-use
+
+USE_APACHE= 22+
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-apxs=${APXS}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+SUB_LIST+= APACHEMODDIR=${APACHEMODDIR}
+
+post-install:
+ ${LOCALBASE}/sbin/apxs -e -a -n smooth_streaming ${LOCALBASE}/${APACHEMODDIR}/${PORTNAME}.so
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/mod_smooth_streaming/distinfo b/www/mod_smooth_streaming/distinfo
new file mode 100644
index 000000000000..1647cbf02bb9
--- /dev/null
+++ b/www/mod_smooth_streaming/distinfo
@@ -0,0 +1,3 @@
+MD5 (apache22/apache_mod_smooth_streaming-1.0.8.tar.gz) = 606db653147a609619e4477e2ae9af9a
+SHA256 (apache22/apache_mod_smooth_streaming-1.0.8.tar.gz) = 5820e8d2a72f806a7d06088c9908a01d829a2deb4ef6dd6124b41dbf8069d81a
+SIZE (apache22/apache_mod_smooth_streaming-1.0.8.tar.gz) = 328809
diff --git a/www/mod_smooth_streaming/files/pkg-message.in b/www/mod_smooth_streaming/files/pkg-message.in
new file mode 100644
index 000000000000..bcb3286bb20c
--- /dev/null
+++ b/www/mod_smooth_streaming/files/pkg-message.in
@@ -0,0 +1,11 @@
+***************************************************************
+
+To enable, add these lines to your main web server config:
+
+ LoadModule smooth_streaming_module %%APACHEMODDIR%%/mod_smooth_streaming.so
+ AddHandler smooth-streaming.extensions .ism
+
+For more information on how to configure, see
+http://smoothstreaming.code-shop.com/trac/wiki/Mod-Smooth-Streaming-Apache
+
+***************************************************************
diff --git a/www/mod_smooth_streaming/pkg-descr b/www/mod_smooth_streaming/pkg-descr
new file mode 100644
index 000000000000..58d41bedd5d9
--- /dev/null
+++ b/www/mod_smooth_streaming/pkg-descr
@@ -0,0 +1,18 @@
+Smooth Streaming Module for Apache. Encode your content once
+and playback on Silverlight, iPhone and Flash 10.1.
+
+Advantages & features:
+
+ * It's HTTP-based, so no problems with firewalls.
+ * It's cache/proxy friendly, so you can use generic HTTP caches/proxies.
+ * It's cheap, there is no need for additional media streaming
+ services offered by hosting providers.
+ * The end user will appreciate the fast starting and seeking
+ anywhere in the video.
+ * The video dynamically adapts to network conditions.
+ * It uses the industry standard MPEG4 file format.
+ * Use your favourite open source software (X264) to encode your videos.
+ * Encoded content is compatible with both Smooth Streaming for Silverlight
+ as well as for HTTP Streaming to the iPhone.
+
+WWW: http://smoothstreaming.code-shop.com/trac/wiki/Mod-Smooth-Streaming-Apache
diff --git a/www/mod_smooth_streaming/pkg-plist b/www/mod_smooth_streaming/pkg-plist
new file mode 100644
index 000000000000..2fca49fee40b
--- /dev/null
+++ b/www/mod_smooth_streaming/pkg-plist
@@ -0,0 +1,4 @@
+@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %D/%F
+%%APACHEMODDIR%%/%%AP_MODULE%%
+@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%F
+@unexec echo "Don't forget to remove all mod_smooth_streaming-related directives in your httpd.conf"