aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2006-08-05 12:18:45 +0800
committerahze <ahze@FreeBSD.org>2006-08-05 12:18:45 +0800
commitaaa67135b3fc8cec396bed155cec975ba04f24dd (patch)
tree6c66ec025ab670e47d3340e99a1630ee9d970a1b /www
parent780953df0faf84c52f934d1ff22adebf6b91ead6 (diff)
downloadfreebsd-ports-gnome-aaa67135b3fc8cec396bed155cec975ba04f24dd.tar.gz
freebsd-ports-gnome-aaa67135b3fc8cec396bed155cec975ba04f24dd.tar.zst
freebsd-ports-gnome-aaa67135b3fc8cec396bed155cec975ba04f24dd.zip
- Fix build with new gmake
- Use MASTER_SITES_MOZILLA_EXTENDED
Diffstat (limited to 'www')
-rw-r--r--www/mozilla-devel/Makefile10
-rw-r--r--www/mozilla-devel/files/patch-extensions_p3p_Makefile.in30
2 files changed, 32 insertions, 8 deletions
diff --git a/www/mozilla-devel/Makefile b/www/mozilla-devel/Makefile
index 13b10e387b3a..9fbe0521ff39 100644
--- a/www/mozilla-devel/Makefile
+++ b/www/mozilla-devel/Makefile
@@ -3,15 +3,14 @@
# Whom: eivind/dima/jseger
#
# $FreeBSD$
-# $MCom: ports/www/mozilla-devel/Makefile,v 1.10 2005/10/27 00:08:39 marcus Exp $
-#
+# $MCom: ports/www/mozilla-devel/Makefile,v 1.12 2006/07/18 15:05:56 ahze Exp $
PORTNAME?= mozilla
PORTVERSION= 1.8.b1
PORTREVISION?= 7
PORTEPOCH?= 2
CATEGORIES?= www
-MASTER_SITES= ${MASTER_SITE_MOZILLA}
+MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.b1/b1/}/source
DISTNAME= ${PORTNAME}-source-${PORTVERSION:S/.b1/b1/}
@@ -115,11 +114,6 @@ OPTIONS=CALENDAR "Enable the Calendar module" off \
IGNORE= core dumps on ${ARCH} during post-build
.endif
-.if exists(${X11BASE}/lib/X11/fonts/mozilla/fonts.dir)
-BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
- illegibly. Please remove the mozilla-fonts package
-.endif
-
.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
defined(WITHOUT_COMPOSER))
BROKEN= Calendar requires Composer and Mailnews support.
diff --git a/www/mozilla-devel/files/patch-extensions_p3p_Makefile.in b/www/mozilla-devel/files/patch-extensions_p3p_Makefile.in
new file mode 100644
index 000000000000..efade70e981b
--- /dev/null
+++ b/www/mozilla-devel/files/patch-extensions_p3p_Makefile.in
@@ -0,0 +1,30 @@
+--- extensions/p3p/Makefile.in.orig Sun Jul 9 14:10:16 2006
++++ extensions/p3p/Makefile.in Sun Jul 9 14:20:10 2006
+@@ -62,23 +62,23 @@
+ p3p200010.xsl: resources/content/p3p.xsl.in Makefile.in
+ @$(RM) -f $@
+ $(PP) -DNAMESPACE=http://www.w3.org/2000/10/18/P3Pv1 \
+- -DHAS_TMPL_RETENTION\
++ -DHAS_TMPL_RETENTION \
+ $< > $@
+
+ p3p200012.xsl: resources/content/p3p.xsl.in Makefile.in
+ @$(RM) -f $@
+ $(PP) -DNAMESPACE=http://www.w3.org/2000/12/P3Pv1 \
+- -DHAS_CALL_OURS\
++ -DHAS_CALL_OURS \
+ $< > $@
+
+ p3p200109.xsl: resources/content/p3p.xsl.in Makefile.in
+ @$(RM) -f $@
+ $(PP) -DNAMESPACE=http://www.w3.org/2001/09/P3Pv1 \
+- -DHAS_CALL_OURS\
++ -DHAS_CALL_OURS \
+ $< > $@
+
+ p3p200201.xsl: resources/content/p3p.xsl.in Makefile.in
+ @$(RM) -f $@
+ $(PP) -DNAMESPACE=http://www.w3.org/2002/01/P3Pv1 \
+- -DHAS_CALL_OURS -DHAS_PURPOSE_SRC\
++ -DHAS_CALL_OURS -DHAS_PURPOSE_SRC \
+ $< > $@