aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2016-10-28 21:47:26 +0800
committerfeld <feld@FreeBSD.org>2016-10-28 21:47:26 +0800
commitab142d347c7f2d6270d619e821128bacde4546ab (patch)
tree3a4833a3d6474a0c3df9a91f691130c4555f66ad /www
parent8b807e5395f7304d8a3de70a1067242c644922cb (diff)
downloadfreebsd-ports-gnome-ab142d347c7f2d6270d619e821128bacde4546ab.tar.gz
freebsd-ports-gnome-ab142d347c7f2d6270d619e821128bacde4546ab.tar.zst
freebsd-ports-gnome-ab142d347c7f2d6270d619e821128bacde4546ab.zip
www/node: Update to 6.9.1
Bump to the latest upstream 6.x release. Node.js v6 is now an LTS release, see the v6.9.0 release announcement for details. The v6.9.0 release was also a security release, while v6.9.1 fixes a regression introduced in v6.8.0. Cleanup clang vs. gcc handling by using USES=compiler:c++-lib https://nodejs.org/en/blog/release/v6.9.0/ https://nodejs.org/en/blog/release/v6.9.1/ https://nodejs.org/en/blog/vulnerability/october-2016-security-releases/ PR: 213604 Security: CVE-2016-5180
Diffstat (limited to 'www')
-rw-r--r--www/node/Makefile19
-rw-r--r--www/node/distinfo6
2 files changed, 7 insertions, 18 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index 49d9a0259d6d..5fb54caba01c 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= node
-PORTVERSION= 6.8.0
+PORTVERSION= 6.9.1
DISTVERSIONPREFIX= v
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
@@ -22,11 +22,11 @@ BUNDLED_SSL_CONFIGURE_OFF+= --shared-openssl
NLS_CONFIGURE_ON= --with-intl=system-icu
NLS_LIB_DEPENDS= libicui18n.so:devel/icu
-USES= compiler execinfo gmake python:2,build pkgconfig localbase
+USES= compiler:c++11-lib execinfo gmake python:2,build pkgconfig localbase
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFLICTS_INSTALL= node4-* node-0.[02-9][0-9]* node-devel-0.[0-9]* node010-[0-9]* node012-[0-9]* iojs-[0-9]*
+CONFLICTS_INSTALL= node4-4.* node012-0.12.* node010-0.10.* node-devel-[0-9]* iojs-[0-9]*
ONLY_FOR_ARCHS= i386 amd64 armv6
CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} \
@@ -65,18 +65,7 @@ IGNORE= cannot build node.js with LibreSSL. You must enable BUNDLED_SSL
CONFIGURE_ARGS= --openssl-no-asm
.endif
-.if ${COMPILER_TYPE} == clang
-MAKE_ENV+= LINK=clang++
-CFLAGS+= -Wno-unused-private-field
-.if ${COMPILER_VERSION} >= 33
-CFLAGS+= -Wno-nested-anon-types -Wno-unused-function
-.if ${COMPILER_VERSION} >= 34
-CFLAGS+= -Wno-unused-const-variable
-.endif
-.endif
-.else
-MAKE_ARGS+= strictaliasing=off
-USE_GCC= yes
+.if ${COMPILER_TYPE} == gcc
# GCC does not expose std::snprintf() without this define
CXXFLAGS+= -D_GLIBCXX_USE_C99
.endif
diff --git a/www/node/distinfo b/www/node/distinfo
index f52b8ad70a7b..3a93c9ca04ae 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1476306017
-SHA256 (node-v6.8.0.tar.gz) = a8a2d4b74734991dd45e5b2b0b13617864f1283f6d6bc262e1e4d30741114352
-SIZE (node-v6.8.0.tar.gz) = 26502047
+TIMESTAMP = 1476953621
+SHA256 (node-v6.9.1.tar.gz) = a98997ca3a4d10751f0ebe97839b2308a31ae884b4203cda0c99cf36bc7fe3bf
+SIZE (node-v6.9.1.tar.gz) = 26504341