aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-09-04 17:48:07 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-09-04 17:48:07 +0800
commitac7d4c905c8d9d2adbd85f6b99350551b79225f1 (patch)
treec6e13405d3b50df6082d4afe286f0e77e804aab5 /www
parent287680e92511208fff55005e48046e57897c8636 (diff)
downloadfreebsd-ports-gnome-ac7d4c905c8d9d2adbd85f6b99350551b79225f1.tar.gz
freebsd-ports-gnome-ac7d4c905c8d9d2adbd85f6b99350551b79225f1.tar.zst
freebsd-ports-gnome-ac7d4c905c8d9d2adbd85f6b99350551b79225f1.zip
- Update to 0.46
Changes: http://search.cpan.org/dist/WWW-Contact/Changes PR: ports/160453 Submitted by: sunpoet (myself) Approved by: Fred Cox <sailorfred@yahoo.com> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/p5-WWW-Contact/Makefile72
-rw-r--r--www/p5-WWW-Contact/distinfo4
2 files changed, 41 insertions, 35 deletions
diff --git a/www/p5-WWW-Contact/Makefile b/www/p5-WWW-Contact/Makefile
index 33af811e69bb..685ac27ab1d1 100644
--- a/www/p5-WWW-Contact/Makefile
+++ b/www/p5-WWW-Contact/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= WWW-Contact
-PORTVERSION= 0.43
+PORTVERSION= 0.46
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:FAYLAND
@@ -15,38 +15,44 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sailorfred@yahoo.com
COMMENT= Contact importer for all the major email systems
-RUN_DEPENDS= ${SITE_PERL}/HTML/TokeParser/Simple.pm:${PORTSDIR}/www/p5-HTML-TokeParser-Simple \
- ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize \
- ${SITE_PERL}/HTML/TreeBuilder.pm:${PORTSDIR}/www/p5-HTML-Tree \
- ${SITE_PERL}/${PERL_ARCH}/JSON/XS.pm:${PORTSDIR}/converters/p5-JSON-XS \
- ${SITE_PERL}/Text/vCard/Addressbook.pm:${PORTSDIR}/textproc/p5-Text-vCard \
- ${SITE_PERL}/WWW/Mechanize/GZip.pm:${PORTSDIR}/www/p5-WWW-Mechanize-GZip \
- ${SITE_PERL}/Net/Google/AuthSub.pm:${PORTSDIR}/net/p5-Net-Google-AuthSub \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
- ${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/${PERL_ARCH}/Moose.pm:${PORTSDIR}/devel/p5-Moose \
- ${SITE_PERL}/${PERL_ARCH}/Net/DNS/Resolver.pm:${PORTSDIR}/dns/p5-Net-DNS
-
-LICENSE_COMB= dual
LICENSE= ART20 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-HTML-TokeParser-Simple>=0:${PORTSDIR}/www/p5-HTML-TokeParser-Simple \
+ p5-HTML-Tree>=0:${PORTSDIR}/www/p5-HTML-Tree \
+ p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-Moose>=0.77:${PORTSDIR}/devel/p5-Moose \
+ p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
+ p5-Net-Google-AuthSub>=0:${PORTSDIR}/net/p5-Net-Google-AuthSub \
+ p5-Text-vCard>=0:${PORTSDIR}/textproc/p5-Text-vCard \
+ p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize \
+ p5-WWW-Mechanize-GZip>=0:${PORTSDIR}/www/p5-WWW-Mechanize-GZip
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-USE_PERL5= yes
-
-MAN3= WWW::Contact.3 \
- WWW::Contact::Base.3 \
- WWW::Contact::Plaxo.3\
- WWW::Contact::Rediffmail.3 \
- WWW::Contact::CN::163.3 \
- WWW::Contact::GoogleContactsAPI.3 \
- WWW::Contact::Lycos.3 \
- WWW::Contact::Yahoo.3 \
- WWW::Contact::Indiatimes.3 \
- WWW::Contact::BG::Abv.3 \
- WWW::Contact::BG::Mail.3 \
- WWW::Contact::Mail.3 \
- WWW::Contact::Hotmail.3 \
- WWW::Contact::AOL.3 \
- WWW::Contact::Gmail.3
-
-.include <bsd.port.mk>
+
+MAN3= WWW::Contact.3 \
+ WWW::Contact::AOL.3 \
+ WWW::Contact::BG::Abv.3 \
+ WWW::Contact::BG::Mail.3 \
+ WWW::Contact::Base.3 \
+ WWW::Contact::CN::163.3 \
+ WWW::Contact::Gmail.3 \
+ WWW::Contact::GoogleContactsAPI.3 \
+ WWW::Contact::Hotmail.3 \
+ WWW::Contact::Indiatimes.3 \
+ WWW::Contact::Lycos.3 \
+ WWW::Contact::Mail.3 \
+ WWW::Contact::Plaxo.3 \
+ WWW::Contact::Rediffmail.3 \
+ WWW::Contact::Yahoo.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.90:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-Contact/distinfo b/www/p5-WWW-Contact/distinfo
index f9851c6eb369..828b45a11c1c 100644
--- a/www/p5-WWW-Contact/distinfo
+++ b/www/p5-WWW-Contact/distinfo
@@ -1,2 +1,2 @@
-SHA256 (WWW-Contact-0.43.tar.gz) = 0b575fbe094ad05b5fb267e811d3a8540ffa249d990ecdfaafc134658bc93219
-SIZE (WWW-Contact-0.43.tar.gz) = 24181
+SHA256 (WWW-Contact-0.46.tar.gz) = d2b0b5805a0788c18d8b5201a9be6a5c9f97103937e83780dbae96703c1bd297
+SIZE (WWW-Contact-0.46.tar.gz) = 22187