aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-09-11 03:10:08 +0800
committerpi <pi@FreeBSD.org>2016-09-11 03:10:08 +0800
commitb1a62253aac304d473395128091791ce6bbd77a9 (patch)
treeb2011b4cb90fa853bed911ef0e5875a4412a5ae6 /www
parentb0b339d01f912dfdaccb97f53d370b885c1ec135 (diff)
downloadfreebsd-ports-gnome-b1a62253aac304d473395128091791ce6bbd77a9.tar.gz
freebsd-ports-gnome-b1a62253aac304d473395128091791ce6bbd77a9.tar.zst
freebsd-ports-gnome-b1a62253aac304d473395128091791ce6bbd77a9.zip
New port: www/mod_auth_gssapi
This module adds support for single-sign-on authentication via GSSAPI to the Apache httpd. It is intended as a successor to mod_auth_kerb. WWW: https://github.com/modauthgssapi/mod_auth_gssapi PR: 212325 Submitted by: chris@chrullrich.net
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_auth_gssapi/Makefile48
-rw-r--r--www/mod_auth_gssapi/distinfo3
-rw-r--r--www/mod_auth_gssapi/files/240_mod_auth_gssapi.conf.sample.in9
-rw-r--r--www/mod_auth_gssapi/pkg-descr4
5 files changed, 65 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ab9383f35936..dc97e224e8f9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -411,6 +411,7 @@
SUBDIR += mod_auth_cas
SUBDIR += mod_auth_cookie_mysql2
SUBDIR += mod_auth_external2
+ SUBDIR += mod_auth_gssapi
SUBDIR += mod_auth_imap2
SUBDIR += mod_auth_kerb2
SUBDIR += mod_auth_mysql2
diff --git a/www/mod_auth_gssapi/Makefile b/www/mod_auth_gssapi/Makefile
new file mode 100644
index 000000000000..122fb40261a9
--- /dev/null
+++ b/www/mod_auth_gssapi/Makefile
@@ -0,0 +1,48 @@
+# $FreeBSD$
+
+PORTNAME= mod_auth_gssapi
+PORTVERSION= 1.4.1
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
+
+MAINTAINER= chris@chrullrich.net
+COMMENT= Apache module for authenticating users with GSSAPI
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GITHUB= yes
+GH_ACCOUNT= modauthgssapi
+
+USE_APACHE= 24+
+USES= autoreconf libtool ssl gssapi:mit,flags
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= KRB5_CONFIG=${KRB5CONFIG}
+CONFIGURE_ARGS+= OPENSSL_CFLAGS=-I${OPENSSLINC}
+CONFIGURE_ARGS+= OPENSSL_LIBS=-lcrypto
+
+PLIST_FILES= @sample\ %%APACHEETCDIR%%/modules.d/%%APMOD_FILE%% \
+ %%APACHEMODDIR%%/mod_auth_gssapi.so
+
+SUB_FILES= ${APMOD_FILE}
+APMOD_FILE= 240_${PORTNAME}.conf.sample
+PLIST_SUB+= APMOD_FILE=${APMOD_FILE}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000000 && ${SSL_DEFAULT} == base
+IGNORE= mod_auth_gssapi requires OpenSSL 1.0.0+
+.elif ${SSL_DEFAULT:Mlibressl*}
+IGNORE= mod_auth_gssapi currently only supports OpenSSL
+.endif
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
+ ${APXS} -S LIBEXECDIR=${STAGEDIR}${PREFIX}/${APACHEMODDIR} \
+ -i -n ${MODULENAME} ${WRKSRC}/src/${MODULENAME}.la
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/modules.d
+ ${INSTALL_DATA} ${WRKDIR}/${APMOD_FILE} ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/modules.d
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/${MODULENAME}.so
+
+.include <bsd.port.post.mk>
diff --git a/www/mod_auth_gssapi/distinfo b/www/mod_auth_gssapi/distinfo
new file mode 100644
index 000000000000..cf59526955e8
--- /dev/null
+++ b/www/mod_auth_gssapi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1473058147
+SHA256 (modauthgssapi-mod_auth_gssapi-v1.4.1_GH0.tar.gz) = bd2209f6b41d6334dd06d880d0c0ff3c06cebb3cd7457fc3fb5fc57b7b97803e
+SIZE (modauthgssapi-mod_auth_gssapi-v1.4.1_GH0.tar.gz) = 102871
diff --git a/www/mod_auth_gssapi/files/240_mod_auth_gssapi.conf.sample.in b/www/mod_auth_gssapi/files/240_mod_auth_gssapi.conf.sample.in
new file mode 100644
index 000000000000..5816e6f2ba8e
--- /dev/null
+++ b/www/mod_auth_gssapi/files/240_mod_auth_gssapi.conf.sample.in
@@ -0,0 +1,9 @@
+## $FreeBSD$
+## vim: set filetype=apache:
+##
+## module file for mod_auth_gssapi
+##
+## PROVIDE: mod_auth_gssapi
+## REQUIRE:
+
+#LoadModule auth_gssapi_module %%APACHEMODDIR%%/mod_auth_gssapi.so
diff --git a/www/mod_auth_gssapi/pkg-descr b/www/mod_auth_gssapi/pkg-descr
new file mode 100644
index 000000000000..b65ed0a735aa
--- /dev/null
+++ b/www/mod_auth_gssapi/pkg-descr
@@ -0,0 +1,4 @@
+This module adds support for single-sign-on authentication via GSSAPI
+to the Apache httpd. It is intended as a successor to mod_auth_kerb.
+
+WWW: https://github.com/modauthgssapi/mod_auth_gssapi