aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2007-12-19 08:04:50 +0800
committerbeech <beech@FreeBSD.org>2007-12-19 08:04:50 +0800
commitb3fce03b554b9a62ddf5ea8d8be6797ebe64924d (patch)
treece0d0ff42ca4e4c95c7e3b5535d021f15753027f /www
parentf1c3b00d9dfe1811946eba65c573734f0d60bf54 (diff)
downloadfreebsd-ports-gnome-b3fce03b554b9a62ddf5ea8d8be6797ebe64924d.tar.gz
freebsd-ports-gnome-b3fce03b554b9a62ddf5ea8d8be6797ebe64924d.tar.zst
freebsd-ports-gnome-b3fce03b554b9a62ddf5ea8d8be6797ebe64924d.zip
- Fix bug "isspace broken for UTF-8 locales."
Causes Japanese characters to display improperly. PR: ports/116363 Submitted by: Hiromi Kimura <hiromi@tac.tsukuba.ac.jp> Approved by: linimon (mentor)
Diffstat (limited to 'www')
-rw-r--r--www/horde-base/Makefile1
-rw-r--r--www/horde-base/files/patch-lib_Horde_NLS.php13
-rw-r--r--www/horde4-base/Makefile1
-rw-r--r--www/horde4-base/files/patch-lib_Horde_NLS.php13
4 files changed, 28 insertions, 0 deletions
diff --git a/www/horde-base/Makefile b/www/horde-base/Makefile
index ddcf639cd4bf..a680116737b8 100644
--- a/www/horde-base/Makefile
+++ b/www/horde-base/Makefile
@@ -8,6 +8,7 @@
PORTNAME= horde
DISTVERSIONPREFIX=
DISTVERSION= 3.1.5
+PORTREVISION= 1
CATEGORIES= www
PKGNAMEPREFIX=
PKGNAMESUFFIX= -base
diff --git a/www/horde-base/files/patch-lib_Horde_NLS.php b/www/horde-base/files/patch-lib_Horde_NLS.php
new file mode 100644
index 000000000000..8e157c276647
--- /dev/null
+++ b/www/horde-base/files/patch-lib_Horde_NLS.php
@@ -0,0 +1,13 @@
+--- lib/Horde/NLS.php.orig 2007-09-29 07:22:46.000000000 -0800
++++ lib/Horde/NLS.php 2007-12-18 11:16:03.000000000 -0900
+@@ -119,6 +119,10 @@
+ setlocale(LC_ALL, $lang_charset);
+ }
+ }
++        /* avoid FreeBSD issapce(3) bug */
++        if(NLS::getCharset() == "UTF-8"){
++            setlocale(LC_CTYPE,"C");
++        }
+ @putenv('LANG=' . $lang_charset);
+ @putenv('LANGUAGE=' . $lang_charset);
+ }
diff --git a/www/horde4-base/Makefile b/www/horde4-base/Makefile
index ddcf639cd4bf..a680116737b8 100644
--- a/www/horde4-base/Makefile
+++ b/www/horde4-base/Makefile
@@ -8,6 +8,7 @@
PORTNAME= horde
DISTVERSIONPREFIX=
DISTVERSION= 3.1.5
+PORTREVISION= 1
CATEGORIES= www
PKGNAMEPREFIX=
PKGNAMESUFFIX= -base
diff --git a/www/horde4-base/files/patch-lib_Horde_NLS.php b/www/horde4-base/files/patch-lib_Horde_NLS.php
new file mode 100644
index 000000000000..8e157c276647
--- /dev/null
+++ b/www/horde4-base/files/patch-lib_Horde_NLS.php
@@ -0,0 +1,13 @@
+--- lib/Horde/NLS.php.orig 2007-09-29 07:22:46.000000000 -0800
++++ lib/Horde/NLS.php 2007-12-18 11:16:03.000000000 -0900
+@@ -119,6 +119,10 @@
+ setlocale(LC_ALL, $lang_charset);
+ }
+ }
++        /* avoid FreeBSD issapce(3) bug */
++        if(NLS::getCharset() == "UTF-8"){
++            setlocale(LC_CTYPE,"C");
++        }
+ @putenv('LANG=' . $lang_charset);
+ @putenv('LANGUAGE=' . $lang_charset);
+ }