aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-07-06 14:45:43 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-07-06 14:45:43 +0800
commitb60f570b2c8179fa9b09a26afdc7d512ecd3eca3 (patch)
tree35d63e63e8181adfd5bb2ad55aaeaf6315c02aea /www
parent246f3da571698c3732e5651e741068fb09507702 (diff)
downloadfreebsd-ports-gnome-b60f570b2c8179fa9b09a26afdc7d512ecd3eca3.tar.gz
freebsd-ports-gnome-b60f570b2c8179fa9b09a26afdc7d512ecd3eca3.tar.zst
freebsd-ports-gnome-b60f570b2c8179fa9b09a26afdc7d512ecd3eca3.zip
- Add rubygem-jwt 0.1.4
JWT is a Ruby implementation of JSON Web Token draft 06 [1]. [1] http://self-issued.info/docs/draft-jones-json-web-token-06.html WWW: https://github.com/progrium/ruby-jwt RG: https://rubygems.org/gems/jwt
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-jwt/Makefile24
-rw-r--r--www/rubygem-jwt/distinfo2
-rw-r--r--www/rubygem-jwt/pkg-descr6
4 files changed, 33 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 70f0c6d08571..b86eafe5e679 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1697,6 +1697,7 @@
SUBDIR += rubygem-jekyll
SUBDIR += rubygem-journey
SUBDIR += rubygem-jquery-rails
+ SUBDIR += rubygem-jwt
SUBDIR += rubygem-layout-yullio
SUBDIR += rubygem-less
SUBDIR += rubygem-lighthouse-api
diff --git a/www/rubygem-jwt/Makefile b/www/rubygem-jwt/Makefile
new file mode 100644
index 000000000000..195e3759cd8b
--- /dev/null
+++ b/www/rubygem-jwt/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: rubygem-jwt
+# Date created: 2012-07-04
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jwt
+PORTVERSION= 0.1.4
+CATEGORIES= www devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= JSON Web Token implementation in Ruby
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-json>=1.2.4:${PORTSDIR}/devel/rubygem-json
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-jwt/distinfo b/www/rubygem-jwt/distinfo
new file mode 100644
index 000000000000..7cd592f8c4f5
--- /dev/null
+++ b/www/rubygem-jwt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/jwt-0.1.4.gem) = a79a0faaacb4673c1c44ad1ab62cdaaf75bc01f13e48aea4aeaaf1adbd3c6d4a
+SIZE (rubygem/jwt-0.1.4.gem) = 5632
diff --git a/www/rubygem-jwt/pkg-descr b/www/rubygem-jwt/pkg-descr
new file mode 100644
index 000000000000..815243f84385
--- /dev/null
+++ b/www/rubygem-jwt/pkg-descr
@@ -0,0 +1,6 @@
+JWT is a Ruby implementation of JSON Web Token draft 06 [1].
+
+[1] http://self-issued.info/docs/draft-jones-json-web-token-06.html
+
+WWW: https://github.com/progrium/ruby-jwt
+RG: https://rubygems.org/gems/jwt