aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2011-07-11 05:33:00 +0800
committerashish <ashish@FreeBSD.org>2011-07-11 05:33:00 +0800
commitb6668387c632b75eae1ea1f5c553a1af5fe1c9d7 (patch)
tree1e8fff8b05abab48f616ec8f5813af6b0b05d791 /www
parentc15d0c164d6135c3177abfcb6a172698d302801d (diff)
downloadfreebsd-ports-gnome-b6668387c632b75eae1ea1f5c553a1af5fe1c9d7.tar.gz
freebsd-ports-gnome-b6668387c632b75eae1ea1f5c553a1af5fe1c9d7.tar.zst
freebsd-ports-gnome-b6668387c632b75eae1ea1f5c553a1af5fe1c9d7.zip
Generic HTTP types for Haskell (for both client and server code).
WWW: https://github.com/aristidb/http-types Obtained from: FreeBSD Haskell
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/hs-http-types/Makefile22
-rw-r--r--www/hs-http-types/distinfo2
-rw-r--r--www/hs-http-types/pkg-descr3
4 files changed, 28 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 7ee006ef8dd2..3edda6c64ec4 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -316,6 +316,7 @@
SUBDIR += hs-cgi
SUBDIR += hs-fastcgi
SUBDIR += hs-http-server
+ SUBDIR += hs-http-types
SUBDIR += hs-oeis
SUBDIR += hs-scgi
SUBDIR += hs-url
diff --git a/www/hs-http-types/Makefile b/www/hs-http-types/Makefile
new file mode 100644
index 000000000000..92b2ceec52bb
--- /dev/null
+++ b/www/hs-http-types/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: hs-http-types
+# Date created: May 24, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= http-types
+PORTVERSION= 0.6.4
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Generic HTTP types for Haskell (for both client and server code)
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= blaze-builder>=0.2.1.4 case-insensitive>=0.2 text>=0.11.0.2
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-http-types/distinfo b/www/hs-http-types/distinfo
new file mode 100644
index 000000000000..70fa77374972
--- /dev/null
+++ b/www/hs-http-types/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/http-types-0.6.4.tar.gz) = a9d3ecfe7b347629a397ddaef766c14b075dcac0e52ddab8f2d04b2aa53f481c
+SIZE (cabal/http-types-0.6.4.tar.gz) = 7638
diff --git a/www/hs-http-types/pkg-descr b/www/hs-http-types/pkg-descr
new file mode 100644
index 000000000000..591ae86c0234
--- /dev/null
+++ b/www/hs-http-types/pkg-descr
@@ -0,0 +1,3 @@
+Generic HTTP types for Haskell (for both client and server code).
+
+WWW: https://github.com/aristidb/http-types