aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2004-12-30 01:05:01 +0800
committerskv <skv@FreeBSD.org>2004-12-30 01:05:01 +0800
commitb82614674628665b4e18073d78a9a061798d996f (patch)
tree10934ed3f287f4152a1aa7282d166be7a672f4c6 /www
parent171007d60dedf2534c3cfa4df06eba8a84d0d262 (diff)
downloadfreebsd-ports-gnome-b82614674628665b4e18073d78a9a061798d996f.tar.gz
freebsd-ports-gnome-b82614674628665b4e18073d78a9a061798d996f.tar.zst
freebsd-ports-gnome-b82614674628665b4e18073d78a9a061798d996f.zip
Unbreak build on perl < 5.6.x
* add stub "#define aTHX_"
Diffstat (limited to 'www')
-rw-r--r--www/p5-libapreq/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/www/p5-libapreq/Makefile b/www/p5-libapreq/Makefile
index 166201914f5c..3cbc0eb39bef 100644
--- a/www/p5-libapreq/Makefile
+++ b/www/p5-libapreq/Makefile
@@ -28,9 +28,15 @@ PERL_CONFIGURE= yes
MAN3= Apache::Cookie.3 Apache::Request.3 Apache::libapreq.3 \
libapreq.3
+.include <bsd.port.pre.mk>
+
post-patch:
@${PERL} -pi~ -e '$$_="" if ($$.>37 && $$.<63) || /PREREQ_PM/' \
${WRKSRC}/Makefile.PL
+.if ${PERL_LEVEL} < 500600
+ @${PERL} -pi~ -e '$$_="#define aTHX_\n" if $$. == 155' \
+ ${WRKSRC}/c/apache_request.h
+.endif
post-install:
.ifndef(NOPORTDOCS)
@@ -41,4 +47,4 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/eg/perl/* ${EXAMPLESDIR}/perl
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>