aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2006-02-13 18:03:35 +0800
committerlawrance <lawrance@FreeBSD.org>2006-02-13 18:03:35 +0800
commitb95a97cb96490cbd755c9c326a7409be85671f76 (patch)
treef8e6bdb1d2c01446fedefe8a9c04261dfd278275 /www
parent8016208c426ce716de9867b549bec07bf5d8caec (diff)
downloadfreebsd-ports-gnome-b95a97cb96490cbd755c9c326a7409be85671f76.tar.gz
freebsd-ports-gnome-b95a97cb96490cbd755c9c326a7409be85671f76.tar.zst
freebsd-ports-gnome-b95a97cb96490cbd755c9c326a7409be85671f76.zip
Fix instiki startup due to a change in the ruby Logger interface.
Bump PORTREVISION. PR: ports/92511 Submitted by: Alastair Rankine <arsptr@optusnet.com.au> Reviewed by: Kelley Reynolds <kelley@insidesystems.net> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/instiki/Makefile4
-rw-r--r--www/instiki/files/patch-vendor_rails_activesupport_lib_active_support_clean_logger.rb14
2 files changed, 18 insertions, 0 deletions
diff --git a/www/instiki/Makefile b/www/instiki/Makefile
index ed0da84846c5..f725d114ef56 100644
--- a/www/instiki/Makefile
+++ b/www/instiki/Makefile
@@ -7,6 +7,7 @@
PORTNAME= instiki
PORTVERSION= 0.10.2
+PORTREVISION= 1
CATEGORIES= www ruby
MASTER_SITES= http://rubyforge.lauschmusik.de/instiki/ \
http://rubyforge.planetargon.com/instiki/ \
@@ -34,6 +35,9 @@ RUBY_SHEBANG_FILES=instiki
INSTIKIPORT?= 2500
+post-patch:
+ @${FIND} ${WRKSRC} -name '*.orig' -delete
+
pre-install:
@${SED} ${SED_SCRIPT} ${FILESDIR}/${PORTNAME}.sh >${WRKDIR}/${PORTNAME}.sh
diff --git a/www/instiki/files/patch-vendor_rails_activesupport_lib_active_support_clean_logger.rb b/www/instiki/files/patch-vendor_rails_activesupport_lib_active_support_clean_logger.rb
new file mode 100644
index 000000000000..1409cd25ebcc
--- /dev/null
+++ b/www/instiki/files/patch-vendor_rails_activesupport_lib_active_support_clean_logger.rb
@@ -0,0 +1,14 @@
+--- vendor/rails/activesupport/lib/active_support/clean_logger.rb.orig 2005-09-21 00:31:08.000000000 -0700
++++ vendor/rails/activesupport/lib/active_support/clean_logger.rb 2005-09-21 00:45:36.000000000 -0700
+@@ -10,7 +10,9 @@
+ end
+
+ private
+- remove_const "Format"
++ if const_defined?(:Format) # Not defined in Ruby 1.8.3
++ remove_const "Format"
++ end
+ Format = "%s\n"
+ def format_message(severity, timestamp, msg, progname)
+ Format % [msg]
+--- patch-as_clean_logger_rb ends here ---