aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2016-07-11 16:38:10 +0800
committerolgeni <olgeni@FreeBSD.org>2016-07-11 16:38:10 +0800
commitba0a4e8ac41d6e88ef8212b87acca474b9b4fe61 (patch)
treedec7063c0735fc5c595a13d4cadb0944de7310a6 /www
parentcdfd790fce5d6e19bfe59180eebbe77dcf2f8698 (diff)
downloadfreebsd-ports-gnome-ba0a4e8ac41d6e88ef8212b87acca474b9b4fe61.tar.gz
freebsd-ports-gnome-ba0a4e8ac41d6e88ef8212b87acca474b9b4fe61.tar.zst
freebsd-ports-gnome-ba0a4e8ac41d6e88ef8212b87acca474b9b4fe61.zip
Add www/elixir-phoenix_pubsub, a distributed pubsub and presence platform
for the Phoenix Framework.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/elixir-phoenix_pubsub/Makefile20
-rw-r--r--www/elixir-phoenix_pubsub/distinfo3
-rw-r--r--www/elixir-phoenix_pubsub/pkg-descr3
-rw-r--r--www/elixir-phoenix_pubsub/pkg-plist27
5 files changed, 54 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d8fac01e30f8..d6663ce229c2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -137,6 +137,7 @@
SUBDIR += elixir-phoenix
SUBDIR += elixir-phoenix_ecto
SUBDIR += elixir-phoenix_html
+ SUBDIR += elixir-phoenix_pubsub
SUBDIR += elixir-webassembly
SUBDIR += emacs-w3m
SUBDIR += encode-explorer
diff --git a/www/elixir-phoenix_pubsub/Makefile b/www/elixir-phoenix_pubsub/Makefile
new file mode 100644
index 000000000000..cd14c6c30726
--- /dev/null
+++ b/www/elixir-phoenix_pubsub/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= phoenix_pubsub
+PORTVERSION= 1.0.0
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+PKGNAMEPREFIX= elixir-
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Distributed PubSub for Phoenix
+
+LICENSE= MIT
+
+USES= elixir
+USE_GITHUB= yes
+GH_ACCOUNT= phoenixframework
+
+MIX_REWRITE= yes
+
+.include <bsd.port.mk>
diff --git a/www/elixir-phoenix_pubsub/distinfo b/www/elixir-phoenix_pubsub/distinfo
new file mode 100644
index 000000000000..a828b05fe968
--- /dev/null
+++ b/www/elixir-phoenix_pubsub/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1467897304
+SHA256 (phoenixframework-phoenix_pubsub-v1.0.0_GH0.tar.gz) = ad60de86cbd12400d2797c288b03cd15ed7b67758a4289d95d2bb84f8836cb75
+SIZE (phoenixframework-phoenix_pubsub-v1.0.0_GH0.tar.gz) = 30391
diff --git a/www/elixir-phoenix_pubsub/pkg-descr b/www/elixir-phoenix_pubsub/pkg-descr
new file mode 100644
index 000000000000..e1093a921473
--- /dev/null
+++ b/www/elixir-phoenix_pubsub/pkg-descr
@@ -0,0 +1,3 @@
+Distributed PubSub and Presence platform for the Phoenix Framework.
+
+WWW: https://github.com/phoenixframework/phoenix_pubsub
diff --git a/www/elixir-phoenix_pubsub/pkg-plist b/www/elixir-phoenix_pubsub/pkg-plist
new file mode 100644
index 000000000000..35937e4cb351
--- /dev/null
+++ b/www/elixir-phoenix_pubsub/pkg-plist
@@ -0,0 +1,27 @@
+lib/elixir/lib/phoenix_pubsub/ebin/Elixir.Phoenix.PubSub.BroadcastError.beam
+lib/elixir/lib/phoenix_pubsub/ebin/Elixir.Phoenix.PubSub.GC.beam
+lib/elixir/lib/phoenix_pubsub/ebin/Elixir.Phoenix.PubSub.Local.beam
+lib/elixir/lib/phoenix_pubsub/ebin/Elixir.Phoenix.PubSub.LocalSupervisor.beam
+lib/elixir/lib/phoenix_pubsub/ebin/Elixir.Phoenix.PubSub.PG2.beam
+lib/elixir/lib/phoenix_pubsub/ebin/Elixir.Phoenix.PubSub.PG2Server.beam
+lib/elixir/lib/phoenix_pubsub/ebin/Elixir.Phoenix.PubSub.Supervisor.beam
+lib/elixir/lib/phoenix_pubsub/ebin/Elixir.Phoenix.PubSub.beam
+lib/elixir/lib/phoenix_pubsub/ebin/Elixir.Phoenix.Tracker.Clock.beam
+lib/elixir/lib/phoenix_pubsub/ebin/Elixir.Phoenix.Tracker.DeltaGeneration.beam
+lib/elixir/lib/phoenix_pubsub/ebin/Elixir.Phoenix.Tracker.Replica.beam
+lib/elixir/lib/phoenix_pubsub/ebin/Elixir.Phoenix.Tracker.State.beam
+lib/elixir/lib/phoenix_pubsub/ebin/Elixir.Phoenix.Tracker.beam
+lib/elixir/lib/phoenix_pubsub/ebin/phoenix_pubsub.app
+lib/elixir/lib/phoenix_pubsub/lib/phoenix/pubsub.ex
+lib/elixir/lib/phoenix_pubsub/lib/phoenix/pubsub/gc.ex
+lib/elixir/lib/phoenix_pubsub/lib/phoenix/pubsub/local.ex
+lib/elixir/lib/phoenix_pubsub/lib/phoenix/pubsub/local_supervisor.ex
+lib/elixir/lib/phoenix_pubsub/lib/phoenix/pubsub/pg2.ex
+lib/elixir/lib/phoenix_pubsub/lib/phoenix/pubsub/pg2_server.ex
+lib/elixir/lib/phoenix_pubsub/lib/phoenix/pubsub/supervisor.ex
+lib/elixir/lib/phoenix_pubsub/lib/phoenix/tracker.ex
+lib/elixir/lib/phoenix_pubsub/lib/phoenix/tracker/clock.ex
+lib/elixir/lib/phoenix_pubsub/lib/phoenix/tracker/delta_generation.ex
+lib/elixir/lib/phoenix_pubsub/lib/phoenix/tracker/replica.ex
+lib/elixir/lib/phoenix_pubsub/lib/phoenix/tracker/state.ex
+%%PORTDOCS%%%%DOCSDIR%%/README.md