aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2014-11-20 21:27:52 +0800
committerkuriyama <kuriyama@FreeBSD.org>2014-11-20 21:27:52 +0800
commitba27797f61899f80e6bc66fe249f2f4736b2abd6 (patch)
tree330a379100de7b266df57ca1b00ce9b62df97c5a /www
parent98489720dce369f91a02237f0be78e0c02b44e6b (diff)
downloadfreebsd-ports-gnome-ba27797f61899f80e6bc66fe249f2f4736b2abd6.tar.gz
freebsd-ports-gnome-ba27797f61899f80e6bc66fe249f2f4736b2abd6.tar.zst
freebsd-ports-gnome-ba27797f61899f80e6bc66fe249f2f4736b2abd6.zip
- Upgrade to 1.3132.
Diffstat (limited to 'www')
-rw-r--r--www/p5-Dancer/Makefile31
-rw-r--r--www/p5-Dancer/distinfo4
-rw-r--r--www/p5-Dancer/pkg-plist42
3 files changed, 36 insertions, 41 deletions
diff --git a/www/p5-Dancer/Makefile b/www/p5-Dancer/Makefile
index 8ef921970bc4..14667428c614 100644
--- a/www/p5-Dancer/Makefile
+++ b/www/p5-Dancer/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= Dancer
-PORTVERSION= 1.3120
+PORTVERSION= 1.3132
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:YANICK
@@ -14,27 +14,17 @@ LICENSE= ART10 GPLv1
LICENSE_COMB= dual
RUN_DEPENDS= \
+ p5-HTTP-Body>0:${PORTSDIR}/www/p5-HTTP-Body \
+ p5-HTTP-Date>0:${PORTSDIR}/www/p5-HTTP-Date \
+ p5-HTTP-Message>0:${PORTSDIR}/www/p5-HTTP-Message \
+ p5-HTTP-Server-Simple-PSGI>0:${PORTSDIR}/www/p5-HTTP-Server-Simple-PSGI \
+ p5-Hash-Merge-Simple>0:${PORTSDIR}/devel/p5-Hash-Merge-Simple \
p5-libwww>0:${PORTSDIR}/www/p5-libwww \
- p5-HTTP-Body>=1.07:${PORTSDIR}/www/p5-HTTP-Body \
- p5-HTTP-Server-Simple-PSGI>=0.11:${PORTSDIR}/www/p5-HTTP-Server-Simple-PSGI \
p5-MIME-Types>0:${PORTSDIR}/mail/p5-MIME-Types \
- p5-Module-Runtime>=0:${PORTSDIR}/devel/p5-Module-Runtime \
- p5-URI>=1.59:${PORTSDIR}/net/p5-URI \
- p5-Try-Tiny>=0.09:${PORTSDIR}/lang/p5-Try-Tiny
+ p5-Module-Runtime>0:${PORTSDIR}/devel/p5-Module-Runtime \
+ p5-Try-Tiny>0:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
BUILD_DEPENDS:= ${RUN_DEPENDS}
-TEST_DEPENDS= \
- p5-Test-TCP>0:${PORTSDIR}/devel/p5-Test-TCP \
- p5-JSON>0:${PORTSDIR}/converters/p5-JSON \
- p5-YAML>0:${PORTSDIR}/textproc/p5-YAML \
- p5-Plack>0:${PORTSDIR}/www/p5-Plack \
- p5-XML-Simple>0:${PORTSDIR}/textproc/p5-XML-Simple \
- p5-HTTP-Parser-XS>0:${PORTSDIR}/www/p5-HTTP-Parser-XS \
- p5-Template-Toolkit>0:${PORTSDIR}/www/p5-Template-Toolkit \
- p5-Test-Output>0:${PORTSDIR}/devel/p5-Test-Output \
- p5-Plack>0:${PORTSDIR}/www/p5-Plack \
- p5-Clone>0:${PORTSDIR}/devel/p5-Clone
-# XXX: test wants p5-Dancer-Session-Cookie, but this causes cyclic dependency.
-# p5-Dancer-Session-Cookie>0:${PORTSDIR}/www/p5-Dancer-Session-Cookie
OPTIONS_DEFINE= YAML
OPTIONS_DEFAULT= YAML
@@ -42,10 +32,11 @@ OPTIONS_DEFAULT= YAML
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MYAML}
-RUN_DEPENDS+= p5-YAML>=0.71:${PORTSDIR}/textproc/p5-YAML
+RUN_DEPENDS+= p5-YAML>0:${PORTSDIR}/textproc/p5-YAML
.endif
USES= perl5
USE_PERL5= configure
+NO_ARCH= YES
.include <bsd.port.mk>
diff --git a/www/p5-Dancer/distinfo b/www/p5-Dancer/distinfo
index ad6236ce5223..ce32940b5c39 100644
--- a/www/p5-Dancer/distinfo
+++ b/www/p5-Dancer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Dancer-1.3120.tar.gz) = 444d3739c6e5128a21a4eb806f20d7e3a312ab3166e6a5866f851b7cc2dadae2
-SIZE (Dancer-1.3120.tar.gz) = 302268
+SHA256 (Dancer-1.3132.tar.gz) = 7ddb8046423cbdc44ae61b53e2a8897f1ca1e2c7dbe903dacf7a121a1e46149f
+SIZE (Dancer-1.3132.tar.gz) = 388898
diff --git a/www/p5-Dancer/pkg-plist b/www/p5-Dancer/pkg-plist
index 6f6c4d5ffa8c..51ea8d279dd4 100644
--- a/www/p5-Dancer/pkg-plist
+++ b/www/p5-Dancer/pkg-plist
@@ -1,7 +1,16 @@
man/man1/dancer.1.gz
%%PERL5_MAN3%%/Dancer.3.gz
+%%PERL5_MAN3%%/Dancer::App.3.gz
%%PERL5_MAN3%%/Dancer::Config.3.gz
%%PERL5_MAN3%%/Dancer::Config::Object.3.gz
+%%PERL5_MAN3%%/Dancer::Continuation.3.gz
+%%PERL5_MAN3%%/Dancer::Continuation::Halted.3.gz
+%%PERL5_MAN3%%/Dancer::Continuation::Route.3.gz
+%%PERL5_MAN3%%/Dancer::Continuation::Route::ErrorSent.3.gz
+%%PERL5_MAN3%%/Dancer::Continuation::Route::FileSent.3.gz
+%%PERL5_MAN3%%/Dancer::Continuation::Route::Forwarded.3.gz
+%%PERL5_MAN3%%/Dancer::Continuation::Route::Passed.3.gz
+%%PERL5_MAN3%%/Dancer::Continuation::Route::Templated.3.gz
%%PERL5_MAN3%%/Dancer::Cookbook.3.gz
%%PERL5_MAN3%%/Dancer::Cookie.3.gz
%%PERL5_MAN3%%/Dancer::Cookies.3.gz
@@ -13,10 +22,14 @@ man/man1/dancer.1.gz
%%PERL5_MAN3%%/Dancer::Error.3.gz
%%PERL5_MAN3%%/Dancer::Exception.3.gz
%%PERL5_MAN3%%/Dancer::Exception::Base.3.gz
+%%PERL5_MAN3%%/Dancer::Factory::Hook.3.gz
%%PERL5_MAN3%%/Dancer::FileUtils.3.gz
+%%PERL5_MAN3%%/Dancer::GetOpt.3.gz
%%PERL5_MAN3%%/Dancer::HTTP.3.gz
+%%PERL5_MAN3%%/Dancer::Handler.3.gz
%%PERL5_MAN3%%/Dancer::Handler::Debug.3.gz
%%PERL5_MAN3%%/Dancer::Handler::PSGI.3.gz
+%%PERL5_MAN3%%/Dancer::Handler::Standalone.3.gz
%%PERL5_MAN3%%/Dancer::Hook.3.gz
%%PERL5_MAN3%%/Dancer::Hook::Properties.3.gz
%%PERL5_MAN3%%/Dancer::Introduction.3.gz
@@ -36,12 +49,19 @@ man/man1/dancer.1.gz
%%PERL5_MAN3%%/Dancer::Plugin.3.gz
%%PERL5_MAN3%%/Dancer::Plugin::Ajax.3.gz
%%PERL5_MAN3%%/Dancer::Plugins.3.gz
+%%PERL5_MAN3%%/Dancer::Policy.3.gz
+%%PERL5_MAN3%%/Dancer::Renderer.3.gz
%%PERL5_MAN3%%/Dancer::Request.3.gz
%%PERL5_MAN3%%/Dancer::Request::Upload.3.gz
%%PERL5_MAN3%%/Dancer::Response.3.gz
+%%PERL5_MAN3%%/Dancer::Route.3.gz
%%PERL5_MAN3%%/Dancer::Route::Cache.3.gz
+%%PERL5_MAN3%%/Dancer::Route::Registry.3.gz
%%PERL5_MAN3%%/Dancer::Serializer.3.gz
+%%PERL5_MAN3%%/Dancer::Serializer::Abstract.3.gz
+%%PERL5_MAN3%%/Dancer::Serializer::Dumper.3.gz
%%PERL5_MAN3%%/Dancer::Serializer::JSON.3.gz
+%%PERL5_MAN3%%/Dancer::Serializer::JSONP.3.gz
%%PERL5_MAN3%%/Dancer::Serializer::Mutable.3.gz
%%PERL5_MAN3%%/Dancer::Serializer::XML.3.gz
%%PERL5_MAN3%%/Dancer::Serializer::YAML.3.gz
@@ -49,6 +69,7 @@ man/man1/dancer.1.gz
%%PERL5_MAN3%%/Dancer::Session::Abstract.3.gz
%%PERL5_MAN3%%/Dancer::Session::Simple.3.gz
%%PERL5_MAN3%%/Dancer::Session::YAML.3.gz
+%%PERL5_MAN3%%/Dancer::SharedData.3.gz
%%PERL5_MAN3%%/Dancer::Template.3.gz
%%PERL5_MAN3%%/Dancer::Template::Abstract.3.gz
%%PERL5_MAN3%%/Dancer::Template::Simple.3.gz
@@ -108,6 +129,7 @@ bin/dancer
%%SITE_PERL%%/Dancer/Plugin.pm
%%SITE_PERL%%/Dancer/Plugin/Ajax.pm
%%SITE_PERL%%/Dancer/Plugins.pod
+%%SITE_PERL%%/Dancer/Policy.pod
%%SITE_PERL%%/Dancer/Renderer.pm
%%SITE_PERL%%/Dancer/Request.pm
%%SITE_PERL%%/Dancer/Request/Upload.pm
@@ -119,6 +141,7 @@ bin/dancer
%%SITE_PERL%%/Dancer/Serializer/Abstract.pm
%%SITE_PERL%%/Dancer/Serializer/Dumper.pm
%%SITE_PERL%%/Dancer/Serializer/JSON.pm
+%%SITE_PERL%%/Dancer/Serializer/JSONP.pm
%%SITE_PERL%%/Dancer/Serializer/Mutable.pm
%%SITE_PERL%%/Dancer/Serializer/XML.pm
%%SITE_PERL%%/Dancer/Serializer/YAML.pm
@@ -134,22 +157,3 @@ bin/dancer
%%SITE_PERL%%/Dancer/Test.pm
%%SITE_PERL%%/Dancer/Timer.pm
%%SITE_PERL%%/Dancer/Tutorial.pod
-@dirrm %%SITE_PERL%%/Dancer/Template
-@dirrm %%SITE_PERL%%/Dancer/Session
-@dirrm %%SITE_PERL%%/Dancer/Serializer
-@dirrm %%SITE_PERL%%/Dancer/Route
-@dirrm %%SITE_PERL%%/Dancer/Request
-@dirrm %%SITE_PERL%%/Dancer/Plugin
-@dirrm %%SITE_PERL%%/Dancer/Object
-@dirrm %%SITE_PERL%%/Dancer/Logger/Capture
-@dirrm %%SITE_PERL%%/Dancer/Logger
-@dirrm %%SITE_PERL%%/Dancer/Hook
-@dirrm %%SITE_PERL%%/Dancer/Handler
-@dirrm %%SITE_PERL%%/Dancer/Factory
-@dirrm %%SITE_PERL%%/Dancer/Exception
-@dirrm %%SITE_PERL%%/Dancer/Development
-@dirrm %%SITE_PERL%%/Dancer/Continuation/Route
-@dirrm %%SITE_PERL%%/Dancer/Continuation
-@dirrm %%SITE_PERL%%/Dancer/Config
-@dirrm %%SITE_PERL%%/Dancer
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer