aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-11-02 11:31:50 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-11-02 11:31:50 +0800
commitc05503c2b7b424f8bd8f7c5133c608b46dc3714e (patch)
tree468fea72be6addcdfe8ed9d7fd7932025c18fa28 /www
parent8a628cc1c08e07be2eb1c4b4d090f2b05aa25c9d (diff)
downloadfreebsd-ports-gnome-c05503c2b7b424f8bd8f7c5133c608b46dc3714e.tar.gz
freebsd-ports-gnome-c05503c2b7b424f8bd8f7c5133c608b46dc3714e.tar.zst
freebsd-ports-gnome-c05503c2b7b424f8bd8f7c5133c608b46dc3714e.zip
Plack Middleware for mapping urls to status code-driven responses.
WWW: http://search.cpan.org/dist/Plack-Middleware-Status/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Plack-Middleware-Status/Makefile26
-rw-r--r--www/p5-Plack-Middleware-Status/distinfo2
-rw-r--r--www/p5-Plack-Middleware-Status/pkg-descr3
-rw-r--r--www/p5-Plack-Middleware-Status/pkg-plist4
5 files changed, 36 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ad879cc9d627..54441c45e525 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1118,6 +1118,7 @@
SUBDIR += p5-Plack-Middleware-JSConcat
SUBDIR += p5-Plack-Middleware-ReverseProxy
SUBDIR += p5-Plack-Middleware-Session
+ SUBDIR += p5-Plack-Middleware-Status
SUBDIR += p5-Plack-Middleware-Throttle
SUBDIR += p5-Plack-Server-Coro
SUBDIR += p5-Plack-Server-POE
diff --git a/www/p5-Plack-Middleware-Status/Makefile b/www/p5-Plack-Middleware-Status/Makefile
new file mode 100644
index 000000000000..b3ae15221ca2
--- /dev/null
+++ b/www/p5-Plack-Middleware-Status/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Plack::Middleware::Status
+# Date created: 01 Nov 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Plack-Middleware-Status
+PORTVERSION= 1.101150
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to map urls to status code-driven responses for Plack
+
+RUN_DEPENDS= \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-Plack>0:${PORTSDIR}/www/p5-Plack
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Plack::Middleware::Status.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Plack-Middleware-Status/distinfo b/www/p5-Plack-Middleware-Status/distinfo
new file mode 100644
index 000000000000..0148864333d5
--- /dev/null
+++ b/www/p5-Plack-Middleware-Status/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Plack-Middleware-Status-1.101150.tar.gz) = 0013ab1c3842f0ccb9890bc1f507daa2e002a7276a84c944bf9c19be1eb2e8fb
+SIZE (Plack-Middleware-Status-1.101150.tar.gz) = 10551
diff --git a/www/p5-Plack-Middleware-Status/pkg-descr b/www/p5-Plack-Middleware-Status/pkg-descr
new file mode 100644
index 000000000000..b78e355523e5
--- /dev/null
+++ b/www/p5-Plack-Middleware-Status/pkg-descr
@@ -0,0 +1,3 @@
+Plack Middleware for mapping urls to status code-driven responses.
+
+WWW: http://search.cpan.org/dist/Plack-Middleware-Status/
diff --git a/www/p5-Plack-Middleware-Status/pkg-plist b/www/p5-Plack-Middleware-Status/pkg-plist
new file mode 100644
index 000000000000..12df723bd159
--- /dev/null
+++ b/www/p5-Plack-Middleware-Status/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Middleware/Status/.packlist
+%%SITE_PERL%%/Plack/Middleware/Status.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Middleware/Status
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Middleware