aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2010-08-28 02:49:00 +0800
committermm <mm@FreeBSD.org>2010-08-28 02:49:00 +0800
commitc11e1ba3dd8dcff160a328fff565ddd82de385cf (patch)
treea059d4aae190183cd112248ba0c02dd043daa6da /www
parented98f5e7107b590c9189b0c8bfa99a49711eea6f (diff)
downloadfreebsd-ports-gnome-c11e1ba3dd8dcff160a328fff565ddd82de385cf.tar.gz
freebsd-ports-gnome-c11e1ba3dd8dcff160a328fff565ddd82de385cf.tar.zst
freebsd-ports-gnome-c11e1ba3dd8dcff160a328fff565ddd82de385cf.zip
mod_geoip is a lighttpd module that looks up the country code
for the IP address making the request without using reverse DNS. WWW: http://redmine.lighttpd.net/wiki/1/Docs:ModGeoip
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/lighttpd-mod_geoip/Makefile52
2 files changed, 53 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index eef252ef7c5d..77ef89d67ab9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -369,6 +369,7 @@
SUBDIR += lifetype
SUBDIR += lightsquid
SUBDIR += lighttpd
+ SUBDIR += lighttpd-mod_geoip
SUBDIR += lighttpd-mysqlauth
SUBDIR += lilurl
SUBDIR += limesurvey
diff --git a/www/lighttpd-mod_geoip/Makefile b/www/lighttpd-mod_geoip/Makefile
new file mode 100644
index 000000000000..96b81023d830
--- /dev/null
+++ b/www/lighttpd-mod_geoip/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: mod_geoip
+# Date created: 27 Aug 2010
+# Whom: Martin Matuska <mm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_geoip
+CATEGORIES= www geography
+PKGNAMEPREFIX= lighttpd-
+DISTNAME= lighttpd-${PORTVERSION}
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= GeoIP module for lighttpd
+
+LIB_DEPENDS= GeoIP.5:${PORTSDIR}/net/GeoIP
+BUILD_DEPENDS= ${LOCALBASE}/sbin/lighttpd:${PORTSDIR}/www/lighttpd
+RUN_DEPENDS= ${LOCALBASE}/sbin/lighttpd:${PORTSDIR}/www/lighttpd
+
+MASTERDIR= ${.CURDIR}/../lighttpd
+DESCR= ${FILESDIR}/pkg-descr.${PORTNAME}
+PLIST= ${FILESDIR}/pkg-plist.${PORTNAME}
+LATEST_LINK= lighttpd-${PORTNAME}
+
+PATCH_SITES+= ${MASTER_SITE_LOCAL}
+PATCHFILES+= lighttpd-1.4.26_mod_geoip.patch.gz
+PATCH_SITE_SUBDIR+= mm
+USE_AUTOTOOLS+= autoconf:262 autoheader:262 aclocal:110 automake:110
+ACLOCAL_ARGS+= -I m4
+
+BUILD_WRKSRC= ${WRKSRC}/src
+ALL_TARGET= ${PORTNAME}.la
+
+_BUILDING_LIGHTTPD_MODULE= yes
+
+do-install:
+ @${INSTALL_KLD} ${WRKSRC}/src/.libs/${PORTNAME}.so \
+ ${LOCALBASE}/lib/lighttpd
+ @${INSTALL_KLD} ${WRKSRC}/src/.libs/${PORTNAME}.la \
+ ${LOCALBASE}/lib/lighttpd
+ @${INSTALL_DATA} ${WRKSRC}/src/.libs/${PORTNAME}.a \
+ ${LOCALBASE}/lib/lighttpd
+
+post-install:
+ @${INSTALL_DATA} ${WRKSRC}/doc/config/conf.d/geoip.conf \
+ ${PREFIX}/etc/lighttpd/conf.d/geoip.conf.sample
+.if !exists(${PREFIX}/etc/lighttpd/conf.d/geoip.conf)
+ @${INSTALL_DATA} ${WRKSRC}/doc/config/conf.d/geoip.conf \
+ ${PREFIX}/etc/lighttpd/conf.d/geoip.conf.sample
+.endif
+
+.include "${MASTERDIR}/Makefile"