aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2014-04-23 22:54:27 +0800
committerfeld <feld@FreeBSD.org>2014-04-23 22:54:27 +0800
commitc954405eead7c359d7788fd159d8b8e272daed3b (patch)
tree035dcb7732404a4e2f9e626f2ff83550eb1e8153 /www
parent5b4d5989e58328a66a523e468c1729376516bdc9 (diff)
downloadfreebsd-ports-gnome-c954405eead7c359d7788fd159d8b8e272daed3b.tar.gz
freebsd-ports-gnome-c954405eead7c359d7788fd159d8b8e272daed3b.tar.zst
freebsd-ports-gnome-c954405eead7c359d7788fd159d8b8e272daed3b.zip
Welcome mod_cloudflare to the tree.
Unfortunately, Cloudflare doesn't seem to be handling release management of mod_cloudflare very well so for now we are pulling from their public Github repository and the version number will be 0.0.YYYYMMDD based on the date of the commit we're pulling. They don't commit updates very often, so this should be fine until they figure out their release process.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_cloudflare/Makefile27
-rw-r--r--www/mod_cloudflare/distinfo2
-rw-r--r--www/mod_cloudflare/pkg-descr6
4 files changed, 36 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d627bf82044b..7158988263d5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -469,6 +469,7 @@
SUBDIR += mod_cfg_ldap
SUBDIR += mod_chroot
SUBDIR += mod_clamav
+ SUBDIR += mod_cloudflare
SUBDIR += mod_cplusplus
SUBDIR += mod_cvs2
SUBDIR += mod_dnssd
diff --git a/www/mod_cloudflare/Makefile b/www/mod_cloudflare/Makefile
new file mode 100644
index 000000000000..5dcfcc482a8c
--- /dev/null
+++ b/www/mod_cloudflare/Makefile
@@ -0,0 +1,27 @@
+# Created by: Mark Felder <feld@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mod_cloudflare
+PORTVERSION= 0.0.20140409
+CATEGORIES= www
+MASTER_SITES= GH
+
+MAINTAINER= feld@FreeBSD.org
+COMMENT= Cloudflare fork of mod_remoteip
+
+LICENSE= APACHE20
+
+USE_GITHUB= yes
+GH_ACCOUNT= cloudflare
+GH_PROJECT= mod_cloudflare
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= da8436d
+
+USE_APACHE= 22+
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+SHORTMODNAME= cloudflare
+
+SRC_FILE= mod_cloudflare.c
+
+.include <bsd.port.mk>
diff --git a/www/mod_cloudflare/distinfo b/www/mod_cloudflare/distinfo
new file mode 100644
index 000000000000..046e3c7039bc
--- /dev/null
+++ b/www/mod_cloudflare/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mod_cloudflare-0.0.20140409.tar.gz) = 934fc0995334462436ea92a45df2c7dfab0fb790ae651396eee34a546cfee5ca
+SIZE (mod_cloudflare-0.0.20140409.tar.gz) = 9969
diff --git a/www/mod_cloudflare/pkg-descr b/www/mod_cloudflare/pkg-descr
new file mode 100644
index 000000000000..9a982070c2f5
--- /dev/null
+++ b/www/mod_cloudflare/pkg-descr
@@ -0,0 +1,6 @@
+Based on mod_remoteip.c, this Apache extension will replace the
+remote_ip variable in user's logs with the correct remote IP sent from
+CloudFlare. The module only performs the IP substitution for requests
+originating from CloudFlare IPs by default.
+
+WWW: https://github.com/cloudflare/mod_cloudflare