aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2000-09-22 09:59:06 +0800
committerkris <kris@FreeBSD.org>2000-09-22 09:59:06 +0800
commitcc2138f8872f35766e9eed08df7f940799f6989d (patch)
tree135ecc5c6f2aa6e70fad57b88e4dc5800c435b99 /www
parent86525b91dae5387ee33a49235af5a72d7c327c2a (diff)
downloadfreebsd-ports-gnome-cc2138f8872f35766e9eed08df7f940799f6989d.tar.gz
freebsd-ports-gnome-cc2138f8872f35766e9eed08df7f940799f6989d.tar.zst
freebsd-ports-gnome-cc2138f8872f35766e9eed08df7f940799f6989d.zip
Update all ports using OpenSSL and RSA to work without rsaref since
it is no longer required. Apologies to the various maintainers whom I did not yet hear back from, but the ports freeze is coming up in a few hours and I will be verifying all of these ports on a 4.1 machine myself to catch any problems.
Diffstat (limited to 'www')
-rw-r--r--www/apache13-modssl/Makefile2
-rw-r--r--www/apache13-ssl/Makefile13
-rw-r--r--www/lynx-ssl/Makefile2
-rw-r--r--www/w3m-ssl/Makefile2
-rw-r--r--www/w3m/Makefile3
5 files changed, 4 insertions, 18 deletions
diff --git a/www/apache13-modssl/Makefile b/www/apache13-modssl/Makefile
index 90b7eca2e995..084982a873ce 100644
--- a/www/apache13-modssl/Makefile
+++ b/www/apache13-modssl/Makefile
@@ -42,7 +42,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
MAINTAINER= rse@engelschall.com
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.include <bsd.port.pre.mk>
diff --git a/www/apache13-ssl/Makefile b/www/apache13-ssl/Makefile
index dad49b24226c..9ddab095c366 100644
--- a/www/apache13-ssl/Makefile
+++ b/www/apache13-ssl/Makefile
@@ -44,7 +44,7 @@ Y2K= http://www.apache-ssl.org/#Y2K
APACHE_VERSION= 1.3.12
APACHE_SSL_VERSION= 1.40
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.include <bsd.port.pre.mk>
@@ -52,15 +52,8 @@ USE_OPENSSL= RSA
# Set APACHE_PERF_TUNING env. variable to YES to get maximum performance
#
-.if !defined(OPENSSLINC)
-OPENSSLINC= ${PREFIX}/ssl/include
-.endif
CFLAGS+= -I${OPENSSLINC}/openssl
-.if !defined(OPENSSLLIB)
-OPENSSLLIB= ${PREFIX}/ssl/lib
-.endif
-
HAS_CONFIGURE= yes
CONFIGURE_ARGS= \
--prefix=${PREFIX} \
@@ -90,11 +83,7 @@ CFLAGS+= -O6 -fomit-frame-pointer
.endif
CONFIGURE_ENV= OPTIM='${OPTIM}'
-.if defined(OPENSSL_RSAREF)
-CONFIGURE_ENV+= EXTRA_SSL_LIBS="-L${OPENSSLLIB} -lRSAglue -L${LOCALBASE}/lib -lrsaref"
-.else
CONFIGURE_ENV+= EXTRA_SSL_LIBS="-L${OPENSSLLIB} -L${LOCALBASE}/lib"
-.endif
MAN1= dbmmanage.1 htdigest.1 htpasswd.1
MAN8= ab.8 httpsdctl.8 apxs.8 httpsd.8 logresolve.8 rotatelogs.8
diff --git a/www/lynx-ssl/Makefile b/www/lynx-ssl/Makefile
index 81a3386a0d56..72fd234e7170 100644
--- a/www/lynx-ssl/Makefile
+++ b/www/lynx-ssl/Makefile
@@ -11,7 +11,7 @@ CATEGORIES= www
MASTER_SITES= ftp://lynx.isc.org/current/
DISTNAME= lynx2.8.3rel.1
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.include <bsd.port.pre.mk>
diff --git a/www/w3m-ssl/Makefile b/www/w3m-ssl/Makefile
index cac3a737c9a2..4e18014227cb 100644
--- a/www/w3m-ssl/Makefile
+++ b/www/w3m-ssl/Makefile
@@ -11,6 +11,6 @@ MASTERDIR= ${.CURDIR}/../../www/w3m
PKGDIR= ${.CURDIR}/pkg
PLIST= ${MASTERDIR}/pkg/PLIST
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.include "${MASTERDIR}/Makefile"
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index 0dd03eaef50a..e8a425b1a1e1 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -48,9 +48,6 @@ SSL_LIBS= -L${OPENSSLLIB} -lssl -lcrypto
SED_CMD+= -e "s,undef USE_SSL,define USE_SSL,g" \
-e "s,undef USE_SSL_VERIFY, define USE_SSL_VERIFY,g"
-.if defined(OPENSSL_RSAREF)
-EXTRA_SSL_LIBS= -lRSAglue -lrsaref
-.endif
MAKE_FLAGS+= DEFS="${SSL_CFLAGS} -I${LOCALBASE}/include" \
LIBS="${SSL_LIBS} ${EXTRA_SSL_LIBS} -L${LOCALBASE}/lib"
.else