aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-11-21 04:25:02 +0800
committerrakuco <rakuco@FreeBSD.org>2014-11-21 04:25:02 +0800
commitcccbbca8d24307715516160bdd0db6c7dff14ef6 (patch)
tree8ce438f29aa54de65c88d28d73989866e33ebb86 /www
parentde06e5616720bd1faafdd1ad57a8a2ef7cc3a4e7 (diff)
downloadfreebsd-ports-gnome-cccbbca8d24307715516160bdd0db6c7dff14ef6.tar.gz
freebsd-ports-gnome-cccbbca8d24307715516160bdd0db6c7dff14ef6.tar.zst
freebsd-ports-gnome-cccbbca8d24307715516160bdd0db6c7dff14ef6.zip
Stop installing libplatformplugin.so.
That is an example plugin that is not supposed to be built and installed by default. Its sole purpose is to be an example of how to write a plugin, and it does so by making <select> elements show up in a separate dialog. We definitely do not want that. As a bonus, it allows us to remove some of the hacks we do in the pre-configure target. While here: - Improve the comment about why we change ALL_TARGET. - Remove the weird CONFIGURE_ENV change we did that does not seem to be necessary anymore. I could not find any explanation for why it was added in the first place.
Diffstat (limited to 'www')
-rw-r--r--www/webkit-qt5/Makefile14
-rw-r--r--www/webkit-qt5/files/patch-Source__QtWebKit.pro17
-rw-r--r--www/webkit-qt5/pkg-plist1
3 files changed, 20 insertions, 12 deletions
diff --git a/www/webkit-qt5/Makefile b/www/webkit-qt5/Makefile
index bf01f8889207..7cc894fb6bf3 100644
--- a/www/webkit-qt5/Makefile
+++ b/www/webkit-qt5/Makefile
@@ -2,6 +2,7 @@
PORTNAME= webkit
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= www
PKGNAMEPREFIX= qt5-
@@ -26,11 +27,10 @@ RUBY_NO_RUN_DEPENDS= yes
USE_SQLITE= 3
USE_XORG= x11 xcomposite xrender
USES= bison gmake gperf perl5 pkgconfig python:build qmake:outsource
-# Keep make(1) from descending into obj/ subdirectories during tests.
-CONFIGURE_ENV= MAKEOBJDIR=.
# Use flex(1) from ports.
MAKE_ENV= PATH="${LOCALBASE}/bin:${PATH}"
-# Probably required.
+# "all" builds many more targets. The default one is called "first" in
+# QtWebKit, and is invoked by default when make is called without arguments.
ALL_TARGET= first
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
@@ -62,14 +62,6 @@ post-patch:
${WRKSRC}/Tools/qmake/mkspecs/features/configure.prf
pre-configure:
-# Write a clean installation procedure to avoid the installation of
-# the file during the build stage.
- @${REINPLACE_CMD} -e 's|\[QT_INSTALL_PLUGINS]|{ROOT_BUILD_DIR}/plugins|' \
- ${WRKSRC}/Source/WebKit/qt/examples/platformplugin/platformplugin.pro
- @${ECHO_CMD} "target.path = ${PREFIX}/${QT_PLUGINDIR_REL}/webkit" \
- >> ${WRKSRC}/Source/WebKit/qt/examples/platformplugin/platformplugin.pro
- @${ECHO_CMD} "INSTALLS += target" \
- >> ${WRKSRC}/Source/WebKit/qt/examples/platformplugin/platformplugin.pro
@${REINPLACE_CMD} -Ee 's|linux-?\*|unix|g' \
${WRKSRC}/Source/JavaScriptCore/DerivedSources.pri \
${WRKSRC}/Source/JavaScriptCore/JavaScriptCore.pri \
diff --git a/www/webkit-qt5/files/patch-Source__QtWebKit.pro b/www/webkit-qt5/files/patch-Source__QtWebKit.pro
new file mode 100644
index 000000000000..ebb0ca193f58
--- /dev/null
+++ b/www/webkit-qt5/files/patch-Source__QtWebKit.pro
@@ -0,0 +1,17 @@
+Do not go into the examples/ directory, which contains only platformplugin/.
+
+Even though it is not part of the default target, it is included in `make
+install', and platformplugin's .pro file has a DESTDIR setting that causes the
+file system to be touched even though there is nothing to build or install.
+--- a/Source/QtWebKit.pro
++++ b/Source/QtWebKit.pro
+@@ -38,9 +38,4 @@ build?(webkit1) {
+ tests.file = tests.pri
+ SUBDIRS += tests
+ }
+-
+- examples.file = WebKit/qt/examples/examples.pro
+- examples.CONFIG += no_default_target
+- examples.makefile = Makefile
+- SUBDIRS += examples
+ }
diff --git a/www/webkit-qt5/pkg-plist b/www/webkit-qt5/pkg-plist
index f010156cdc69..6fab2f02a1e4 100644
--- a/www/webkit-qt5/pkg-plist
+++ b/www/webkit-qt5/pkg-plist
@@ -100,7 +100,6 @@
%%QT_MKSPECDIR%%/modules/qt_lib_webkit_private.pri
%%QT_MKSPECDIR%%/modules/qt_lib_webkitwidgets.pri
%%QT_MKSPECDIR%%/modules/qt_lib_webkitwidgets_private.pri
-%%QT_PLUGINDIR%%/webkit/libplatformplugin.so
%%QT_QMLDIR%%/QtWebKit/experimental/libqmlwebkitexperimentalplugin.so
%%QT_QMLDIR%%/QtWebKit/experimental/qmldir
%%QT_QMLDIR%%/QtWebKit/libqmlwebkitplugin.so