aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-05-07 03:41:58 +0800
committermarcus <marcus@FreeBSD.org>2009-05-07 03:41:58 +0800
commitcd51cdc0bbb93ead77bd08b3ded8b355229c060e (patch)
tree0f64d88ac4f52b641afee061872aa10e3c53988e /www
parenta8f5d0ca662c7c924d920d8199575840ec8a3da4 (diff)
downloadfreebsd-ports-gnome-cd51cdc0bbb93ead77bd08b3ded8b355229c060e.tar.gz
freebsd-ports-gnome-cd51cdc0bbb93ead77bd08b3ded8b355229c060e.tar.zst
freebsd-ports-gnome-cd51cdc0bbb93ead77bd08b3ded8b355229c060e.zip
Fix make describe for epiphany-webkit.
Diffstat (limited to 'www')
-rw-r--r--www/epiphany/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index 479017ea7bff..ab04d89fd954 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -59,6 +59,7 @@ EXTRA_CFLAGS+= `pkg-config --cflags WebKitGtk` -I${LOCALBASE}/include/WebKit/web
EXTRA_LIBS+= `pkg-config --libs WebKitGtk`
CONFLICTS= epiphany-[1-9]*
PLIST_SUB+= GECKO="@comment "
+PLUGIN_SYMLINK= 18
.else
USE_GECKO+= firefox libxul
CONFIGURE_ARGS+= --with-gecko=${GECKO} \
@@ -67,6 +68,11 @@ CONFIGURE_ARGS+= --with-gecko=${GECKO} \
.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
CONFLICTS= epiphany-webkit-[1-9]*
PLIST_SUB+= GECKO=""
+.if ${GECKO:Mlibxul}!=""
+PLUGIN_SYMLINK= 19
+.else
+PLUGIN_SYMLINK= 18
+.endif
.endif
NO_WERROR= yes
@@ -75,12 +81,6 @@ NO_WERROR= yes
CONFIGURE_ARGS+= --enable-compile-warnings=no
.endif
-.if ${GECKO:Mlibxul}!=""
-PLUGIN_SYMLINK= 19
-.else
-PLUGIN_SYMLINK= 18
-.endif
-
.if ${HAVE_GNOME:Mpygnome2}!=""
USE_PYTHON= yes
.include "${PORTSDIR}/Mk/bsd.python.mk"