aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-05-02 12:16:48 +0800
committermarcus <marcus@FreeBSD.org>2006-05-02 12:16:48 +0800
commitd4e5c2a063b94543e3fa2e97d0c460ea0875307f (patch)
tree9bba092a5c14d9ca33aea42bd1282b116218a4bf /www
parent9be83038f8b1137d35c0a09474ddf46ad82bf4aa (diff)
downloadfreebsd-ports-gnome-d4e5c2a063b94543e3fa2e97d0c460ea0875307f.tar.gz
freebsd-ports-gnome-d4e5c2a063b94543e3fa2e97d0c460ea0875307f.tar.zst
freebsd-ports-gnome-d4e5c2a063b94543e3fa2e97d0c460ea0875307f.zip
Remove -DGNOME_DISABLE_DEPRECATED to fix the build with new libgnome. While
here, remove USE_REINPLACE to appease portlint. Reported by: pointyhat via kris
Diffstat (limited to 'www')
-rw-r--r--www/screem-devel/Makefile6
-rw-r--r--www/screem/Makefile6
2 files changed, 8 insertions, 4 deletions
diff --git a/www/screem-devel/Makefile b/www/screem-devel/Makefile
index c9a583fdde34..6b8419215ea2 100644
--- a/www/screem-devel/Makefile
+++ b/www/screem-devel/Makefile
@@ -21,7 +21,6 @@ USE_X_PREFIX= yes
USE_GNOME= desktopfileutils gnomehack gnomemenus gnomeprefix gnometarget \
gtksourceview intlhack libgnomeprintui libgnomeui libgtkhtml
USE_XPM= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -45,7 +44,10 @@ CONFIGURE_ARGS+= --enable-enchant
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|$${DATADIRNAME}/$${PACKAGE}|$${DATADIRNAME}/gnome/$${PACKAGE}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$${DATADIRNAME}/$${PACKAGE}|$${DATADIRNAME}/gnome/$${PACKAGE}|g ; \
+ s|-DGNOME_DISABLE_DEPRECATED||g ; \
+ s|-DGNOMEUI_DISABLE_DEPRECATED||g ; \
+ s|-DGTK_DISABLE_DEPRECATED||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|\&\& make|\&\& $$(MAKE)|g' ${WRKSRC}/tests/Makefile.in
.include <bsd.port.mk>
diff --git a/www/screem/Makefile b/www/screem/Makefile
index c9a583fdde34..6b8419215ea2 100644
--- a/www/screem/Makefile
+++ b/www/screem/Makefile
@@ -21,7 +21,6 @@ USE_X_PREFIX= yes
USE_GNOME= desktopfileutils gnomehack gnomemenus gnomeprefix gnometarget \
gtksourceview intlhack libgnomeprintui libgnomeui libgtkhtml
USE_XPM= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -45,7 +44,10 @@ CONFIGURE_ARGS+= --enable-enchant
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|$${DATADIRNAME}/$${PACKAGE}|$${DATADIRNAME}/gnome/$${PACKAGE}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$${DATADIRNAME}/$${PACKAGE}|$${DATADIRNAME}/gnome/$${PACKAGE}|g ; \
+ s|-DGNOME_DISABLE_DEPRECATED||g ; \
+ s|-DGNOMEUI_DISABLE_DEPRECATED||g ; \
+ s|-DGTK_DISABLE_DEPRECATED||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|\&\& make|\&\& $$(MAKE)|g' ${WRKSRC}/tests/Makefile.in
.include <bsd.port.mk>