aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2009-01-24 07:27:08 +0800
committerbrooks <brooks@FreeBSD.org>2009-01-24 07:27:08 +0800
commite3895db1d2853ad83d4257b6a6a3d29d191217e7 (patch)
tree41308e0c0464d0fef71ca5b2f4e65f4509dee785 /www
parentacccf2df96288e7eed09c3a95e340450e93d90d7 (diff)
downloadfreebsd-ports-gnome-e3895db1d2853ad83d4257b6a6a3d29d191217e7.tar.gz
freebsd-ports-gnome-e3895db1d2853ad83d4257b6a6a3d29d191217e7.tar.zst
freebsd-ports-gnome-e3895db1d2853ad83d4257b6a6a3d29d191217e7.zip
This a plugin for Trac which enables Mercurial to be used instead of Subversion
as the VersioningSystemBackend for Trac. WWW: http://trac.edgewall.org/wiki/TracMercurial
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-mercurial/Makefile35
-rw-r--r--www/trac-mercurial/distinfo3
-rw-r--r--www/trac-mercurial/pkg-descr4
4 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c33c89248835..46aeebe7fc61 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1437,6 +1437,7 @@
SUBDIR += trac-ldap
SUBDIR += trac-macropost
SUBDIR += trac-mastertickets
+ SUBDIR += trac-mercurial
SUBDIR += trac-nav
SUBDIR += trac-navadd
SUBDIR += trac-pagelist
diff --git a/www/trac-mercurial/Makefile b/www/trac-mercurial/Makefile
new file mode 100644
index 000000000000..136ecfbec04a
--- /dev/null
+++ b/www/trac-mercurial/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: trac-mercurial
+# Date created: January 23, 2009
+# Whom: Brooks Davis <brooks@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${PYDISTUTILS_PKGNAME:S;^Trac;;:L}
+PORTVERSION= 0.11.0.7
+CATEGORIES= www devel python
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brooks
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+
+MAINTAINER= brooks@freebsd.org
+COMMENT= A plugin to use Mercurial instead of Subversion in Trac
+
+RUN_DEPENDS+= hg:${PORTSDIR}/devel/mercurial \
+ tracd:${PORTSDIR}/www/trac
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_PYTHON= 2.3+
+NO_BUILD= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= TracMercurial
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+PYDISTUTILS_NOEGGINFO= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+do-build:
+ @${DO_NADA}
+
+.include <bsd.port.mk>
diff --git a/www/trac-mercurial/distinfo b/www/trac-mercurial/distinfo
new file mode 100644
index 000000000000..748e26aecd87
--- /dev/null
+++ b/www/trac-mercurial/distinfo
@@ -0,0 +1,3 @@
+MD5 (mercurialplugin-0.11.0.7.tar.gz) = 0e9966e495b8d712927041409c110bd7
+SHA256 (mercurialplugin-0.11.0.7.tar.gz) = c24e43b1c7080c8f30972e1baf8664b0b7807e5dcf4b6d276c3612b48e004914
+SIZE (mercurialplugin-0.11.0.7.tar.gz) = 20064
diff --git a/www/trac-mercurial/pkg-descr b/www/trac-mercurial/pkg-descr
new file mode 100644
index 000000000000..00fdabf14e4e
--- /dev/null
+++ b/www/trac-mercurial/pkg-descr
@@ -0,0 +1,4 @@
+This a plugin for Trac which enables Mercurial to be used instead of Subversion
+as the VersioningSystemBackend for Trac.
+
+WWW: http://trac.edgewall.org/wiki/TracMercurial