aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-26 23:28:28 +0800
committerbapt <bapt@FreeBSD.org>2014-05-26 23:28:28 +0800
commite6b8ed87b5e99e0ddfa7f575594f03f1992cf201 (patch)
tree1485083919fd5b153bf056ea17ac895ea758a8a9 /www
parent729d5d5ddb37fd2035af319a95b99466360a2e7e (diff)
downloadfreebsd-ports-gnome-e6b8ed87b5e99e0ddfa7f575594f03f1992cf201.tar.gz
freebsd-ports-gnome-e6b8ed87b5e99e0ddfa7f575594f03f1992cf201.tar.zst
freebsd-ports-gnome-e6b8ed87b5e99e0ddfa7f575594f03f1992cf201.zip
Replace lang/lua with the new lang/lua51
lang/lua51 is working the same way lang/lua52, chase ports using lua 5.1 Make the default lua lua52 Make all lua ports using USES=lua Approved by: portmgr (implicit)
Diffstat (limited to 'www')
-rw-r--r--www/apache24/Makefile3
-rw-r--r--www/elinks/Makefile2
-rw-r--r--www/lighttpd/Makefile4
-rw-r--r--www/luakit/Makefile3
4 files changed, 5 insertions, 7 deletions
diff --git a/www/apache24/Makefile b/www/apache24/Makefile
index 36e1c3f095bc..0ed702bd2887 100644
--- a/www/apache24/Makefile
+++ b/www/apache24/Makefile
@@ -113,8 +113,7 @@ MAKE_ENV+= EXPR_COMPAT=yes \
# here we do only OPTIONS fixups
.if ${PORT_OPTIONS:MLUA}
-USE_LUA= 5.1+
-LUA_COMPS= lua
+USES+= lua:51
.endif
.if ${PORT_OPTIONS:MPROXY_HTML} || ${PORT_OPTIONS:MXML2ENC}
diff --git a/www/elinks/Makefile b/www/elinks/Makefile
index ce3e8145fb9b..06b76bfdecac 100644
--- a/www/elinks/Makefile
+++ b/www/elinks/Makefile
@@ -62,7 +62,7 @@ CONFIGURE_ARGS+= --without-guile
.endif
.if ${PORT_OPTIONS:MLUA}
-USE_LUA= 5.0
+USES= lua:51
CONFIGURE_ARGS+= --with-lua
CPPFLAGS+= -I${LUA_INCDIR}
LDFLAGS+= -L${LUA_LIBDIR}
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index cef0da7c711f..70865ef18eca 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -113,9 +113,9 @@ LIB_DEPENDS+= libev.so:${PORTSDIR}/devel/libev
.endif
.if ${PORT_OPTIONS:MLUA}
-USE_LUA= 5.1
+USES= lua:51
CONFIGURE_ARGS+= --with-lua
-CONFIGURE_ENV+= LUA_CFLAGS="-I${LUA_INCDIR}" LUA_LIBS="-L${LUA_LIBDIR} -llua"
+CONFIGURE_ENV+= LUA_CFLAGS="-I${LUA_INCDIR}" LUA_LIBS="-L${LUA_LIBDIR} -llua-${LUA_VER}"
.endif
.if ${PORT_OPTIONS:MMEMCACHE}
diff --git a/www/luakit/Makefile b/www/luakit/Makefile
index d16ded0834e5..119a1a87e4a4 100644
--- a/www/luakit/Makefile
+++ b/www/luakit/Makefile
@@ -24,9 +24,8 @@ GH_PROGECT= ${PORTNAME}
GH_TAGNAME= ${PORTVERSION:C/r/-r/}
GH_COMMIT= 0d5f4ab
-USES= pkgconfig gmake
+USES= pkgconfig gmake lua:51
USE_GNOME= glib20 gtk20
-USE_LUA= 5.1
MAKE_ARGS+= USE_UNIQUE=1 NO_JAVASCRIPTCORE=1
MAN1= luakit.1