aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2012-04-24 07:32:13 +0800
committerdelphij <delphij@FreeBSD.org>2012-04-24 07:32:13 +0800
commitebc30d74848836607c9b793e11b26cdc931b3371 (patch)
tree6be9d59b37cd854e9ae422d571ac9dbff02068dc /www
parentdd00514bf22323c87df3487018f8de4b2e69e530 (diff)
downloadfreebsd-ports-gnome-ebc30d74848836607c9b793e11b26cdc931b3371.tar.gz
freebsd-ports-gnome-ebc30d74848836607c9b793e11b26cdc931b3371.tar.zst
freebsd-ports-gnome-ebc30d74848836607c9b793e11b26cdc931b3371.zip
Update to 2012-01-25a to fix a CSRF vulnerability.
Noticed by: eadler
Diffstat (limited to 'www')
-rw-r--r--www/dokuwiki/Makefile1
-rw-r--r--www/dokuwiki/files/patch-2012-01-25-to-2012-01-25a27
2 files changed, 28 insertions, 0 deletions
diff --git a/www/dokuwiki/Makefile b/www/dokuwiki/Makefile
index 08d36930896a..26bf28d09803 100644
--- a/www/dokuwiki/Makefile
+++ b/www/dokuwiki/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dokuwiki
PORTVERSION= ${DIST_VER:S/${PORTNAME}//:S/-//g}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.splitbrain.org/_media/projects/dokuwiki/ \
LOCAL/chinsan/${PORTNAME}
diff --git a/www/dokuwiki/files/patch-2012-01-25-to-2012-01-25a b/www/dokuwiki/files/patch-2012-01-25-to-2012-01-25a
new file mode 100644
index 000000000000..20a107b7853f
--- /dev/null
+++ b/www/dokuwiki/files/patch-2012-01-25-to-2012-01-25a
@@ -0,0 +1,27 @@
+--- ./VERSION.orig 2012-01-25 11:39:35.000000000 -0800
++++ ./VERSION 2012-04-23 16:30:33.214390779 -0700
+@@ -1 +1 @@
+-2012-01-25 "Angua"
++2012-01-25a "Angua"
+--- ./doku.php.orig 2012-01-25 11:39:32.000000000 -0800
++++ ./doku.php 2012-04-23 16:30:33.214390779 -0700
+@@ -7,7 +7,7 @@
+ */
+
+ // update message version
+-$updateVersion = 36;
++$updateVersion = 36.1;
+
+ // xdebug_start_profiling();
+
+--- ./inc/html.php.orig 2012-01-25 11:39:32.000000000 -0800
++++ ./inc/html.php 2012-04-23 16:30:40.813392265 -0700
+@@ -1437,7 +1437,7 @@
+ global $TEXT;
+
+ if ($param['target'] !== 'section') {
+- msg('No editor for edit target ' . $param['target'] . ' found.', -1);
++ msg('No editor for edit target ' . hsc($param['target']) . ' found.', -1);
+ }
+
+ $attr = array('tabindex'=>'1');