aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2010-09-03 21:28:39 +0800
committerosa <osa@FreeBSD.org>2010-09-03 21:28:39 +0800
commited467cc838b39d9af7e10072d29de8d4f664ebf1 (patch)
treeb54d766c729ad6e73ceebf710b3d969660a82739 /www
parentdc845616e7ae743af0bc353d42bf8d3c472a94c9 (diff)
downloadfreebsd-ports-gnome-ed467cc838b39d9af7e10072d29de8d4f664ebf1.tar.gz
freebsd-ports-gnome-ed467cc838b39d9af7e10072d29de8d4f664ebf1.tar.zst
freebsd-ports-gnome-ed467cc838b39d9af7e10072d29de8d4f664ebf1.zip
Install three plain configuration files with -dist prefix.
Do not remove fastcgi_params configuration file, which may carefully edited by the user. Sync DEBUG knob description with www/nginx-devel. Bump PORTREVISION.
Diffstat (limited to 'www')
-rw-r--r--www/nginx/Makefile7
-rw-r--r--www/nginx/pkg-plist4
2 files changed, 7 insertions, 4 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index c849c1516e32..0af5a2c1e8bf 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nginx
PORTVERSION= 0.7.67
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -18,7 +19,7 @@ COMMENT= Robust and small WWW server
LICENSE= BSD
-OPTIONS= DEBUG "Build with debug" off \
+OPTIONS= DEBUG "Enable nginx debugging" off \
DEBUGLOG "Enable debug log (--with-debug)" off \
IPV6 "Enable IPv6" off \
GOOGLE_PERFTOOLS "Enable google perftools module" off \
@@ -490,10 +491,10 @@ do-install:
${MKDIR} ${ETCDIR} ${NGINX_TMPDIR}
${CHOWN} ${WWWOWN}:${WWWGRP} ${NGINX_TMPDIR}
${INSTALL_PROGRAM} ${WRKSRC}/objs/nginx ${PREFIX}/sbin
-.for i in koi-win koi-utf win-utf fastcgi_params
+.for i in koi-utf koi-win win-utf
${INSTALL_DATA} ${WRKSRC}/conf/${i} ${ETCDIR}
.endfor
-.for i in mime.types nginx.conf
+.for i in fastcgi_params mime.types nginx.conf
[ -f ${ETCDIR}/${i} ] || \
${INSTALL_DATA} ${WRKSRC}/conf/${i} ${ETCDIR}
${INSTALL_DATA} ${WRKSRC}/conf/${i} ${ETCDIR}/${i}-dist
diff --git a/www/nginx/pkg-plist b/www/nginx/pkg-plist
index a7e17fd87740..aca447f49243 100644
--- a/www/nginx/pkg-plist
+++ b/www/nginx/pkg-plist
@@ -1,5 +1,7 @@
@comment $FreeBSD$
-%%ETCDIR%%/fastcgi_params
+@unexec if cmp -s %D/%%ETCDIR%%/fastcgi_params-dist %D/%%ETCDIR%%/fastcgi_params; then rm -f %D/%%ETCDIR%%/fastcgi_params; fi
+%%ETCDIR%%/fastcgi_params-dist
+@exec if [ ! -f %D/%%ETCDIR%%/fastcgi_params ] ; then cp -p %D/%F %B/fastcgi_params; fi
%%ETCDIR%%/koi-utf
%%ETCDIR%%/koi-win
%%ETCDIR%%/win-utf