aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2013-01-22 08:58:34 +0800
committerkuriyama <kuriyama@FreeBSD.org>2013-01-22 08:58:34 +0800
commitf48f54cff871d98a6afa1788bf765ccaab796bc2 (patch)
tree8a2d93441fae15dc6626b2de5d3283174b9ee886 /www
parent9a3cd417f2b7c690119931d675ab1ac838214da4 (diff)
downloadfreebsd-ports-gnome-f48f54cff871d98a6afa1788bf765ccaab796bc2.tar.gz
freebsd-ports-gnome-f48f54cff871d98a6afa1788bf765ccaab796bc2.tar.zst
freebsd-ports-gnome-f48f54cff871d98a6afa1788bf765ccaab796bc2.zip
This plugin integrates HTTP::MobileAgent and Amon2.
This module adds $c->mobile_agent() method to the context object. The agent class is generated by $c->req. WWW: http://search.cpan.org/dist/Amon2-Plugin-Web-MobileAgent/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Amon2-Plugin-Web-MobileAgent/Makefile38
-rw-r--r--www/p5-Amon2-Plugin-Web-MobileAgent/distinfo2
-rw-r--r--www/p5-Amon2-Plugin-Web-MobileAgent/pkg-descr6
-rw-r--r--www/p5-Amon2-Plugin-Web-MobileAgent/pkg-plist3
5 files changed, 50 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index af6916470122..7b5d4b13553d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -606,6 +606,7 @@
SUBDIR += p5-Amon2
SUBDIR += p5-Amon2-Lite
SUBDIR += p5-Amon2-Plugin-LogDispatch
+ SUBDIR += p5-Amon2-Plugin-Web-MobileAgent
SUBDIR += p5-Any-Template
SUBDIR += p5-AnyEvent-HTTP
SUBDIR += p5-AnyEvent-HTTP-LWP-UserAgent
diff --git a/www/p5-Amon2-Plugin-Web-MobileAgent/Makefile b/www/p5-Amon2-Plugin-Web-MobileAgent/Makefile
new file mode 100644
index 000000000000..a94b7f3c9cd8
--- /dev/null
+++ b/www/p5-Amon2-Plugin-Web-MobileAgent/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= Amon2-Plugin-Web-MobileAgent
+PORTVERSION= 0.09
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension of HTTP::MobileAgent plugin for Amon2
+
+RUN_DEPENDS= \
+ p5-Amon2>=3.66:${PORTSDIR}/www/p5-Amon2 \
+ ja-p5-Encode-JP-Mobile>=0.29:${PORTSDIR}/japanese/p5-Encode-JP-Mobile \
+ p5-HTTP-MobileAgent>0:${PORTSDIR}/www/p5-HTTP-MobileAgent \
+ p5-HTTP-MobileAgent-Plugin-Charset>0:${PORTSDIR}/www/p5-HTTP-MobileAgent-Plugin-Charset \
+ p5-Lingua-JA-Regular-Unicode>0:${PORTSDIR}/japanese/p5-Lingua-JA-Regular-Unicode
+BUILD_DEPENDS= ${RUN_DEPENDS}
+TEST_DEPENDS= \
+ p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires \
+ p5-Tiffany>0:${PORTSDIR}/textproc/p5-Tiffany \
+ p5-Amon2-DBI>0:${PORTSDIR}/databases/p5-Amon2-DBI \
+ p5-LWP-Protocol-PSGI>0:${PORTSDIR}/www/p5-LWP-Protocol-PSGI \
+ p5-HTML-FillInForm-Lite>0:${PORTSDIR}/www/p5-HTML-FillInForm-Lite \
+ p5-HTTP-Session>0:${PORTSDIR}/www/p5-HTTP-Session \
+ p5-Plack-Middleware-ReverseProxy>0:${PORTSDIR}/www/p5-Plack-Middleware-ReverseProxy \
+ p5-Test-WWW-Mechanize-PSGI>0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize-PSGI \
+ p5-DBD-SQLite>0:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-String-CamelCase>0:${PORTSDIR}/textproc/p5-String-CamelCase \
+ p5-Module-Find>0:${PORTSDIR}/devel/p5-Module-Find
+
+PERL_MODBUILD= yes
+
+MAN3= Amon2::Plugin::Web::MobileAgent.3 \
+ Amon2::Plugin::Web::MobileCharset.3 \
+ Amon2::Setup::Flavor::MobileJP.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Amon2-Plugin-Web-MobileAgent/distinfo b/www/p5-Amon2-Plugin-Web-MobileAgent/distinfo
new file mode 100644
index 000000000000..b105051104cd
--- /dev/null
+++ b/www/p5-Amon2-Plugin-Web-MobileAgent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Amon2-Plugin-Web-MobileAgent-0.09.tar.gz) = 072bd805376c10c64384d016818c46b132c8cd4cb0d7488831996c7ee87b2bda
+SIZE (Amon2-Plugin-Web-MobileAgent-0.09.tar.gz) = 17704
diff --git a/www/p5-Amon2-Plugin-Web-MobileAgent/pkg-descr b/www/p5-Amon2-Plugin-Web-MobileAgent/pkg-descr
new file mode 100644
index 000000000000..a639c82f0808
--- /dev/null
+++ b/www/p5-Amon2-Plugin-Web-MobileAgent/pkg-descr
@@ -0,0 +1,6 @@
+This plugin integrates HTTP::MobileAgent and Amon2.
+
+This module adds $c->mobile_agent() method to the context object. The
+agent class is generated by $c->req.
+
+WWW: http://search.cpan.org/dist/Amon2-Plugin-Web-MobileAgent/
diff --git a/www/p5-Amon2-Plugin-Web-MobileAgent/pkg-plist b/www/p5-Amon2-Plugin-Web-MobileAgent/pkg-plist
new file mode 100644
index 000000000000..8e0085222332
--- /dev/null
+++ b/www/p5-Amon2-Plugin-Web-MobileAgent/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Amon2/Plugin/Web/MobileAgent.pm
+%%SITE_PERL%%/Amon2/Plugin/Web/MobileCharset.pm
+%%SITE_PERL%%/Amon2/Setup/Flavor/MobileJP.pm