aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2010-10-26 15:55:03 +0800
committerbeat <beat@FreeBSD.org>2010-10-26 15:55:03 +0800
commit002fb6a1ecb8769bf564df32db96f3e59457a5f5 (patch)
tree2f3bb8f6c1a2c439ec524f84564e95455840708a /www
parentb37e1abe2e2a8afe8114a5ca05f8a4c5c75cf755 (diff)
downloadfreebsd-ports-gnome-002fb6a1ecb8769bf564df32db96f3e59457a5f5.tar.gz
freebsd-ports-gnome-002fb6a1ecb8769bf564df32db96f3e59457a5f5.tar.zst
freebsd-ports-gnome-002fb6a1ecb8769bf564df32db96f3e59457a5f5.zip
- Fix crash destroying stream in OSS sydneyaudio backend
- Bump PORTREVISION PR: ports/151728 Submitted by: Ilya A. Arhipov <pa36ouHu4er AT yandex.ru> Obtained from: Mozilla Bugzilla ID 562488
Diffstat (limited to 'www')
-rw-r--r--www/firefox-esr/Makefile1
-rw-r--r--www/firefox-esr/files/patch-media-libsydneyaudio-src-sydney_audio_oss.c33
-rw-r--r--www/firefox/Makefile1
-rw-r--r--www/firefox/files/patch-media-libsydneyaudio-src-sydney_audio_oss.c33
-rw-r--r--www/firefox36/Makefile1
-rw-r--r--www/firefox36/files/patch-media-libsydneyaudio-src-sydney_audio_oss.c33
6 files changed, 102 insertions, 0 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 9f737f1f6534..5fd269729185 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
DISTVERSION= 3.6.11
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
diff --git a/www/firefox-esr/files/patch-media-libsydneyaudio-src-sydney_audio_oss.c b/www/firefox-esr/files/patch-media-libsydneyaudio-src-sydney_audio_oss.c
new file mode 100644
index 000000000000..66ce3efd66d3
--- /dev/null
+++ b/www/firefox-esr/files/patch-media-libsydneyaudio-src-sydney_audio_oss.c
@@ -0,0 +1,33 @@
+--- media/libsydneyaudio/src/sydney_audio_oss.c.orig 2010-10-12 21:45:53.000000000 +0400
++++ media/libsydneyaudio/src/sydney_audio_oss.c 2010-10-25 23:33:08.919096567 +0400
+@@ -258,6 +258,7 @@
+ int
+ sa_stream_destroy(sa_stream_t *s) {
+ int result = SA_SUCCESS;
++ pthread_t thread_id;
+
+ if (s == NULL) {
+ return SA_SUCCESS;
+@@ -265,8 +266,10 @@
+
+ pthread_mutex_lock(&s->mutex);
+
++ thread_id = s->thread_id;
++
+ /*
+- * This causes the thread sending data to ALSA to stop
++ * This causes the thread sending data to OSS to stop
+ */
+ s->thread_id = 0;
+
+@@ -281,6 +284,8 @@
+
+ pthread_mutex_unlock(&s->mutex);
+
++ pthread_join(thread_id, NULL);
++
+ /*
+ * Release resources.
+ */
+
+
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 9f737f1f6534..5fd269729185 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
DISTVERSION= 3.6.11
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
diff --git a/www/firefox/files/patch-media-libsydneyaudio-src-sydney_audio_oss.c b/www/firefox/files/patch-media-libsydneyaudio-src-sydney_audio_oss.c
new file mode 100644
index 000000000000..66ce3efd66d3
--- /dev/null
+++ b/www/firefox/files/patch-media-libsydneyaudio-src-sydney_audio_oss.c
@@ -0,0 +1,33 @@
+--- media/libsydneyaudio/src/sydney_audio_oss.c.orig 2010-10-12 21:45:53.000000000 +0400
++++ media/libsydneyaudio/src/sydney_audio_oss.c 2010-10-25 23:33:08.919096567 +0400
+@@ -258,6 +258,7 @@
+ int
+ sa_stream_destroy(sa_stream_t *s) {
+ int result = SA_SUCCESS;
++ pthread_t thread_id;
+
+ if (s == NULL) {
+ return SA_SUCCESS;
+@@ -265,8 +266,10 @@
+
+ pthread_mutex_lock(&s->mutex);
+
++ thread_id = s->thread_id;
++
+ /*
+- * This causes the thread sending data to ALSA to stop
++ * This causes the thread sending data to OSS to stop
+ */
+ s->thread_id = 0;
+
+@@ -281,6 +284,8 @@
+
+ pthread_mutex_unlock(&s->mutex);
+
++ pthread_join(thread_id, NULL);
++
+ /*
+ * Release resources.
+ */
+
+
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index 9f737f1f6534..5fd269729185 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
DISTVERSION= 3.6.11
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
diff --git a/www/firefox36/files/patch-media-libsydneyaudio-src-sydney_audio_oss.c b/www/firefox36/files/patch-media-libsydneyaudio-src-sydney_audio_oss.c
new file mode 100644
index 000000000000..66ce3efd66d3
--- /dev/null
+++ b/www/firefox36/files/patch-media-libsydneyaudio-src-sydney_audio_oss.c
@@ -0,0 +1,33 @@
+--- media/libsydneyaudio/src/sydney_audio_oss.c.orig 2010-10-12 21:45:53.000000000 +0400
++++ media/libsydneyaudio/src/sydney_audio_oss.c 2010-10-25 23:33:08.919096567 +0400
+@@ -258,6 +258,7 @@
+ int
+ sa_stream_destroy(sa_stream_t *s) {
+ int result = SA_SUCCESS;
++ pthread_t thread_id;
+
+ if (s == NULL) {
+ return SA_SUCCESS;
+@@ -265,8 +266,10 @@
+
+ pthread_mutex_lock(&s->mutex);
+
++ thread_id = s->thread_id;
++
+ /*
+- * This causes the thread sending data to ALSA to stop
++ * This causes the thread sending data to OSS to stop
+ */
+ s->thread_id = 0;
+
+@@ -281,6 +284,8 @@
+
+ pthread_mutex_unlock(&s->mutex);
+
++ pthread_join(thread_id, NULL);
++
+ /*
+ * Release resources.
+ */
+
+