aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-05-03 10:27:37 +0800
committermiwi <miwi@FreeBSD.org>2010-05-03 10:27:37 +0800
commit0051288eb00d1b45555f22d066ba06f82a6313cd (patch)
tree631b55cf4e002d585dbae221c90d2c9794048b9a /www
parentab3e52d597dd5ace3354444a6a291ffd47757293 (diff)
downloadfreebsd-ports-gnome-0051288eb00d1b45555f22d066ba06f82a6313cd.tar.gz
freebsd-ports-gnome-0051288eb00d1b45555f22d066ba06f82a6313cd.tar.zst
freebsd-ports-gnome-0051288eb00d1b45555f22d066ba06f82a6313cd.zip
- integrate a patch for squid bug 2899 that could cause compilation
issues on certain platforms PR: 146242 Submitted by: Thomas-Martin Seck <tmseck@web.de> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/squid30/Makefile2
-rw-r--r--www/squid30/files/patch-lib-rfc1738.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index 15edce072fb5..5b3f32a33d26 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -61,7 +61,7 @@
PORTNAME= squid
PORTVERSION= 3.0.${SQUID_STABLE_VER}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
http://mirrors.ccs.neu.edu/Squid/ \
diff --git a/www/squid30/files/patch-lib-rfc1738.c b/www/squid30/files/patch-lib-rfc1738.c
new file mode 100644
index 000000000000..c1e4e1ca13d4
--- /dev/null
+++ b/www/squid30/files/patch-lib-rfc1738.c
@@ -0,0 +1,12 @@
+--- lib/rfc1738.c.orig 2010-04-16 14:36:23.000000000 +0200
++++ lib/rfc1738.c 2010-04-16 14:37:11.000000000 +0200
+@@ -203,8 +203,7 @@ rfc1738_unescape(char *s)
+ j++; /* Skip % */
+ } else {
+ /* decode */
+- char v1, v2;
+- int x;
++ int v1, v2, x;
+ v1 = fromhex(s[j + 1]);
+ if (v1 < 0)
+ continue; /* non-hex or \0 */