aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorseanc <seanc@FreeBSD.org>2003-02-07 10:44:21 +0800
committerseanc <seanc@FreeBSD.org>2003-02-07 10:44:21 +0800
commit029b18cf87aedbf71e33f8d866f6df8c14ff7289 (patch)
tree2315898546b50fdde5fb0c2b3b87a246f37d3136 /www
parent1f6ee4fb3acab07e5bf5542a77600b7f2b044939 (diff)
downloadfreebsd-ports-gnome-029b18cf87aedbf71e33f8d866f6df8c14ff7289.tar.gz
freebsd-ports-gnome-029b18cf87aedbf71e33f8d866f6df8c14ff7289.tar.zst
freebsd-ports-gnome-029b18cf87aedbf71e33f8d866f6df8c14ff7289.zip
Correct ports that were abusing the FORBIDDEN variable and replace with
either IGNORE or BROKEN. Since there seems to be some confusion, for the record: BROKEN is reserved for ports that don't work. This will prevent users from installing the port, but please note that ports marked as BROKEN will still be built by bento IGNORE is reserved for ports that should not be built for one reason or another (including bento). Users and bento will not build ports marked as IGNORE. FORBIDDEN is reserved for security breakages only!!! Only mark a port as FORBIDDEN if there is a security issue with the port at the time. Reviewed by: kris (portmgr)
Diffstat (limited to 'www')
-rw-r--r--www/dansguardian/Makefile2
-rw-r--r--www/roxen/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/www/dansguardian/Makefile b/www/dansguardian/Makefile
index c8f40f6a0a13..c5595fed9489 100644
--- a/www/dansguardian/Makefile
+++ b/www/dansguardian/Makefile
@@ -42,7 +42,7 @@ NO_PACKAGE= "Redistribution is restricted. Check ${DG_URL} for more info"
.include <bsd.port.pre.mk>
.if !(exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}))
-FORBIDDEN="Commercial source download is restricted. Please visit and read ${DG_URL} and download ${DISTNAME}${EXTRACT_SUFX} into ${DISTDIR} before running make"
+IGNORE= "Commercial source download is restricted. Please visit and read ${DG_URL} and download ${DISTNAME}${EXTRACT_SUFX} into ${DISTDIR} before running make"
.endif
post-install:
diff --git a/www/roxen/Makefile b/www/roxen/Makefile
index 47d2b926b2ea..808300c8158f 100644
--- a/www/roxen/Makefile
+++ b/www/roxen/Makefile
@@ -37,7 +37,7 @@ post-install:
.include <bsd.port.pre.mk>
.if defined(PARALLEL_PACKAGE_BUILD) && ${OSVERSION} >= 500000
-FORBIDDEN= hang
+IGNORE= hang
.endif
.include <bsd.port.post.mk>