aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-04-01 06:20:42 +0800
committermiwi <miwi@FreeBSD.org>2009-04-01 06:20:42 +0800
commit0f1003151ca3bf8be0374ad857c809c56d439438 (patch)
tree010e794d873f8bb79c6f6bd1b333231cf4f6d25a /www
parent930f1d9bf6abd6de150299489d6d972e190d167d (diff)
downloadfreebsd-ports-gnome-0f1003151ca3bf8be0374ad857c809c56d439438.tar.gz
freebsd-ports-gnome-0f1003151ca3bf8be0374ad857c809c56d439438.tar.zst
freebsd-ports-gnome-0f1003151ca3bf8be0374ad857c809c56d439438.zip
- The squid_kerb_auth helper needs to know about the endianness of the system
at compile time. Its author suggests to use -D__LITTLE_ENDIAN__ in the program's Makefile and this is the solution proposed in ports/131878. Since FreeBSD (and FreeBSD ports) might be used on big-endian architectures as well as on little endian architectures I decided to instrument an already present endianness check directly in the affected source file instead. - Bump PORTREVISION since this affects the content (and functionality) of the port's binary package. Pr: 133159 Submitted by: Thomas-Martin Seck <tmseck@web.de> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/squid/Makefile1
-rw-r--r--www/squid/files/patch-squid_kerb_auth22
-rw-r--r--www/squid30/Makefile1
-rw-r--r--www/squid30/files/patch-squid_kerb_auth22
-rw-r--r--www/squid31/Makefile1
-rw-r--r--www/squid31/files/patch-squid_kerb_auth22
6 files changed, 69 insertions, 0 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 7b83aab36862..cb99077a6395 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -76,6 +76,7 @@
PORTNAME= squid
PORTVERSION= 2.7.${SQUID_STABLE_VER}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
ftp://mirrors.24-7-solutions.net/pub/squid/%SUBDIR%/ \
diff --git a/www/squid/files/patch-squid_kerb_auth b/www/squid/files/patch-squid_kerb_auth
index 6b9a57b8caf3..2dd3353b6e05 100644
--- a/www/squid/files/patch-squid_kerb_auth
+++ b/www/squid/files/patch-squid_kerb_auth
@@ -557,3 +557,25 @@ ports framework where Heimdal is part of the base system.
#define gss_nt_service_name GSS_C_NT_HOSTBASED_SERVICE
#else
#include <gssapi/gssapi.h>
+--- helpers/negotiate_auth/squid_kerb_auth/spnegohelp/derparse.c.orig 2007-05-15 01:36:32.000000000 +0200
++++ helpers/negotiate_auth/squid_kerb_auth/spnegohelp/derparse.c 2009-03-28 17:21:54.000000000 +0100
+@@ -22,12 +22,19 @@
+ //
+ /////////////////////////////////////////////////////////////
+
++#include "config.h"
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <memory.h>
+ #include "spnego.h"
+ #include "derparse.h"
+
++#ifdef WORDS_BIGENDIAN
++#undef __LITTLE_ENDIAN__
++#else
++#define __LITTLE_ENDIAN__ 1
++#endif
++
+ //
+ // The GSS Mechanism OID enumeration values (SPNEGO_MECH_OID) control which offset in
+ // the array below, that a mechanism can be found.
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index a01c18a83aa7..0558907742a3 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -61,6 +61,7 @@
PORTNAME= squid
PORTVERSION= 3.0.${SQUID_STABLE_VER}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
ftp://mirrors.24-7-solutions.net/pub/squid/%SUBDIR%/ \
diff --git a/www/squid30/files/patch-squid_kerb_auth b/www/squid30/files/patch-squid_kerb_auth
index 359bc6f68ca2..371db4eaa383 100644
--- a/www/squid30/files/patch-squid_kerb_auth
+++ b/www/squid30/files/patch-squid_kerb_auth
@@ -466,3 +466,25 @@ ports framework where Heimdal is part of the base system.
#define gss_nt_service_name GSS_C_NT_HOSTBASED_SERVICE
#else
#include <gssapi/gssapi.h>
+--- helpers/negotiate_auth/squid_kerb_auth/spnegohelp/derparse.c.orig 2009-03-28 17:01:45.000000000 +0100
++++ helpers/negotiate_auth/squid_kerb_auth/spnegohelp/derparse.c 2009-03-28 17:06:55.000000000 +0100
+@@ -22,12 +22,19 @@
+ //
+ /////////////////////////////////////////////////////////////
+
++#include "config.h"
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <memory.h>
+ #include "spnego.h"
+ #include "derparse.h"
+
++#ifdef WORDS_BIGENDIAN
++#undef __LITTLE_ENDIAN__
++#else
++#define __LITTLE_ENDIAN__ 1
++#endif
++
+ //
+ // The GSS Mechanism OID enumeration values (SPNEGO_MECH_OID) control which offset in
+ // the array below, that a mechanism can be found.
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index a01c18a83aa7..0558907742a3 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -61,6 +61,7 @@
PORTNAME= squid
PORTVERSION= 3.0.${SQUID_STABLE_VER}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
ftp://mirrors.24-7-solutions.net/pub/squid/%SUBDIR%/ \
diff --git a/www/squid31/files/patch-squid_kerb_auth b/www/squid31/files/patch-squid_kerb_auth
index 359bc6f68ca2..371db4eaa383 100644
--- a/www/squid31/files/patch-squid_kerb_auth
+++ b/www/squid31/files/patch-squid_kerb_auth
@@ -466,3 +466,25 @@ ports framework where Heimdal is part of the base system.
#define gss_nt_service_name GSS_C_NT_HOSTBASED_SERVICE
#else
#include <gssapi/gssapi.h>
+--- helpers/negotiate_auth/squid_kerb_auth/spnegohelp/derparse.c.orig 2009-03-28 17:01:45.000000000 +0100
++++ helpers/negotiate_auth/squid_kerb_auth/spnegohelp/derparse.c 2009-03-28 17:06:55.000000000 +0100
+@@ -22,12 +22,19 @@
+ //
+ /////////////////////////////////////////////////////////////
+
++#include "config.h"
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <memory.h>
+ #include "spnego.h"
+ #include "derparse.h"
+
++#ifdef WORDS_BIGENDIAN
++#undef __LITTLE_ENDIAN__
++#else
++#define __LITTLE_ENDIAN__ 1
++#endif
++
+ //
+ // The GSS Mechanism OID enumeration values (SPNEGO_MECH_OID) control which offset in
+ // the array below, that a mechanism can be found.